Bug 12451 - switching to VT: Segfault in xkb/xkbUtils.c causes system freeze
Summary: switching to VT: Segfault in xkb/xkbUtils.c causes system freeze
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: x86 (IA32) All
: medium critical
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL: http://lists.freedesktop.org/archives...
Whiteboard:
Keywords:
Depends on:
Blocks: xorg-7.4
  Show dependency treegraph
 
Reported: 2007-09-17 00:26 UTC by Willi Mann
Modified: 2008-05-06 23:20 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Backtrace of the segfault (5.06 KB, text/plain)
2007-09-17 00:35 UTC, Willi Mann
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Willi Mann 2007-09-17 00:26:22 UTC
When I switch to VT, I get a system freeze. The hardware is Intel Corporation 82852/855GM, more details at the URL.

I'll attach a backtrace.
Comment 1 Willi Mann 2007-09-17 00:35:47 UTC
Created attachment 11597 [details]
Backtrace of the segfault

Backtrace + the value of xkbi->desc, which is NULL. I forgot to mention that I use the debian package of xorg server, of experimental, which is version 1.4,recompiled with -O0

Note that the only 100% way to reproduce this bug is to play a video (with xv) before switching to VT, but it sometimes occurs without playing a video before (Maybe that's a different bug then, as I have not taken stacktraces of that faults). This bug might be related to Bug 12437.
Comment 2 Willi Mann 2007-09-21 00:21:25 UTC
As the bug occurs in some keyboard-related code: No matter whether NUM is enabled or disabled under X, the LED on my keyboard is off. It is on as soon as I switch to VT (unless it crashes). This also applies to CAPS-LOCK. 

However, the internal state is preserved, as THESE THREE WORDS are written with CAPS-LOCK enabled.
Comment 3 Peter Hutterer 2008-04-22 01:19:56 UTC
(In reply to comment #2)
> As the bug occurs in some keyboard-related code: No matter whether NUM is
> enabled or disabled under X, the LED on my keyboard is off. It is on as soon as
> I switch to VT (unless it crashes). This also applies to CAPS-LOCK. 
> 
> However, the internal state is preserved, as THESE THREE WORDS are written with
> CAPS-LOCK enabled.
> 

Willi:
Can you please try with a recent X server. The xkb code has improved since and I can't reproduce your problem with the current version. If it still occurs,  please attach your log file.
Comment 4 Willi Mann 2008-04-22 08:18:11 UTC
I can't reproduce it anymore, as all the xv related issues have been resolved for me. 

I have another crash bug (on context switch) which occurs very seldomly that might be related to this bug, but I haven't had yet time to really investigate it. 
Comment 5 Peter Hutterer 2008-04-29 05:46:12 UTC
(In reply to comment #4)
> I can't reproduce it anymore, as all the xv related issues have been resolved
> for me. 
> 
> I have another crash bug (on context switch) which occurs very seldomly that
> might be related to this bug, but I haven't had yet time to really investigate
> it. 
> 

actually, since this bug is marked as a blocker for server 1.5 - are you able to test the server-1.5-branch as well?
If you can't reproduce it, I guess we can mark it as closed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.