Bug 12555 (daven) - [945GM] hang during VT switch
Summary: [945GM] hang during VT switch
Status: RESOLVED FIXED
Alias: daven
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium critical
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 13027
  Show dependency treegraph
 
Reported: 2007-09-24 17:34 UTC by Dave Noble
Modified: 2007-11-12 13:18 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dave Noble 2007-09-24 17:34:59 UTC
When changing video terminals using chvt; or ctrl+alt F(1-8), after two changes in close succession (about 15 seconds), the entire system locks up, including SSH sessions into the machine. I have a feeling that this may also be responsible for the lockups sometimes experienced when suspending/resuming; however, due to the fact that these take longer to reproduce, are less of a common occurrence and are extremely inconvenient.

I have marked the bug as critical, as with unsynced filesystems, a crash caused by something that could be invoked by "Fast User Switching" as implemented under various large desktop environments (gnome, kde et al.), it could cause (and has caused) user data loss.

I am running X Window System version 1.3.0 on a Lenovo/IBM Thinkpad X60s (it uses an Intel GMA950 chip). I am using only the internal display. Please find my configuration here: http://mrdaven.mine.nu/bugreport/xorg-25092007/xorg.conf and the log here: http://mrdaven.mine.nu/bugreport/xorg-25092007/xorg.log although I fear that this file will be somewhat useless, as it doesn't catch the failure when it crashes due to the hard drives not being synced. I will post again next occurence if I get better logs.

I will also in the meanwhile upgrade to version 1.4.0; assuming something similar may have already been fixed.
Comment 1 Bryce Harrington 2007-09-28 19:34:33 UTC
This sounds vaguely similar to the following Ubuntu bug, that was fixed today:

https://bugs.launchpad.net/ubuntu/+bug/127101

Might be worth looking at in case it's the same bug.
Comment 2 Jesse Barnes 2007-10-31 12:34:22 UTC
Dave, can you try the latest drivers from git?  We've fixed several VT switch problems recently, hopefully including yours.
Comment 3 Jesse Barnes 2007-11-12 13:18:52 UTC
I think Bryce is right that this bug has been fixed, so I'm going to close it out.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.