Bug 12610 - Pressing some keys don't fire KeyPress event
Summary: Pressing some keys don't fire KeyPress event
Status: RESOLVED WORKSFORME
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Daniel Stone
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-09-28 07:02 UTC by Lukasz Krotowski
Modified: 2007-09-28 08:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.52 KB, text/plain)
2007-09-28 07:03 UTC, Lukasz Krotowski
no flags Details
Xorg.0.log (45.37 KB, text/plain)
2007-09-28 07:04 UTC, Lukasz Krotowski
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Lukasz Krotowski 2007-09-28 07:02:58 UTC
When using xserver from git (dc37f91d94b1b580f589cefe40630017bb4d8bb8 from branch no-pci-rework) keys: 1, 4, 7, 8, 9, -, =, BackSpace don't fire KeyPress when pressed. Xev reports that KeyPress is fired on releasing (with KeyRelease event). Xserver-1.4 works fine.
Comment 1 Lukasz Krotowski 2007-09-28 07:03:38 UTC
Created attachment 11800 [details]
xorg.conf
Comment 2 Lukasz Krotowski 2007-09-28 07:04:11 UTC
Created attachment 11801 [details]
Xorg.0.log
Comment 3 Daniel Stone 2007-09-28 07:45:00 UTC
Bizzare.  Could you please git bisect it?
Comment 4 Lukasz Krotowski 2007-09-28 08:12:17 UTC
Bizarre indeed (when using EXA broken keys are different), but applying patch: "Fix key repeats during VT switch." (81c28ffd2b13a83770eadcfd7829d35d319d637f) cherry-picked at xorg-server-1.4 branch fixes keys. So I suppose it's just another cherry-pick time. ;)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.