Bug 12630 - paste event when hotplugging mouse
Summary: paste event when hotplugging mouse
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/evdev (show other bugs)
Version: 7.3 (2007.09)
Hardware: Other All
: medium normal
Assignee: Zephaniah E. Hull
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 15607 (view as bug list)
Depends on:
Blocks:
 
Reported: 2007-09-30 10:54 UTC by Julien Cristau
Modified: 2008-04-19 05:59 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (1.24 KB, text/plain)
2007-09-30 10:54 UTC, Julien Cristau
no flags Details
Xorg.0.log (88.30 KB, text/plain)
2007-09-30 10:55 UTC, Julien Cristau
no flags Details
input devices from lshal (3.70 KB, text/plain)
2007-09-30 10:58 UTC, Julien Cristau
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Julien Cristau 2007-09-30 10:54:03 UTC
i'm using input hotplug via hal with xserver 1.4.  when i plug in my usb mouse, the contents of the clipboard are pasted. i'll attach my log, config and the input-related stuff from lshal.
Comment 1 Julien Cristau 2007-09-30 10:54:48 UTC
Created attachment 11830 [details]
xorg.conf
Comment 2 Julien Cristau 2007-09-30 10:55:19 UTC
Created attachment 11831 [details]
Xorg.0.log
Comment 3 Julien Cristau 2007-09-30 10:58:27 UTC
Created attachment 11832 [details]
input devices from lshal
Comment 4 Peter Hutterer 2007-10-01 02:03:07 UTC
just a vague stab in the dark: the evdev driver flushes all buttons on device init (-> sends button release events). could this be the cause?
Comment 5 Daniel Stone 2007-10-01 04:04:03 UTC
(In reply to comment #4)
> just a vague stab in the dark: the evdev driver flushes all buttons on device
> init (-> sends button release events). could this be the cause?

why?
Comment 6 Peter Hutterer 2007-10-02 16:19:39 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > just a vague stab in the dark: the evdev driver flushes all buttons on device
> > init (-> sends button release events). could this be the cause?
> 
> why?
> 

I think it's to make sure that the device doesn't have buttons pressed. And I assume this is a leftover from the evdev-internal hotplugging.
Comment 7 Julien Cristau 2007-10-03 06:13:19 UTC
(In reply to comment #4)
> just a vague stab in the dark: the evdev driver flushes all buttons on device
> init (-> sends button release events). could this be the cause?
> 
removing that flush seems to fix it.  thanks!
Comment 8 Julien Cristau 2007-12-07 08:05:56 UTC
commit eeb3727004327bc4d83192a7956c1835b3bd6161
Author: Julien Cristau <jcristau@debian.org>
Date:   Fri Nov 9 00:38:54 2007 +0100

    Don't flush buttons on init (bug#12630)
Comment 9 Julien Cristau 2008-04-19 05:59:01 UTC
*** Bug 15607 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.