Bug 12666 - Mouse and keyboard inputs dismissed, system hung after showing a tooltip
Summary: Mouse and keyboard inputs dismissed, system hung after showing a tooltip
Status: RESOLVED NOTOURBUG
Alias: None
Product: xorg
Classification: Unclassified
Component: * Other (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86 (IA32) Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-03 10:17 UTC by legolas558
Modified: 2007-10-04 10:40 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf used by legolas558 (12.75 KB, application/octet-stream)
2007-10-03 10:23 UTC, legolas558
no flags Details
Xorg.0.log from the console where I ran startx (37.90 KB, text/plain)
2007-10-03 10:30 UTC, legolas558
no flags Details
Xorg.8.log of the Xorg process (15.71 KB, text/plain)
2007-10-03 10:31 UTC, legolas558
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description legolas558 2007-10-03 10:17:23 UTC
I have recently updated by gentoo-sources to kernel version 2.6.22-r8 (from 2.6.22-r5) and also rebuilt the kernel, xorg-server (now version 1.3.0, released 19 April 2007) and all the correlated packages

==Previous bugs==
Some possibly unrelated bugs regarding the ps2 mouse (synaptics touchpad) and the keyboard have been fixed, they where somewhat related to i8042 multiplexing; just for your information, you can ask more if you think it's related. Sometimes some key events do get processed with delay - and that's very similar to the bug of atkbd.c messages in dmesg that I had before - however keyboard works almost flawlessly (couldnt test it very well in X since I have very little time before XFCE4 hangs).

==The bug==
But now, when I start XFCE4, the system hangs almost instantly if I open up two windows and switch 2-3 times to them using the taskbar buttons (top bar).
The triggering event seems to be the tooltip of buttons. When the tooltip pops up, I can still click once on a taskbar button. At that point, the relative window does not pop up and if I try to switch to it using Alt+Tab or if I click once more on a button of the taskbar, X hangs and no more processes my input.

Animations keep playing, and the bottom bar watch ":" keeps blinking (havent checked if the time elapses, btw).

From that moment, the mouse cursor can be moved around but no click events or keyboard events are caught by X. Progress bars animations still progress, but windows full redrawing never happens (windows do not close themselves after something finishes, for example sending an email). So the system seems on its own, not caring about my input.

I can only switch to a shell terminal and terminate the startx process on the relative terminal using Ctrl+C

The first times I have more chances to be able to switch back to the shell, because if I run again startx and then go back to the shell as explained above, at some point I will no more be able to use Ctrl+Alt+Fn and I will just have to hardly turn off the notebook.

The attachments are relative to the above described situation.

==Summary==
I have just 3-4 chances to be able to use X, and I must be careful at not opening more than 2 windows and not clicking on the taskbar relative buttons, then the system hangs and I will have to shut it down because I cant ever get back to the shell.

I have noticed that if I use /dev/input/mouse0 (legacy mouse) it hardly hangs; instead if I use as InputDevice /dev/input/mice (synaptics-mapped but with "mouse" driver) or the specific synaptics device (with "synaptics" driver), it hangs as explained previously.

==Bug isolation==
Please tell me how to reduce this nasty situation to a clearly identifiable bug.
Comment 1 legolas558 2007-10-03 10:23:32 UTC
Created attachment 11885 [details]
xorg.conf used by legolas558
Comment 2 legolas558 2007-10-03 10:29:41 UTC
==Precisation==
This is what I do to test if the bug is still present:
I open up two windows, for example two text editors, and click on their relative taskbar buttons. At a certain point, the tooltip which comes up will not disappear.
Then, if I click once more, I loose mouse input control.
But keyboard still works! I can do everything except switching to another window (forced mono-tasking?) through Alt+Tab or clicking again on the relative taskbar button. If I try to switch to another window, I loose also keyboard input control and I can only switch to the shell using Ctrl+Alt+Fn (till it works..because at a certain point, it will stop working too).

==Last log line==

On the log (Xorg.0.log, from the console from which I started Xorg), I can see this line:
Synaptics DeviceOff called

Then I push Ctrl+C to quit the process (Xorg.0.log attached)
Comment 3 legolas558 2007-10-03 10:30:27 UTC
Created attachment 11886 [details]
Xorg.0.log from the console where I ran startx
Comment 4 legolas558 2007-10-03 10:31:27 UTC
Created attachment 11887 [details]
Xorg.8.log of the Xorg process
Comment 5 legolas558 2007-10-03 10:42:04 UTC
I can confirm that the clock elapses, so the system is no more getting input. The first to be dismissed is the mouse (even if cursor moves around), then the keyboard.

The keyboard can be still used a few times (between startx sessions) to switch to shell, then it totally becomes dead - like if disconnected (and this is a keyboard integrated on the notebook).

The only noticeable phenomenon regarding the keyboard (till it works), is - as told before - that some keys are processed with a delay. The system does not seem at high CPU usage levels, btw
Comment 6 legolas558 2007-10-04 03:52:01 UTC
A possibly related bug:

https://bugs.launchpad.net/debian/+source/xserver-xorg-video-intel/+bug/127101
Comment 7 legolas558 2007-10-04 04:01:05 UTC
I have been using xf86-video-i810 v2.1.1 when having these troubles; I will now test v1.7.4
Comment 8 legolas558 2007-10-04 04:09:13 UTC
xf86-video-i810 v1.7.4 is not affected; the problem arises with any v2.x

I will forward the information around
Comment 9 legolas558 2007-10-04 04:33:53 UTC
Nothing...it happens with any version of the i810 driver.

It must be related to X's low-level input layer
Comment 10 Daniel Stone 2007-10-04 05:34:51 UTC
If it's input, try just killing the application showing the tooltip.  It's more than likely a hung grab.
Comment 11 legolas558 2007-10-04 06:05:32 UTC
Thanks for the suggestion..however the application would be xfce4-panel
Comment 12 legolas558 2007-10-04 06:18:51 UTC
I am now trying to address this bug here:

http://bugs.gentoo.org/show_bug.cgi?id=194703

I have killed xfce4-panel and I am still working; I will check if it happens even without xfce4-panel
Comment 13 Michel Dänzer 2007-10-04 09:47:02 UTC
Could be http://bugzilla.xfce.org/show_bug.cgi?id=3346 .
Comment 14 legolas558 2007-10-04 10:20:25 UTC
I am now almost sure it is!

I have gtk 2.12; I will now install 2.10 and report here
Comment 15 legolas558 2007-10-04 10:40:34 UTC
I have applied this patch:

http://bugzilla.xfce.org/attachment.cgi?id=1188

and the bug is now gone! :)


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.