Bug 1270 - laptop keyboard doesnt work in x
Summary: laptop keyboard doesnt work in x
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
Depends on:
Reported: 2004-09-01 12:34 UTC by Bret Towe
Modified: 2004-08-31 22:07 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Description Bret Towe 2004-09-01 12:34:30 UTC
i have an emachines m5310 laptop and when i load x the built-in keyboard
doesnt work ive tried various configure options and such nothing seems to
make it work its like its not seeing it all

i can use a usb keyboard without problem but internal even then shows nothing
ive used 'xev' i think it was and it shows nothing at all from the internal keyboard
in console linux keyboard works as it should

there is nothing in the logs that screams fix me
ive had this bug i think since i switched to xorg as i recall
both usb and internal keyboards working in xfree
currently running
didnt work on 6.7.0 

distro is gentoo
no patchs that i can tell mess with keyboard that it includes
ive even recompiled the full system made no difference
compiler is gcc 3.4.1 if that matters

if logs or config are needed just ask and ill attach
Comment 1 Bret Towe 2004-09-01 12:58:32 UTC
for some reason i never tried it before
but the synaptics driver was pointing to wrong event device
changing it to the right event device makes it all better

id change resolve the bug but i dont see idiot user listed...
Comment 2 Adam Jackson 2004-09-01 15:07:28 UTC
configuration error, INVALID.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.