Bug 1276 - tga files sniffed as image/x-icb
Summary: tga files sniffed as image/x-icb
Status: RESOLVED FIXED
Alias: None
Product: shared-mime-info
Classification: Unclassified
Component: freedesktop.org.xml (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Jonathan Blandford
QA Contact:
URL:
Whiteboard:
Keywords:
: 1733 (view as bug list)
Depends on:
Blocks:
 
Reported: 2004-09-02 04:34 UTC by Filip Van Raemdonck
Modified: 2006-02-21 08:54 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Filip Van Raemdonck 2004-09-02 04:34:09 UTC
I changed the application/vnd.lotus-1-2-3 magic string match to:
<match offset="0" type="string"
value="\x00\x00\x02\x00\x06\x04\x06\x00\x08\x00\x00\x00\x00\x00" />
according to the information on
http://www.filext.com/detaillist.php?extdetail=wk1&goButton=Go

I checked with a random .wk1 file I found on
http://www.daniel-hertrich.de/lxgluc/ with the help of google, the magic pattern
is correct.

This might have fixed the problem outlined in
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=245262; however such .tga files
are now detected as image/x-icb :-/
I'll be looking further for another solution to that problem.
Comment 1 Filip Van Raemdonck 2004-09-02 05:11:33 UTC
About the targa || icb problem: after checking image/x-icb is in fact also
listed as "Truevision Targa".
Is there any reason image/x-icb is not an alias for image/x-tga, with simply
.icb as an alternative glob?

BTW. the magic pattern for image/x-icb is also both rather incomplete because
it's too short, and inaccurate because some bytes in the pattern can have
different values for a targa file, and the byte indicating it as an actual ICB
targa file instead of another targa variant is not in the pattern from what I
found in the targa format descriptions.
Comment 2 Christophe Fergeau 2004-11-01 13:22:13 UTC
*** Bug 1733 has been marked as a duplicate of this bug. ***
Comment 3 Christophe Fergeau 2004-11-01 13:26:33 UTC
I committed the lotus 123 magic stuff. I'm keeping this bug open and retitling
it for the tga issue.
Comment 4 Christian - Manny Calavera - Neumair 2006-02-22 03:54:03 UTC
Thanks for your bug report!

I've merged ICB into the TGA MIME type, and added some more extensions.
According to [1], there exist some TGA flavors.

[1] http://netghost.narod.ru/gff/graphics/summary/tga.htm


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.