Bug 12795 - no effective checking pciaccess version when compiling with xserver-1.3
Summary: no effective checking pciaccess version when compiling with xserver-1.3
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: Other All
: medium normal
Assignee: Eric Anholt
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-13 07:42 UTC by Sérgio M. Basto
Modified: 2007-12-04 10:34 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sérgio M. Basto 2007-10-13 07:42:15 UTC
Hi, since commit 126031655c3c1db9881ad17d712461533eb59632 , my i915GM
don't work and recent git stop working at all.
when i915tex has been moved to i915 .
I got on glxinfo: 
libGL error: drmMap of framebuffer failed (Invalid argument)
libGL error: reverting to (slow) indirect rendering
display: :0  screen: 0
direct rendering: No (If you want to find out why, try setting LIBGL_DEBUG=verbose)

And I don't have DRI with Xorg.0.log:
> (WW) intel(0): Removed DRI frontbuffer mapping in compatibility mode.
> (WW) intel(0): DRIGetDeviceInfo will report incorrect frontbuffer
> handle.

Now with latest intel drv git  X don't startup :
once I got this errors:
Oct 11 22:39:35 localhost console-kit-daemon[1979]: GLib-CRITICAL: g_async_queue_push: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Oct 11 22:39:37 localhost console-kit-daemon[1979]: GLib-CRITICAL: g_async_queue_lock: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Oct 11 22:39:37 localhost console-kit-daemon[1979]: GLib-CRITICAL: g_async_queue_length_unlocked: assertion `g_atomic_int_get (&queue->ref_count) > 0' failed
Oct 11 22:39:37 localhost kernel: console-kit-dae[1987]: segfault at 39312d34 eip 002241d7 esp b7ed3340 error 4

but now I don't have errors neither X startup
For me the most strange is nobody complains but me .
Have we something new at building drivers that I am missing ?
Comment 1 Sérgio M. Basto 2007-10-28 22:19:04 UTC
Hi, after many work , I put my system with xorg-server-1.4 and all Xorg 7.4,
and finally I been able to compile latest xor-x11-drv.intel .

I think the drive should warning us to this fact.

with xorg-server 1.3: 
checking whether XSERVER_LIBPCIACCESS is declared... no
checking for PCIACCESS... yes

and badly pass 

with xor-server 1.4:
checking whether XSERVER_LIBPCIACCESS is declared... yes
checking for PCIACCESS... configure: error: Package requirements (pciaccess >=
0.10.0) were not met:

Requested 'pciaccess >= 0.10.0' but version of pciaccess is 0.9.1

Comment 2 Johannes Engel 2007-10-30 06:01:03 UTC
Is there any relation to bug #5714?
Comment 3 Sérgio M. Basto 2007-10-30 07:24:22 UTC
(In reply to comment #2)
> Is there any relation to bug #5714?
> 

I don't know, may be in this bug , this merge require xorg-server >= 1.4 

Comment 4 Eric Anholt 2007-11-30 00:31:38 UTC
comment #1 - yes, you do need updated libpciaccess.
Comment 5 Michael Fu 2007-12-02 18:19:44 UTC
would you please upgrade pciaccess lib and re-test?
Comment 6 Sérgio M. Basto 2007-12-03 09:39:55 UTC
(In reply to comment #5)
> would you please upgrade pciaccess lib and re-test?
> 

I think, I don't explain my self correctly.
The problem is with xorg-server 1.3, no matter the version of LIBPCIACCESS the test pass and perhaps shouldn't pass 
(
checking whether XSERVER_LIBPCIACCESS is declared... no
checking for PCIACCESS... yes
)

Comment 7 Michael Fu 2007-12-03 18:58:20 UTC
I'm a bit of confused , too... so let's get back to the beginning of the question. Is the bug about "glxinfo failure" or "libpciaccess dependency issue during compiling"?

>Hi, after many work , I put my system with xorg-server-1.4 and all Xorg 7.4,
>and finally I been able to compile latest xor-x11-drv.intel .

And, you still can't successfully build the intel driver in this environment, right?
Comment 8 WuNian 2007-12-03 19:47:17 UTC
Did you update kernel module "drm" and libdrm?
Comment 9 Sérgio M. Basto 2007-12-03 20:30:32 UTC
(In reply to comment #7)
> >Hi, after many work , I put my system with xorg-server-1.4 and all Xorg 7.4,
> >and finally I been able to compile latest xor-x11-drv.intel .
> 
> And, you still can't successfully build the intel driver in this environment,
> right?

No , Finally I build xorg-x11-drv.intel , with xorg-server-1.4 and git of libpciaccess

> I'm a bit of confused , too... so let's get back to the beginning of the
> question. Is the bug about "glxinfo failure" or "libpciaccess dependency issue
> during compiling"?

both, may be we can close and forget this bug, because this was when I git pull drm, libdrm, mesa and drv-video-intel with xorg-x11-server 1.3 .

The only thing that remains, in this bug, for me, is the fact that drv-video-intel requires a pciaccess >= 0.10.0 with xorg-x11-server >= 1.4 and don't require with xorg-x11-server <= 1.3 , which could be a little bug.

What I want is the autotools also require pciaccess >= 0.10.0  for older xorg-x11-server, if it require  ok ? else forget it please , and sorry for the noise .



Comment 10 Sérgio M. Basto 2007-12-03 20:37:18 UTC
if we know that new intel drive needs a pciaccess >= 0.10.0 and xorg-x11-server <=1.3 use a version of pciaccess < 0.10.0 , configuration of xf86-drv-intel should stop and require update or xorg-x11-server or pciaccess.
that the point on this bug ok ? 
 
Comment 11 Gordon Jin 2007-12-03 22:15:24 UTC
I'm changing the title to reflect the pciaccess version issue.

Eric, xserver-1.3 is supposed to work with the intel driver git, right? If so, it makes sense to improve the checking mechanism.
Comment 12 Eric Anholt 2007-12-04 10:34:39 UTC
It is not a bug that new libpciaccess is only required for new server.  We can get along fine with old libpciaccess for tools if we don't need libpciaccess for the driver.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.