Bug 12815 - Viewing a page in Konqueror makes X11 unresponsive
Viewing a page in Konqueror makes X11 unresponsive
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/EXA
7.3 (2007.09)
x86 (IA32) Linux (All)
: medium normal
Assigned To: Xorg Project Team
Xorg Project Team
:
: 13207 (view as bug list)
Depends on:
Blocks: xorg-server-1.4.1
  Show dependency treegraph
 
Reported: 2007-10-15 17:23 UTC by William Steve Applegate
Modified: 2007-11-19 08:29 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Full Xorg.0.log (61.42 KB, text/plain)
2007-10-16 14:42 UTC, William Steve Applegate
no flags Details
Backport of fix to server-1.4-branch (750 bytes, patch)
2007-10-18 09:08 UTC, Michel Dänzer
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description William Steve Applegate 2007-10-15 17:23:52 UTC
Executive summary 
~~~~~~~~~~~~~~~~~ 
Upon loading some Web pages in Konqueror, X becomes totally unresponsive (keypresses and mouse buttons aren't honored anymore; the mouse pointer still moves, though), forcing a reboot of the computer. While technically not a crash (the applications apparently continue to run) the end result is exactly the same.

Backtraces
~~~~~~~~~~
None, but see below for a Xorg log that might give some clues as to the origin of the problem.

How To Reproduce 
~~~~~~~~~~~~~~~~ 
  1. Fire up Konqueror
  2. Navigate to <http://www.legifrance.gouv.fr/WAspad/UnTexteDeJorf?numjo=DEVT0761717A>
  3. Konqueror displays the page, but the loading bar freezes at 25%
  4. Mouse clicks and keyboard events are now useless

Expected behaviour 
~~~~~~~~~~~~~~~~~~ 
The page should be loaded, and X11 should keep being usable after loading. This includes responding to user input.

Additional info 
~~~~~~~~~~~~~~~ 
  * OS was Debian Unstable, with kernel 2.6.21-2-k7
  * KDE version used was 3.5.7
  * Upon logging remotely onto the box, I noticed that the Xorg process was using ~90% CPU time
  * The log messages about out-of-order and tossed events (see below) continued to appear everytime I moved/clicked the mouse
  * I was not able to reproduce the bug with another browser; still, the above-mentioned messages seem Xorg-related, according to a Google search. Hence, I'm reporting the bug here. Feel free to advise if you think this is wrong

Xorg.0.log excerpt from the crashed session
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
tossed event which came in late
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
mieqEnequeue: out-of-order valuator event; dropping.
tossed event which came in late
tossed event which came in late

[due to Bugzilla length constraints, I'm not posting the entire Xorg log. If you need it, please tell me]

Complete xorg.conf file (minus leading comments)
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Section "Extensions"
	Option		"Composite"		"Enable"
	Option		"RENDER"		"Enable"
EndSection

Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"CoreKeyboard"
	Option		"XkbRules"		"xorg"
	Option		"XkbModel"		"pc105"
	Option		"XkbLayout"		"fr"
	Option		"XkbVariant"		"latin9"
	Option		"XkbOptions"		"compose:menu"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
	Option		"CorePointer"
	Option		"Device"		"/dev/input/mice"
	Option		"Protocol"		"ImPS/2"
EndSection

Section "Device"
	Identifier	"ATI Technologies Inc RV370 [Radeon X300SE]"
	Driver		"ati"
	BusID		"PCI:1:0:0"
#	Option		"AccelDFS"		"true"
	Option		"AccelMethod"		"EXA"
	Option		"AGPFastWrite"		"true"
	Option		"AGPMode"		"8"
	Option		"AGPSize"		"128"
	Option		"BufferSize"		"2"
	Option		"EnableDepthMoves"	"true"
	Option		"EnablePageFlip"	"true"
#	Option		"FBTexPercent"		"0"
	Option		"GARTSize"		"64"
#	Option		"IgnoreEDID"		"true"
	Option		"mtrr"			"true"
EndSection

Section "Monitor"
	Identifier	"NEC CI VR17"
	Option		"DPMS"
	HorizSync	30-70
	VertRefresh	50-150
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"ATI Technologies Inc RV370 [Radeon X300SE]"
	Monitor		"NEC CI VR17"
	DefaultDepth	24
	SubSection "Display"
		Modes	"1024x768" "800x600" "640x480"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
	InputDevice	"Generic Keyboard"
	InputDevice	"Configured Mouse"
EndSection

Section "DRI"
	Mode		0666
EndSection
Comment 1 Michel Dänzer 2007-10-16 00:25:42 UTC
Please attach (as opposed to paste) the full Xorg.0.log file.
Comment 2 William Steve Applegate 2007-10-16 14:42:03 UTC
Created attachment 12080 [details]
Full Xorg.0.log

Here it is.
Comment 3 Michel Dänzer 2007-10-17 00:00:14 UTC
Does it also happen if you comment out all the driver options except for "AccelMethod" "EXA"?
Comment 4 William Steve Applegate 2007-10-18 06:49:45 UTC
(In reply to comment #3)
> Does it also happen if you comment out all the driver options except for
> "AccelMethod" "EXA"?

Yes, it does.
Comment 5 Michel Dänzer 2007-10-18 09:08:15 UTC
Created attachment 12107 [details] [review]
Backport of fix to server-1.4-branch

This is a backport of the essential part of the fix from the master branch. The other parts are just to save some work in these cases and not strictly necessary to prevent problems like this.
Comment 6 Michel Dänzer 2007-10-18 09:09:34 UTC
Fixed on the master branch, but leaving open and making a blocker for 1.4.1.
Comment 7 Daniel Stone 2007-11-17 13:44:09 UTC
committed, thanks for the backporting
Comment 8 Arkadiusz Miskiewicz 2007-11-19 08:29:27 UTC
*** Bug 13207 has been marked as a duplicate of this bug. ***