Bug 1284 - Xorg unable to reach 1024x768 resolution
Summary: Xorg unable to reach 1024x768 resolution
Status: RESOLVED DUPLICATE of bug 643
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: 6.7.0
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Alan Hourihane
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-02 15:55 UTC by E.Causse
Modified: 2005-07-01 17:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
xorg log file (50.93 KB, text/plain)
2005-03-15 17:01 UTC, E.Causse
no flags Details
Xorg.0.log with Options "MonitorLayout" "NONE,LFP" (46.38 KB, application/octet-stream)
2005-03-23 17:34 UTC, E.Causse
no flags Details
The log file without the "MonitorLayout" Option (48.30 KB, application/octet-stream)
2005-03-23 17:36 UTC, E.Causse
no flags Details
Log with "LFP,NONE" (53.39 KB, application/octet-stream)
2005-03-24 09:30 UTC, E.Causse
no flags Details
Log file with Option DevicePresence (46.08 KB, text/x-log)
2005-03-25 09:36 UTC, E.Causse
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description E.Causse 2004-09-02 15:55:36 UTC
The X Server looks unable to reach 1024x768 resolution.
It runs on a Gateway laptop, with a 1024*768 LCD panel, and the graphic chip is
a i852GM/i855GM (not sure of that).

I've tried all the fixes for 855 : 855patch, 855wrap, 855resolution, but none of
them solved the bug. I tried all the ways to define the 1024x768 mode in the
xorg.conf too, but nothing works. I still have theses lines in my Xorg.0.log :

(II) I810(0): Not using mode "1024x768" (no mode of this name)
(II) I810(0): Increasing the scanline pitch to allow tiling mode (800 -> 1024).
(--) I810(0): Virtual size is 800x600 (pitch 1024)
(**) I810(0):  Built-in mode "800x600"
(**) I810(0):  Built-in mode "640x480"

Note that it's the same as with Xfree 4.3 which comes with mandrake 10.
I installed Xorg with the mandrake cooker rpms.
Comment 1 Adam Jackson 2004-09-02 19:45:21 UTC
this is not an easily fixable bug.  the i8x0 chips have some of the mode
programming support in external components, and we've been utterly unable to
acquire docs for those components.  there are workarounds that involve patching
your BIOS, but that kind of hack will never be added to the server directly.

really it's a bug in Gateway's video bios.

*** This bug has been marked as a duplicate of 643 ***
Comment 2 Guitou 2005-03-08 08:54:25 UTC
This problem differs from the bug #643, because 1024x768 _is_ a standard
resolution, listed in the Intel video bios.
I have the same problem, in my case only the mode 640x480 is available via Xorg.
Hardware : Mainboard Commell LV671 with video chipset Intel 855GME
Software : Xorg 6.8.2 + i810 driver, kernel 2.4.26,...

From Xorg.0.log :
"
(II) I810(0): Not using mode "1280x768" (no mode of this name)
(II) I810(0): Not using mode "1024x768" (no mode of this name)
(II) I810(0): Not using mode "800x600" (no mode of this name)
    [...]
Mode: 30 (640x480)
    [...]
Mode: 32 (0x0)
    [...]
Mode: 34 (0x0)
    [...]
Mode: 38 (0x0)
    [...]
Mode: 3a (0x0)
    [...]
Mode: 3c (0x0)
    [...]
Mode: 41 (640x480)
    [...]
Mode: 43 (0x0)
    [...]
    [...]
"

From the '855resolution' output :
"
855resolution version 0.3, by Alain Poirier

Chipset: 855GM
VBIOS type: 2
VBIOS Version: 3181

Mode 30 : 640x480, 8 bits/pixel
Mode 32 : 800x600, 8 bits/pixel
Mode 34 : 1024x768, 8 bits/pixel
Mode 38 : 1280x1024, 8 bits/pixel
Mode 3a : 1600x1200, 8 bits/pixel
Mode 3c : 1920x1440, 8 bits/pixel
Mode 41 : 640x480, 16 bits/pixel
Mode 43 : 800x600, 16 bits/pixel
Mode 45 : 1024x768, 16 bits/pixel
Mode 49 : 1280x1024, 16 bits/pixel
Mode 4b : 1600x1200, 16 bits/pixel
Mode 4d : 1920x1440, 16 bits/pixel
Mode 50 : 640x480, 32 bits/pixel
Mode 52 : 800x600, 32 bits/pixel
Mode 54 : 1024x768, 32 bits/pixel
Mode 58 : 1280x1024, 32 bits/pixel
Mode 5a : 1600x1200, 32 bits/pixel
Mode 5c : 1920x1440, 32 bits/pixel
"

These modes are included and made available by the Vbios, I just can't figure
why Xorg can't use on other than 640x480.

Another info, I tried the _exact same_ configuration with a slightly different
mainboard including an Intel 845GV chipset, and this same software configuration
is working like a charm with any of the listed resolutions above.
Comment 3 E.Causse 2005-03-09 12:58:46 UTC
It looks like I'm not the only one with this bug, and that not only the Gateway
bios is concerned.
The bug is still valid for me with Xorg 6.8.2 (Mdk Cooker).
Comment 4 Alan Hourihane 2005-03-15 06:59:13 UTC
Please post a full log from your 6.8.2 setup.
Comment 5 E.Causse 2005-03-15 17:01:20 UTC
Created attachment 2124 [details]
xorg log file
Comment 6 E.Causse 2005-03-15 17:02:30 UTC
Comment on attachment 2124 [details]
xorg log file

Here is my config file, log file attached.

Section "Files"
    # Multiple FontPath entries are allowed (they are concatenated together)
    # By default, Mandrake 6.0 and later now use a font server independent of
    # the X server to render fonts.
    FontPath "unix/:-1"
EndSection

Section "ServerFlags"
    #DontZap # disable <Crtl><Alt><BS> (server abort)
    #DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
    AllowMouseOpenFail # allows the server to start up even if the mouse
doesn't work
EndSection

Section "Module"
    Load "dbe" # Double-Buffering Extension
    Load "v4l" # Video for Linux
    Load "extmod"
    Load "type1"
    Load "freetype"
    Load "synaptics"
    Load "glx" # 3D layer
    Load "drm"
EndSection

Section "InputDevice"
    Identifier "Keyboard1"
    Driver "keyboard"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "fr"
    Option "XkbOptions" ""
EndSection

Section "InputDevice"
    Identifier "Mouse1"
    Driver "mouse"
    Option "Protocol" "ExplorerPS/2"
    Option "Device" "/dev/mouse"
    Option "ZAxisMapping" "6 7"
EndSection

Section "InputDevice"
    Identifier "SynapticsMouse1"
    Driver "synaptics"
    Option "Protocol" "auto-dev"
    Option "Device" "/dev/input/mice"
    Option "MaxSpeed" "0.12"
    Option "MinSpeed" "0.06"
    Option "BottomEdge" "4200"
    Option "SHMConfig" "on"
    Option "LeftEdge" "1700"
    Option "FingerLow" "25"
    Option "MaxTapTime" "180"
    Option "MaxTapMove" "220"
    Option "FingerHigh" "30"
    Option "VertScrollDelta" "100"
    Option "AccelFactor" "0.0010"
    Option "TopEdge" "1700"
    Option "RightEdge" "5300"
EndSection

Section "Monitor"
    Identifier "monitor1"
    VendorName "Generic"
    ModelName "Flat Panel 1024x768"
    HorizSync 31.5-48.5
    VertRefresh 40-70
EndSection

Section "Device"
    Identifier "device1"
    VendorName "Intel Corp."
    BoardName "Intel 85x"
    Driver "i810"
    BusID "PCI:0:2:0"
    Option "DPMS"
EndSection

Section "Screen"
    Identifier "screen1"
    Device "device1"
    Monitor "monitor1"
    DefaultColorDepth 24

    Subsection "Display"
	Depth 8
	Virtual 1024 768
    EndSubsection

    Subsection "Display"
	Depth 15
	Virtual 1024 768
    EndSubsection

    Subsection "Display"
	Depth 16
	Virtual 1024 768
    EndSubsection

    Subsection "Display"
	Depth 24
	Virtual 1024 768
    EndSubsection
EndSection

Section "ServerLayout"
    Identifier "layout1"
    InputDevice "Keyboard1" "CoreKeyboard"
    InputDevice "Mouse1" "CorePointer"
    InputDevice "SynapticsMouse1" "AlwaysCore"
    Screen "screen1"
    #Option "Xinerama"
EndSection
Comment 7 E.Causse 2005-03-15 17:06:37 UTC
With the config above, I have a 1024x768 desktop with 800x600 resolution.
Note that the 1024x768 panel is detected but no 1024x768 built-in resolution is
detected.
Comment 8 E.Causse 2005-03-15 17:08:02 UTC
Without the "Virtual" keyword, I still have the same as in original bug description.
Sorry for all the different posts.
Comment 9 Alan Hourihane 2005-03-23 16:36:40 UTC
Can you try this...

In your Device Section put this.

Option "MonitorLayout" "LFP,NONE"

and attach a new log file.
Comment 10 Alan Hourihane 2005-03-23 16:37:21 UTC
Oh, and make sure you are using the driver from

http://www.fairlite.demon.co.uk/intel.html

when trying that option.
Comment 11 E.Causse 2005-03-23 17:34:59 UTC
Created attachment 2200 [details]
Xorg.0.log with Options "MonitorLayout" "NONE,LFP"

Here is the log with :
Options "MonitorLayout" "NONE,LFP"

The result is the same as without the option, although there are differences in
the log apparently. The "LFP,NONE" makes X.Org crash (crap screen on alt-f7 and
nothing on the others).
I used the specified i810 driver.
Comment 12 E.Causse 2005-03-23 17:36:16 UTC
Created attachment 2201 [details]
The log file without the "MonitorLayout" Option

The usual log file, with the same xorg.conf except for the MonitorLayout part.
Comment 13 E.Causse 2005-03-23 17:43:57 UTC
I changed the version to "6.8.2", I hope it's correct to do this by myself.

By the way, is it normal that the driver you specified is marked as built for
xorg version 6.8.1.99 ?
Comment 14 Alan Hourihane 2005-03-24 02:50:50 UTC
(In reply to comment #11)
> Created an attachment (id=2200) [edit]
> Xorg.0.log with Options "MonitorLayout" "NONE,LFP"

You didn't read my reply properly. I said "LFP,NONE" not "NONE,LFP"
Comment 15 Alan Hourihane 2005-03-24 02:52:53 UTC
I see that you did say you tried "LFP,NONE" but it ended up with garbage on the
console. I need a log from that even if it does mess up the console.
Comment 16 E.Causse 2005-03-24 09:30:55 UTC
Created attachment 2206 [details]
Log with "LFP,NONE"

As said before, this configuration completely crashs both X and ttys. I guess
it's because LFP is attached to panel B as said in the log.
Comment 17 Alan Hourihane 2005-03-25 04:30:24 UTC
In your Device Section can you add the option

Option "DevicePresence" 

and see if that makes any difference.

Essentially, I think your BIOS believes your LCD to be 800x600 even though it's
reporting 1024x768 and therefore the ModeAttributes field doesn't allow the mode.
Comment 18 E.Causse 2005-03-25 09:36:53 UTC
Created attachment 2213 [details]
Log file with Option DevicePresence

Additional things appear in the log file, but the result is the same.
Comment 19 Alan Hourihane 2005-03-25 09:45:51 UTC
That's unfortunate, as it appears to be a bug in your video BIOS.

Is there no update for your machine from the manufacturer ?
Comment 20 E.Causse 2005-03-25 13:14:39 UTC
(In reply to comment #19)
> That's unfortunate, as it appears to be a bug in your video BIOS.
> 
> Is there no update for your machine from the manufacturer ?

There is an update available, but it seems to only concern the floppy
controller. Moreover, a win32 utility is needed to flash the bios.
What I don't understand is why I could set 1024 resolution under windows without
problem, if there is a video bios issue ?
Comment 21 Alan Hourihane 2005-03-25 14:07:17 UTC
Because Windows doesn't use the Video BIOS to set the modes.
Comment 22 Adam Jackson 2005-07-02 10:11:02 UTC

*** This bug has been marked as a duplicate of 643 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.