Bug 13009 - hald-probe-volume timeout too short for some hardware
Summary: hald-probe-volume timeout too short for some hardware
Status: RESOLVED FIXED
Alias: None
Product: hal
Classification: Unclassified
Component: hald (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: David Zeuthen (not reading bugmail)
QA Contact:
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-10-30 12:53 UTC by Yann Rouillard
Modified: 2008-11-10 04:05 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
The hald debug log (615.72 KB, text/plain)
2007-10-30 12:55 UTC, Yann Rouillard
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yann Rouillard 2007-10-30 12:53:43 UTC
When a new medium is inserted, hald-probe-volume is launched at some time with a 10s timeout. 
This value seems to be too short for some hardware.
Indeed a DVD-R inserted in LG GSA-H30N recorder is never really recognized because hald-probe-volume is killed after the timeout.

Increasing this value from 10s to 15s solves the bug (in hald/util.h), the DVD-R 
is correctly recognized.

The problem has been found on Ubuntu 7.10 with hal 0.5.9.1, udev 113, kernel 2.6.22.

The original bug is here: https://bugs.launchpad.net/ubuntu/+source/hal/+bug/157775
Comment 1 Yann Rouillard 2007-10-30 12:55:49 UTC
Created attachment 12267 [details]
The hald debug log
Comment 2 Lauri Võsandi 2008-04-09 22:56:49 UTC
I can confirm this. I have external USB powered LG GSA-E50L DVD writer and it's way too slow to recognize inserted DVD in 10secs. Please fix this, this doesnt require a lot of job I think.
Comment 3 Martin Pitt 2008-05-14 10:26:37 UTC
Seems that Yann and I figured this out independently. I sent explanations and the (trivial) patch to the upstream ML recently:

http://lists.freedesktop.org/archives/hal/2008-May/011511.html


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.