Bug 13187 - xorg-server-1.4 crashes when applications grabs input
Summary: xorg-server-1.4 crashes when applications grabs input
Status: RESOLVED INVALID
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/DDX/Xorg (show other bugs)
Version: 7.3 (2007.09)
Hardware: x86 (IA32) All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-11 14:07 UTC by Slava Gorbunov
Modified: 2008-04-03 06:57 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.log (56.63 KB, text/plain)
2007-11-11 14:09 UTC, Slava Gorbunov
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Slava Gorbunov 2007-11-11 14:07:49 UTC
I have found that sometimes xorg-server crashes when qemu grabs mouse and keyboard input (it happens when you click in its window). I didn't find any other conditions which cause crash, so I suppose that it occurs randomly. I have observed this crash twice, once xorg-server printed a backtrace, and once it didn't. But both times there was the following error reported:

Fatal server error:
bogus pointer event from ddx

The backtrace:

Backtrace:
0: /usr/bin/X(xf86SigHandler+0x80) [0x80bf650]
1: [0xb7f13420]
2: /usr/bin/X(XkbRemoveResourceClient+0xb8) [0x8187bb8]
3: /usr/bin/X [0x807eb72]
4: /usr/bin/X(CloseDownDevices+0x38) [0x807edd8]
5: /usr/bin/X(AbortServer+0x23) [0x81b4be3]
6: /usr/bin/X(FatalError+0x67) [0x81b5107]
7: /usr/bin/X(CoreProcessPointerEvent+0x1c5) [0x80923a5]
8: /usr/bin/X(ProcessPointerEvent+0x6e) [0x81895be]
9: /usr/bin/X(mieqProcessInputEvents+0x137) [0x8116777]
10: /usr/bin/X(ProcessInputEvents+0x2c) [0x80bff2c]
11: /usr/bin/X(Dispatch+0x71) [0x80866f1]
12: /usr/bin/X(main+0x495) [0x806dda5]
13: /lib/libc.so.6(__libc_start_main+0xd8) [0xb7c56838]
14: /usr/bin/X(FontFileCompleteXLFD+0xa1) [0x806d0c1]

FatalError re-entered, aborting
Caught signal 11.  Server aborting

I'm using xorg-server-1.4-r2 from gentoo with this patch (which fixes broken keyboard leds) applied:
https://bugs.freedesktop.org/show_bug.cgi?id=12434#c17
Comment 1 Slava Gorbunov 2007-11-11 14:09:39 UTC
Created attachment 12465 [details]
Xorg.log
Comment 2 Peter Hutterer 2008-01-29 19:57:22 UTC
if this is still an issue, I just posted a mini-patch to git master that prints out the event type if this occur. we need to know that to continue.
Comment 3 Peter Hutterer 2008-02-25 19:21:55 UTC
ping?
Comment 4 Slava Gorbunov 2008-02-26 15:35:38 UTC
Sorry, but I am unable to reproduce this crash now. I've tried to make qemu to perform mouse grab many times, but no crash was observed. Perhaps this bug should be closed as invalid.
Comment 5 Peter Hutterer 2008-02-26 19:52:37 UTC
(In reply to comment #4)
> Sorry, but I am unable to reproduce this crash now. I've tried to make qemu to
> perform mouse grab many times, but no crash was observed. Perhaps this bug
> should be closed as invalid.

done. please re-open if bug reappears.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.