Bug 13203 - [XKB] XkbMaxLegalKeyCode needs increased
Summary: [XKB] XkbMaxLegalKeyCode needs increased
Status: RESOLVED DUPLICATE of bug 11227
Alias: None
Product: xorg
Classification: Unclassified
Component: Input/Keyboard (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-12 11:41 UTC by Sebastian Starosielec
Modified: 2007-11-12 13:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Sebastian Starosielec 2007-11-12 11:41:01 UTC
There exists keyboards which sends keycodes larger than 255 (i.e. Logitech S510). The kernel seems to be fixed by now, but 
XkbMaxLegalKeyCode is set to 255 in include/extensions/XKB.h.
Comment 1 Daniel Stone 2007-11-12 13:34:19 UTC

*** This bug has been marked as a duplicate of bug 11227 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.