Bug 13243 - Internal error: invalid bpp (32) in S3VScreenInit
Summary: Internal error: invalid bpp (32) in S3VScreenInit
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/s3virge (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: xorg-7.4
  Show dependency treegraph
 
Reported: 2007-11-14 04:12 UTC by Dave
Modified: 2008-04-07 14:08 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg.8.log - full log file containing the error (24.71 KB, text/plain)
2008-03-24 12:34 UTC, Dave
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2007-11-14 04:12:39 UTC
I have some older hardware (Pentium II) on which I was trying to bring up X.

I'd installed the latest version of gentoo linux and X.org.  I can't tell if the latest X.org build that gentoo pulls in is really the latest available, because the version numbers seem to use a different numbering system.  "X -version" tells me:

X Window System Version 1.3.0
Release Date: 19 April 2007
X Protocol Version 11, Revision 0, Release 1.3
Build Operating System: UNKNOWN
Current Operating System: Linux localhost 2.6.22-gentoo-r9 #1 SMP Mon Nov 12
02:11:50 CST 2007 i686
Build Date: 12 November 2007

"lspci" reports the video card as:

01:01.0 VGA compatible controller: S3 Inc. Trio 64 3D (rev 01)

When I ran "xorgcfg" to generate the config file, I hit the following error (as reported in /var/log/Xorg.8.log), which crashed X:

Internal error: invalid bpp (32) in S3VScreenInit

I can attach the full log file if anyone wants it.

(I also tried running "xorgcfg" with s3virge uninstalled and the fallback vga driver installed, and ran into a different bug, reported in bug 13238.)

After a few hours poking around on the web, I figured out that I could get X to start by letting "xorgcfg" generate a (broken) xorg.conf, then starting X with that config file and a "-depth 16" parameter.

I was able to puzzle this out because I'm comfortable reading technical jargon, which I had to wade through a lot of to work out a solution.  To someone not technically inclined, it's not at all obvious how to get from that cryptic error message to a working X.  I don't know the right way to address this, but the way it's handled now is broken.
Comment 1 Adam Jackson 2008-03-24 09:34:14 UTC
Please do attach the log file from this case.
Comment 2 Dave 2008-03-24 12:34:54 UTC
Created attachment 15431 [details]
Xorg.8.log - full log file containing the error
Comment 3 Adam Jackson 2008-04-07 14:08:20 UTC
Wow, that's funny.

Yeah, s3v has 24+32 support, it's just being turned off for some reason.  Fixed in git, thanks!


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.