Bug 13335 - "hintstyle=hintslight" setting is ignored even if "rgba=none"
Summary: "hintstyle=hintslight" setting is ignored even if "rgba=none"
Status: RESOLVED DUPLICATE of bug 11838
Alias: None
Product: cairo
Classification: Unclassified
Component: general (show other bugs)
Version: 1.5.3
Hardware: All All
: medium normal
Assignee: Carl Worth
QA Contact: cairo-bugs mailing list
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2007-11-21 08:06 UTC by Yasuhiro Fujii
Modified: 2009-09-12 02:59 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Yasuhiro Fujii 2007-11-21 08:06:18 UTC
"hintstyle" setting on fonts.conf seems to be ignored.
I understand it is impossible to set "rgba=rgb" and "hintstyle=hintslight" at the same time because of freetype restriction.
But even if "rgba=none", "hintstyle" setting is ignored.

A patch to fix this bug:
--- cairo-1.4.10/src/cairo-ft-font.c
+++ cairo-1.4.10/src/cairo-ft-font.c
@@@ -1404,7 +1616,7 @@
    options->base.subpixel_order = other->base.subpixel_order;
     }

-    if (options->base.hint_style == CAIRO_HINT_STYLE_DEFAULT)
+    if (other->base.hint_style != CAIRO_HINT_STYLE_DEFAULT)
    options->base.hint_style = other->base.hint_style;

     if (other->base.hint_style == CAIRO_HINT_STYLE_NONE)
Comment 1 Paul Bredbury 2008-09-29 15:19:41 UTC
Looks very similar to bug 11838.
Comment 2 Chris Wilson 2008-10-10 14:55:53 UTC
They do indeed seem to be describing the same bug...

*** This bug has been marked as a duplicate of bug 11838 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.