Bug 13801 - [i965 FBO GEM] render to Mipmap texture through FBO is not working
[i965 FBO GEM] render to Mipmap texture through FBO is not working
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: Eric Anholt
:
Depends on:
Blocks: 18841 intel-3d-release
  Show dependency treegraph
 
Reported: 2007-12-23 23:07 UTC by Shuang He
Modified: 2009-04-23 22:24 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
test case (6.32 KB, text/plain)
2007-12-23 23:11 UTC, Shuang He
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Shuang He 2007-12-23 23:07:10 UTC
System Environment:
--------------------------
--Platform: FC6
--Xf86_video_intel:d9df93578b74785c08ba860b4c9aa23b0c89c91c
--Mesa:e54329233522591bbe8aad8a3fd6bcdc1e430f03 
--DRM:2db6400396ea5c8a5ce54fe9e211b9d01a11d506
--Kernel:2.6.22

Bug detailed description:
--------------------------
This issue doesn't happen on i915 platform


Reproduce steps:
----------------
start X
compile and run the attached test case


Current result:
----------------
nothing was rendered with non-zero level texture


Expected result:
----------------
render to Mipmap texture through FBO should work correctly
Comment 1 Shuang He 2007-12-23 23:11:22 UTC
Created attachment 13336 [details]
test case

this test case generate a mipmap texture through FBO, by assigning each level a different color, then apply the level 1 during rendering a rectangle.
The rectangle rendered should be in green. but it turns out nothing is rendered.
Comment 2 Shuang He 2008-07-28 18:49:27 UTC
This issue still exist with latest GEM
Comment 3 Shuang He 2009-03-22 20:29:17 UTC
this issue still exists with:
Kernel_version:         2.6.29-rc7
Libdrm:         (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa:            (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver:         (server-1.6-branch)60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:      (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Kernel:       (for-airlied)dc529a4fe1ae4667c819437a94185e8581e1e680
Comment 4 Eric Anholt 2009-04-23 14:06:58 UTC
Since this works on master, commit c3e7fc394f9590ac35755e722995fd88bbfd11ce
Author: Eric Anholt <eric@anholt.net>
Date:   Thu Apr 23 09:37:55 2009 -0700

    i965: Support drawing to FBO cube faces other than positive X.
    
    Also fixes drawing to 3D texture depth levels.
    (cherry picked from commit 8374379572d1c541a804990bc926108360f67c02)

Comment 5 Shuang He 2009-04-23 22:24:18 UTC
verified against:
Kernel_version:         2.6.29.1
Libdrm:         (master)412d370b9ae4b2882691863a1c5e13a507574e92
Mesa:           (mesa_7_4_branch)c3e7fc394f9590ac35755e722995fd88bbfd11ce
Xserver:        (server-1.6-branch)11db545a86c8933c638a0bc1fcd4f2c65279f617
Xf86_video_intel:               (2.7)296a986e5258e2fd13ec494071b7063bd639cd68
Kernel:         (qa-branch)ba1d2a9be507cda299c15740ff7e2bb3705a4792