Bug 13922 - Failed to initialize TTM buffer manager
Failed to initialize TTM buffer manager
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Eric Anholt
: NEEDINFO
Depends on:
Blocks: 14314
  Show dependency treegraph
 
Reported: 2008-01-04 01:14 UTC by Max
Modified: 2009-08-24 12:29 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.log (39.42 KB, text/plain)
2008-01-04 01:15 UTC, Max
Details
glxinfo (9.87 KB, application/octet-stream)
2008-01-04 01:16 UTC, Max
Details
xorg.conf (8.40 KB, application/octet-stream)
2008-01-05 08:47 UTC, Max
Details
my glxinfo output (6.78 KB, text/plain)
2008-09-16 13:37 UTC, Denis Misiurca
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Max 2008-01-04 01:14:30 UTC
I can't understand why all gl applications crash X
~% glxinfo|grep render
libGL: XF86DRIGetClientDriverName: 1.9.0 i915 (screen 0)
libGL: OpenDriver: trying /usr/lib/dri/i915_dri.so
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: Searching for BusID pci:0000:00:02.0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 4, (OK)
drmOpenByBusid: drmOpenMinor returns 4
drmOpenByBusid: drmGetBusid reports pci:0000:00:02.0
Failed to initialize TTM buffer manager.  Falling back to classic.
direct rendering: Yes
OpenGL renderer string: Mesa DRI Intel(R) 915GM 20061102 x86/MMX/SSE2
Comment 1 Max 2008-01-04 01:15:23 UTC
Created attachment 13511 [details]
Xorg.log
Comment 2 Max 2008-01-04 01:16:41 UTC
Created attachment 13512 [details]
glxinfo
Comment 3 Max 2008-01-05 08:47:18 UTC
Created attachment 13541 [details]
xorg.conf
Comment 4 Max 2008-01-05 08:48:28 UTC
00:02.0 VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
00:02.1 Display controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 04)
Comment 5 Michael Fu 2008-01-06 17:38:25 UTC
were you using the mesa tip? we once saw this in the last a couple of days, but was fixed quickly... can you retry the tip?
Comment 6 Max 2008-01-07 02:45:10 UTC
when i downgrade mesa from svn to mesa-7.0.2, xf86-video-i810-9999 to 2.1.1, and xorg-server, warnings and errors disappear.
Comment 7 Michael Fu 2008-01-08 21:02:58 UTC
Have you tried the tip?
Comment 8 Gordon Jin 2008-01-08 22:19:27 UTC
The log shows:
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/i915_dri.so: undefined symbol: __driCreateNewScreen_20050727)

You need use xserver tip together with mesa tip. See
https://bugs.freedesktop.org/show_bug.cgi?id=13012
Comment 9 Benjamin Close 2008-01-11 02:38:35 UTC
Bugzilla Upgrade Mass Bug Change

NEEDSINFO state was removed in Bugzilla 3.x, reopening any bugs previously listed as NEEDSINFO.

  - benjsc
    fd.o Wrangler
Comment 10 Michael Fu 2008-01-16 17:02:19 UTC
*** Bug 14094 has been marked as a duplicate of this bug. ***
Comment 11 Timo Jyrinki 2008-01-25 07:22:45 UTC
After some dwelling in the bug reports, I guess "tip" means the latest GIT version, and people are confused about "tip" meaning just that, tips to solve problems... I haven't heard of using "tip" for trunk/master/head/latest git/latest cvs, so it might be a wise idea to avoid that word :)

So: using current mesa's GIT/master version requires also the GIT/master of xserver instead of the 1.4-branch. Ie you need git://anongit.freedesktop.org/git/xorg/xserver in addition to the latest mesa/drm and mesa/mesa. Hope this helps.
Comment 12 Michael Fu 2008-01-28 19:34:18 UTC
thanks Timo's explanation.

Max, need your response for comment# 8...
Comment 13 Timo Jyrinki 2008-02-04 03:51:01 UTC
I think the TTM problems can be confirmed regardless of the fact that the original reporter did not use Xserver's latest git version. I and some other(s) are not able to get TTM enabled either even when using latest version of Xserver & drm & libdrm & mesa & intel ddx, see bug #14314.
Comment 14 Timo Jyrinki 2008-02-05 00:33:43 UTC
Actually it turns out that I still had an old libdrm.pc pkgconfig file, which reported older version, which disabled DRI_MM in the intel DDX driver. For newbies it might be useful to note in Xorg.0.log that the driver was compiled without memory manager support.

TTM works now, so this bug can be fixed/closed.
Comment 15 Denis Misiurca 2008-09-16 13:33:15 UTC
I still see 'Failed to initialize TTM buffer manager.  Falling back to classic.' on Gentoo with the following packages versions:

$ eix -c media-libs/mesa -o x11-base/xorg-server -o x11-drivers/xf86-video-i810
[I] media-libs/mesa (7.2_rc1@16.09.2008): OpenGL-like graphic library for Linux
[I] x11-base/xorg-server (1.5.0@16.09.2008): X.Org X servers
[I] x11-drivers/xf86-video-i810 (2.4.2-r1@08.09.2008): X.Org driver for Intel cards
Comment 16 Denis Misiurca 2008-09-16 13:35:00 UTC
The same happened with Mesa 7.1
Comment 17 Denis Misiurca 2008-09-16 13:37:22 UTC
Created attachment 18929 [details]
my glxinfo output

$ glxinfo > mesabug.txt 2>&1
Comment 18 Gordon Jin 2008-09-16 18:16:46 UTC
(In reply to comment #15)
> I still see 'Failed to initialize TTM buffer manager.  Falling back to
> classic.' on Gentoo with the following packages versions:

Denis, having this warning is expected with current mesa code, as TTM is disabled by default in 7.1 and 7.2.

If that's the only issue you have, please close this bug.
Comment 19 ajax at nwnk dot net 2009-08-24 12:29:06 UTC
Mass version move, cvs -> git