Bug 13923 - mesa unichrome crash in draw_rgba_pixels when starting torcs
Summary: mesa unichrome crash in draw_rgba_pixels when starting torcs
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/Unichrome (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Default DRI bug account
QA Contact:
URL: http://bugs.debian.org/cgi-bin/bugrep...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-04 04:01 UTC by Brice Goglin
Modified: 2019-09-18 20:34 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Brice Goglin 2008-01-04 04:01:26 UTC
"Andrey" reported that torcs crashes right away. The debugging backtrace is:

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb74c68d0 (LWP 5812)]
draw_rgba_pixels (ctx=0x805af30, x=320, y=240, width=800, height=600,
    format=6408, type=5121, unpack=0x8066b7c, pixels=0xb0fe8008)
    at swrast/s_drawpix.c:57
	in swrast/s_drawpix.c
(gdb) #0  draw_rgba_pixels (ctx=0x805af30, x=320, y=240, width=800, height=600,
    format=6408, type=5121, unpack=0x8066b7c, pixels=0xb0fe8008)
    at swrast/s_drawpix.c:57
#1  0xb73b97a9 in _swrast_DrawPixels (ctx=0x805af30, x=320, y=240, width=800,
    height=600, format=6408, type=5121, unpack=0x8066b7c, pixels=0xb0fe8008)
    at swrast/s_drawpix.c:900
#2  0xb74183f4 in _mesa_DrawPixels (width=800, height=600, format=6408,
    type=5121, pixels=0xb0fe8008) at main/drawpix.c:186
#3  0xb7ec57a2 in ?? () from /usr/lib/torcs/lib/libclient.so
#4  0xb7a6cc46 in ?? () from /usr/lib/libglut.so.3
#5  0x0804c410 in ?? ()
#6  0xb7f04780 in ?? () from /lib/ld-linux.so.2
#7  0x0804c410 in ?? ()
#8  0x0804c410 in ?? ()
#9  0xb7a6db40 in ?? () from /usr/lib/libglut.so.3
#10 0xbf876f18 in ?? ()
#11 0xb7a891b0 in ?? () from /usr/lib/libglut.so.3
#12 0x0804c410 in ?? ()
#13 0xbf876f18 in ?? ()
#14 0xbf876e48 in ?? ()
#15 0xb7a70142 in fgEnumWindows () from /usr/lib/libglut.so.3
Backtrace stopped: frame did not save the PC
Comment 1 Brice Goglin 2008-01-04 05:52:47 UTC
Andrey uses Debian libgl1-mesa-dri 7.0.2-3 (based on mesa_7_0_branch commit 0107acde).
Comment 2 Benno Schulenberg 2008-01-16 15:42:37 UTC
From the backtrace it doesn't seem to be specific to a Unichrome.  Could Andrey try Mesa HEAD from git?  Torcs does not segfault here on a Unichrome with the latest git.  (But it freezes when ready to race -- not much better.)
Comment 3 Andrey Paramonov 2008-01-19 10:28:32 UTC
(In reply to comment #2)
> From the backtrace it doesn't seem to be specific to a Unichrome.  Could Andrey
> try Mesa HEAD from git?  Torcs does not segfault here on a Unichrome with the
> latest git.  (But it freezes when ready to race -- not much better.)
> 

Sorry, but I'm afraid I can't help you with testing latest Mesa unless you provide me with detailed instructions of how to correctly install it in Debian. I tried to run TORCS on my working computer, and I must be sure that I will be able to revert Mesa to stable version without pain.

Andrey
Comment 4 Benno Schulenberg 2008-01-19 14:15:45 UTC
You could build Mesa by following http://dri.freedesktop.org/wiki/Building , sections 1.4 and 1.6 (option 2).  But looking at the Debian bug, you appear to have a K8M800 chipset.  For that chip 3D acceleration does not seem to work at all.  See bug #5092, especially comments 22 and 24.  Does any openGL program work on your machine?  glxgears?  tuxracer?  crack-attack?  bzflag?  Be prepared to experience a lockup when you try any of those programs.
Comment 5 Andrey Paramonov 2008-01-20 03:18:22 UTC
(In reply to comment #4)
> But looking at the Debian bug, you appear to
> have a K8M800 chipset.  For that chip 3D acceleration does not seem to work at
> all.  See bug #5092, especially comments 22 and 24.  Does any openGL program
> work on your machine?  glxgears?  tuxracer?  crack-attack?  bzflag?  Be
> prepared to experience a lockup when you try any of those programs.
> 

I actually have K8N800 chipset which seems to be cheaper and crappier version of K8M800. I confirm the behavior described in #5092 (glxgears run Ok, Google Earth freezes system after some seconds). I thought that my problem with TORCS was the symptom of a more general bug (described in #5092) and sent the report so this general bug is documented. It appears that the problem is already known, which is good.

I suggest lowering the priority for this bug, because it is not critical for me at all (I'm not a gamer). Also, I don't think anyone would ever buy PC with crappiest integrated VIA video for 3D gaming ;-)

Andrey
Comment 6 GitLab Migration User 2019-09-18 20:34:53 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/openchrome/old-bug-database/issues/7.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.