Bug 13985 - Server crashes with DRI/XAA while moving glxgears window
Server crashes with DRI/XAA while moving glxgears window
Status: RESOLVED WONTFIX
Product: xorg
Classification: Unclassified
Component: Driver/intel
7.3 (2007.09)
x86 (IA32) BSD (Others)
: medium major
Assigned To: Eric Anholt
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-09 02:51 UTC by Hasso Tepper
Modified: 2009-01-06 23:35 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments
xorg.conf (2.02 KB, application/octet-stream)
2008-01-09 02:53 UTC, Hasso Tepper
no flags Details
Xorg.0.log.1 (33.68 KB, application/x-trash)
2008-01-09 02:57 UTC, Hasso Tepper
no flags Details
Xorg.0.log.2 (28.99 KB, text/x-log)
2008-01-09 02:58 UTC, Hasso Tepper
no flags Details
backtrace.txt (1017 bytes, text/plain)
2008-01-09 03:09 UTC, Hasso Tepper
no flags Details
Log from the affected system - Does not show the issue, but shows configuration (251.27 KB, text/plain)
2008-09-18 11:49 UTC, Allan Stirling
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Hasso Tepper 2008-01-09 02:51:01 UTC
System is DragonFly BSD, xserver 1.4.0 and intel driver fresh 2.2 branch. DRI is fresh git from git://ww2.fs.ei.tum.de/~corecode/git/drm.git (DragonFly port is not yet submitted to upstream), mesa 7.0.2.

Server crashes while I move glxgears window. It might take some seconds, but is reproduceable 100%. It doesn't happen with DRI/EXA (although there is different crash, but it can't be triggered with glxgears). X is restarted after crash, but it isn't able to start any more - I have to reboot machine. Logs/conf/backtraces are from Thinkpad X61s laptop with 965GM chip, but the same happens in desktop with 965Q chip as well.

Backtrace isn't always the same, but the pattern is.
Comment 1 Hasso Tepper 2008-01-09 02:53:48 UTC
Created attachment 13608 [details]
xorg.conf
Comment 2 Hasso Tepper 2008-01-09 02:57:18 UTC
Created attachment 13609 [details]
Xorg.0.log.1

Xorg log from crashing session.
Comment 3 Hasso Tepper 2008-01-09 02:58:27 UTC
Created attachment 13610 [details]
Xorg.0.log.2

Log from new session - X isn't able to start any more because of errors found in hardware state.
Comment 4 Hasso Tepper 2008-01-09 03:09:53 UTC
Created attachment 13611 [details]
backtrace.txt

Although I'm afraid that it's already consequence, there is one of backtraces I get from X core. The patter is always the same, but there might be "... ProcPolyLine(); DamageDamageRegion(); cwPolylines(); XAAPolylinesFallback(); I830Sync(); ..." sequence in it.
Comment 5 Hasso Tepper 2008-01-10 01:06:33 UTC
Just for info, upgrading Mesa to the latest 7.0 branch code didn't change anything.
Comment 6 Allan Stirling 2008-09-18 11:47:34 UTC
I also believe I see this bug.

Ubuntu Hardy, xserver-xorg-video-intel_2.4.1 built from source.

Comment 7 Allan Stirling 2008-09-18 11:49:22 UTC
Created attachment 18988 [details]
Log from the affected system - Does not show the issue, but shows configuration
Comment 8 Gordon Jin 2008-09-18 23:54:02 UTC
I'm afraid XAA won't be supported and will be removed. Please use EXA (default).
Comment 9 Eric Anholt 2009-01-06 23:35:04 UTC
XAA is dead.  If it hurts, don't use it.