Bug 1405 - [XKB] default settings for xmodmap no longer include Alt_R as a modifier
Summary: [XKB] default settings for xmodmap no longer include Alt_R as a modifier
Status: RESOLVED DUPLICATE of bug 926
Alias: None
Product: xorg
Classification: Unclassified
Component: App/xmodmap (show other bugs)
Version: 6.8.0
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-17 11:35 UTC by James Laska
Modified: 2011-10-15 16:49 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description James Laska 2004-09-17 11:35:01 UTC
# Running with Fedora Core 3 (test2)
# xorg-x11-6.8.0-4
#

I noticed after a recent install that my common keypress for changing viewports
in $windowmanger were behaving strangely.  My configured keypress is
<alt><shift>-$arrowkey.  After further investigation, it appears that this
keypress works fine when using Alt_L ... however, Alt_R is causing problems. 
According to `xmodmap` output (see below) it appears that Alt_R is no longer a
modifier.

(~)> xmodmap
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Alt_L (0x7d),  Meta_L (0x9c)
mod2        Num_Lock (0x4d)
mod3
mod4        Super_L (0x7f),  Hyper_L (0x80)
mod5        Mode_switch (0x5d),  ISO_Level3_Shift (0x7c)

I do not have a custom $HOME/.[Xx]modmap configured.  I'm not sure if this is an
expected change or an omission.

Thoughts/comments/concerns?
Comment 1 Paul Curry 2004-11-02 08:32:44 UTC
I've discovered this too.  It makes (left) Alt+Tab not work correctly in kde.  
I mistakenly thought that it was a kde bug and filed a bug report with them 
<http://bugs.kde.org/show_bug.cgi?id=92558>.  It would be nice if right Alt 
working exactly the same as left Alt. 
 
I'm using slackware with xorg 6.8.1. 
Comment 2 Helge Hielscher 2005-02-02 15:22:43 UTC
sounds like a dup of bug 926
Comment 3 Mike A. Harris 2005-04-27 18:17:08 UTC

*** This bug has been marked as a duplicate of 926 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.