Bug 14078 - Support for Logitech Wave
Summary: Support for Logitech Wave
Status: RESOLVED DUPLICATE of bug 11227
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Input/XKB (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Daniel Stone
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-01-15 03:02 UTC by Timo Aaltonen
Modified: 2008-12-22 16:03 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Aaltonen 2008-01-15 03:02:54 UTC
I'd like to add support for Logitech Wave. Currently it lacks support for most of the special keys it has. I sent this to the mailing list:

"I bought a Logitech Wave keyboard, and it has many extra keys that don't produce any events while using the evdev driver (at least xev doesn't show anything). Is there any hope getting them to work? I've been told that if they actually produced anything xev would notice.."

so I thought a bug report would be better in solving this. I'm using Ubuntu Hardy.

I've tried cat'ing the input device on console, and the keys don't produce anything, so I'm a bit lost what to do next.
Comment 1 Sergey V. Udaltsov 2008-01-15 03:05:25 UTC
Well, actually it does not make sense to file a bug against xkeyboard-config if you do not see these keys in xev. Probably, evdev driver should be fixed first (in xorg and/or kernel)
Comment 2 Timo Aaltonen 2008-01-15 03:25:49 UTC
Hmm, ok. I'll also try the kbd driver today if it works any better.
Comment 3 Timo Aaltonen 2008-02-10 00:59:23 UTC
showkey on the console shows the key-id's as >255, so it would need some remapping in the kernel evdev driver?
Comment 4 Sergey V. Udaltsov 2008-02-10 01:47:23 UTC
Yes, I'd guess xorg driver has to be fixed
Comment 5 Daniel Stone 2008-12-22 16:03:04 UTC

*** This bug has been marked as a duplicate of bug 11227 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.