Bug 14221 - [i965 64bit] ut2004 run abort on mesa 7_0_branch
[i965 64bit] ut2004 run abort on mesa 7_0_branch
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i965
unspecified
Other Linux (All)
: medium normal
Assigned To: haihao
:
: 14456 (view as bug list)
Depends on:
Blocks: 16029
  Show dependency treegraph
 
Reported: 2008-01-24 00:51 UTC by Colin.Joe
Modified: 2008-06-27 00:16 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg.0.log (51.12 KB, text/plain)
2008-01-24 00:52 UTC, Colin.Joe
Details
X log (82.51 KB, text/plain)
2008-01-24 05:44 UTC, Shuang He
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin.Joe 2008-01-24 00:51:31 UTC
System Environment:
--------------------------
Platform: gm965
Arch: 64bit 
Xf86_video_intel:    xf86-video-intel-2.2-branch
Xserver:   xserver 1.4
Drm:       libdrm 2.3.0     
Mesa:    mesa_7_0_3_rc1 branch       
Kernel:   2.6.23.1  
   


Bug detailed description:
--------------------------

startx ,run ut 2004 , it run abort and print :
"WARNING: ALC_EXT_capture is subject to change!
Failed to initialize TTM buffer manager.  Falling back to classic.
chosen: dotclock 69257 vco 1939200 ((m 101, m1 16, m2 9), n 3, (p 28, p1 2, p2 14))
Signal: SIGSEGV [segmentation fault]
Aborting.


Crash information will be saved to your logfile.
chosen: dotclock 69257 vco 1939200 ((m 101, m1 16, m2 9), n 3, (p 28, p1 2, p2 14))"



Reproduce steps:
----------------
startx , run ut2004 .
Comment 1 Colin.Joe 2008-01-24 00:52:25 UTC
Created attachment 13894 [details]
Xorg.0.log
Comment 2 Michel Dänzer 2008-01-24 01:54:27 UTC
> Mesa:    mesa_7_0_3_rc1 branch

[...]

> Failed to initialize TTM buffer manager.  Falling back to classic.

The i965 driver on mesa_7_0_branch doesn't have any TTM support. Please
clarify.
Comment 3 Shuang He 2008-01-24 05:28:02 UTC
I think he's attaching the wrong log.
here's what I got on GM965 with mesa-7.0.3-rc1:

WARNING: ALC_EXT_capture is subject to change!
ut2004-bin: intel_regions.c:231: intel_region_data: Assertion `dst_offset + dstx + width + (dsty + height - 1) * dst->pitch * dst->cpp <= dst->pitch * dst->cpp * dst->height' failed.
Signal: SIGIOT [iot trap]
Aborting.


with backtrace:

Starting program: /usr/local/games/ut2004demo/System/ut2004-bin
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread 46995635437952 (LWP 5307)]
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[New Thread 1082132800 (LWP 5310)]
WARNING: ALC_EXT_capture is subject to change!
[New Thread 1090525504 (LWP 5311)]
ut2004-bin: intel_regions.c:231: intel_region_data: Assertion `dst_offset + dstx                                              + width + (dsty + height - 1) * dst->pitch * dst->cpp <= dst->pitch * dst->cpp                                              * dst->height' failed.

Program received signal SIGABRT, Aborted.
[Switching to Thread 46995635437952 (LWP 5307)]
0x00002abe05a3dcab in raise () from /lib/libc.so.6
(gdb) bt
#0  0x00002abe05a3dcab in raise () from /lib/libc.so.6
#1  0x00002abe05a3f660 in abort () from /lib/libc.so.6
#2  0x00002abe05a37436 in __assert_fail () from /lib/libc.so.6
#3  0x00002aaaaafab504 in intel_region_data (intel=0x58f3b30, dst=0x55fe9b0,
    dst_offset=0, dstx=0, dsty=0, src=0x5e71800, src_pitch=512, srcx=0,
    srcy=0, width=512, height=512) at intel_regions.c:229
#4  0x00002aaaaafaa9dc in intel_miptree_image_data (intel=0x58f3b30,
    dst=0x55fe7e0, face=<value optimized out>, level=<value optimized out>,
    src=0x5e71800, src_row_pitch=512, src_image_pitch=0)
    at intel_mipmap_tree.c:255
#5  0x00002aaaaafb2398 in intel_finalize_mipmap_tree (intel=0x58f3b30,
    tObj=<value optimized out>) at intel_tex_validate.c:98
#6  0x00002aaaaafd9939 in upload_wm_surfaces (brw=0x58f3b30)
    at brw_wm_surface_state.c:232
#7  0x00002aaaaafc6c4b in brw_validate_state (brw=0x58f3b30)
    at brw_state_upload.c:259
#8  0x00002aaaaafbcec3 in brw_try_draw_prims (ctx=0x58f3b30, arrays=0x54828b8,
    prim=0x7fffa5f9b200, nr_prims=1, ib=0x7fffa5f9b1e0, min_index=0,
    max_index=27) at brw_draw.c:304
#9  0x00002aaaaafbd310 in brw_draw_prims (ctx=0x58f3b30, arrays=0x54828b8,
    prim=0x7fffa5f9b200, nr_prims=1, ib=0x7fffa5f9b1e0, min_index=0,
    max_index=27) at brw_draw.c:446
#10 0x00002aaaab04f9bf in vbo_exec_DrawRangeElements (mode=4, start=0, end=27,
---Type <return> to continue, or q <return> to quit---
    count=48, type=5123, indices=0x324b308) at vbo/vbo_exec_array.c:330
#11 0x00002abe0872612e in glDrawRangeElements (mode=4, start=0, end=27,
    count=48, type=5123, indices=0x324b308)
    at ../../../src/mesa/glapi/glapitemp.h:1868
#12 0x0000000000ccdeb0 in FOpenGLRenderInterface::DrawPrimitive ()
#13 0x0000000000a3e177 in FBspDrawList::Render ()
#14 0x00000000007de2da in RenderLevel ()
#15 0x00000000007c22c3 in FLevelSceneNode::Render ()
#16 0x00000000007c62c7 in FPlayerSceneNode::Render ()
#17 0x000000000067b813 in UGameEngine::Draw ()
#18 0x0000000000cbd8c6 in USDLViewport::Repaint ()
#19 0x0000000000cbb2c9 in USDLClient::Tick ()
#20 0x000000000067ff30 in UGameEngine::Tick ()
#21 0x0000000000522928 in CMainLoop::RunLoop ()
#22 0x0000000000518aaf in ?? ()
#23 0x0000000000514ded in main ()
Comment 4 Shuang He 2008-01-24 05:44:30 UTC
Created attachment 13901 [details]
X log 

here's my X log
Comment 5 vaLentin 2008-04-13 14:55:00 UTC
When trying Mesa 7.0.2 with the following patch applied to it:

https://bugs.freedesktop.org/show_bug.cgi?id=13492

I get the results described in the current bug report when try running Google Earth.

googleearth-bin: intel_regions.c:231: intel_region_data: Assertion `dst_offset + dstx + width + (dsty + height - 1) * dst->pitch * dst->cpp <= dst->pitch * dst->cpp * dst->height' failed.
Google Earth has caught signal 6.

Stacktrace from glibc:
  ./googleearth-bin(__gxx_personality_v0+0x1e8) [0x8057fb4]
  ./googleearth-bin [0x8058399]
  [0xffffe420]
  [0xffffe410]
  /lib/libc.so.6(gsignal+0x49) [0xb608a629]
  /lib/libc.so.6(abort+0x101) [0xb608bbf1]
  /lib/libc.so.6(__assert_fail+0xef) [0xb6083cfb]
  /usr/lib/dri/i965_dri.so [0xaecafc59]

32 bit system.
Mesa 7.0.2 + the patch from 13492.
Comment 6 Colin.Joe 2008-05-21 18:33:37 UTC
this bug can be reproduced on latest mesa 7_0_branch 
Comment 7 haihao 2008-05-28 01:37:02 UTC
*** Bug 14456 has been marked as a duplicate of this bug. ***
Comment 8 haihao 2008-05-29 00:56:16 UTC
fixed in mesa_7_0_branch.
Comment 9 Colin.Joe 2008-06-27 00:16:01 UTC
Verified.