Bug 14254 - xserver fails to build on OpenBSD
Summary: xserver fails to build on OpenBSD
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: x86 (IA32) OpenBSD
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: patch
Depends on:
Blocks: xorg-7.4
  Show dependency treegraph
 
Reported: 2008-01-26 05:34 UTC by Mark Kettenis
Modified: 2008-03-02 10:39 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Fix (299 bytes, patch)
2008-01-26 05:34 UTC, Mark Kettenis
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Mark Kettenis 2008-01-26 05:34:20 UTC
Created attachment 13956 [details] [review]
Fix

Build fails building hw/xfree86/util/ioport because of unresolved symbols, in particular i386_iopl.  The problem is that it needs to get linked with -li386 but this doesn't happen anymore.  This got broken by Eric Anholt on 2007-08-31 in commit a02db0d500cac20d0f0f107d27c064a175018421 (whee don't you just *love* 30-digit hex numbers to describe commits?).  The problem is that since that commit
SYS_LIBS no longer get substituted by autoconf/automake.  I expect that this brekage is present on NetBSD and FreeBSD too, since by the looks of it they need
the same or similar system libraries to build ioport.

The attached diff fixes things.
Comment 1 Matthieu Herrb 2008-03-02 10:39:29 UTC
Thanks for debugging this. 

I committed different diff in c934366. If I understand the comments in 
configure.ac correclty, the idea of the change that broke ioport build on OpenBSD was to avoid AC_SUBST(SYS_LIBS) 


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.