Bug 14283 - [915 Wine] HL2 under wine assertion failure 'intel->prim.primitive != ~0'
[915 Wine] HL2 under wine assertion failure 'intel->prim.primitive != ~0'
Status: RESOLVED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
unspecified
Other Linux (All)
: medium normal
Assigned To: Eric Anholt
: NEEDINFO
: 15735 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-28 13:21 UTC by Steve Todorov
Modified: 2010-01-06 11:19 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Todorov 2008-01-28 13:21:37 UTC
Hi there,
I've installed HL2. When I start the game via wine, it starts as normal, but right after I click "New game" it shows this:



fixme:d3d:IWineD3DVolumeImpl_LockBox (0xf96ff58) : pBox=0x33e384 stub
fixme:d3d:IWineD3DDeviceImpl_CreateQuery (0x13b210) Event query: Unimplemented, but pretending to be supported
SteamGetUser()
SteamGetUser()
fixme:d3d:IWineD3DDeviceImpl_EvictManagedResources (0x13b210) : stub
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x17c21a40) : stub
fixme:d3d:IWineD3DDeviceImpl_EvictManagedResources (0x13b210) : stub
fixme:d3d9:IDirect3DDevice9Impl_CreateQuery (0x139d80) call to IWineD3DDevice_CreateQuery failed
fixme:d3d:IWineD3DDeviceImpl_EvictManagedResources (0x13b210) : stub
Mesa 7.0.2 implementation error: i915_program_error: Exceeded max temporary reg
Please report at bugzilla.freedesktop.org
Mesa 7.0.2 implementation error: i915_program_error: Exceeded max nr indirect texture lookups
Please report at bugzilla.freedesktop.org
intel_batchbuffer.c:145: intel_flush_inline_primitive: Assertion `intel->prim.primitive != ~0' failed.
fixme:dbghelp:dump_system_info fill in CPU vendorID and feature set
DRM_I830_CMDBUFFER: -22





So I just thought to post this problem here. 
I don't know what this means nor how to fix it. Probably it's a bug in the Mesa ? 

I'm with slackware 12, kernel 2.6.22.9, Gnome 2.20.2, Intel 915G video card. 




Thanks in advance,
Steve
Comment 1 Garry Hurley Jr 2008-01-28 20:00:28 UTC
Steve,

I take it you are not using standard Slack 12 since you are using Gnome.
Tell me, has Slack 12 been updated to xorg 1.4 yet?  If not, you might try
compiling xorg 1.4 (or checking in the ##slackware channel of the Freenode
IRC network to see if someone has built a package yet).  Do not use the
packages you find on Linuxpackages.org for Slackware packages.  Many are not
built properly and your system may not work as expected.  Another thing to
try is to make certain you have the most recent versions of Wine (I would
recommend Cedega if you are looking for broader gaming support), Mesa, and
try using KDE or FVWM to be certain that it isn't an issue within Gnome (I
doubt it, but let's be complete in checking).  I would also see if other
distro users have the same problems with Wine, HL2, or Mesa.  I would offer
to validate the bug, but I have a radeon chipset, and am running Slamd64
current.

Garry

On Jan 28, 2008 4:21 PM, <bugzilla-daemon@freedesktop.org> wrote:

> http://bugs.freedesktop.org/show_bug.cgi?id=14283
>
>           Summary: Slackware 12, wine and Half-Life 2 problem
>           Product: Mesa
>           Version: unspecified
>          Platform: Other
>        OS/Version: Linux (All)
>            Status: NEW
>          Severity: normal
>          Priority: medium
>         Component: Drivers/DRI/i915
>        AssignedTo: dri-devel@lists.sourceforge.net
>        ReportedBy: admin@itnews-bg.com
>
>
> Hi there,
> I've installed HL2. When I start the game via wine, it starts as normal,
> but
> right after I click "New game" it shows this:
>
>
>
> fixme:d3d:IWineD3DVolumeImpl_LockBox (0xf96ff58) : pBox=0x33e384 stub
> fixme:d3d:IWineD3DDeviceImpl_CreateQuery (0x13b210) Event query:
> Unimplemented,
> but pretending to be supported
> SteamGetUser()
> SteamGetUser()
> fixme:d3d:IWineD3DDeviceImpl_EvictManagedResources (0x13b210) : stub
> fixme:d3d:IWineD3DResourceImpl_SetPriority (0x17c21a40) : stub
> fixme:d3d:IWineD3DDeviceImpl_EvictManagedResources (0x13b210) : stub
> fixme:d3d9:IDirect3DDevice9Impl_CreateQuery (0x139d80) call to
> IWineD3DDevice_CreateQuery failed
> fixme:d3d:IWineD3DDeviceImpl_EvictManagedResources (0x13b210) : stub
> Mesa 7.0.2 implementation error: i915_program_error: Exceeded max
> temporary reg
> Please report at bugzilla.freedesktop.org
> Mesa 7.0.2 implementation error: i915_program_error: Exceeded max nr
> indirect
> texture lookups
> Please report at bugzilla.freedesktop.org
> intel_batchbuffer.c:145: intel_flush_inline_primitive: Assertion
> `intel->prim.primitive != ~0' failed.
> fixme:dbghelp:dump_system_info fill in CPU vendorID and feature set
> DRM_I830_CMDBUFFER: -22
>
>
>
>
>
> So I just thought to post this problem here.
> I don't know what this means nor how to fix it. Probably it's a bug in the
> Mesa
> ?
>
> I'm with slackware 12, kernel 2.6.22.9, Gnome 2.20.2, Intel 915G video
> card.
>
>
>
>
> Thanks in advance,
> Steve
>
>
> --
> Configure bugmail: http://bugs.freedesktop.org/userprefs.cgi?tab=email
> ------- You are receiving this mail because: -------
> You are the assignee for the bug.
>
> -------------------------------------------------------------------------
> This SF.net email is sponsored by: Microsoft
> Defy all challenges. Microsoft(R) Visual Studio 2008.
> http://clk.atdmt.com/MRT/go/vse0120000070mrt/direct/01/
> --
> _______________________________________________
> Dri-devel mailing list
> Dri-devel@lists.sourceforge.net
> https://lists.sourceforge.net/lists/listinfo/dri-devel
>
Comment 2 Javier Rosa 2008-02-10 12:54:31 UTC
I have a similar problem with the same chipset using the latest wine (0.9.54) with Guild Wars. I am running ubuntu 7.10 just updated to the most recent set of packages.

wine GwSetup.exe
err:ole:apartment_getclassobject DllGetClassObject returned error 0x80040111
err:ole:CoGetClassObject no class object {fbf23b40-e3f0-101b-8488-00aa003e56f8} could be created for context 0x1
err:ole:apartment_getclassobject DllGetClassObject returned error 0x80040111
err:ole:CoGetClassObject no class object {fbf23b40-e3f0-101b-8488-00aa003e56f8} could be created for context 0x1
fixme:shell:DllCanUnloadNow stub
javirosa@flayn:~$ fixme:shell:DllCanUnloadNow stub
fixme:shell:DllCanUnloadNow stub
fixme:shell:DllCanUnloadNow stub
fixme:shell:DllCanUnloadNow stub
fixme:shell:DllCanUnloadNow stub
fixme:win:EnumDisplayDevicesW ((null),0,0x34f08c,0x00000000), stub!
fixme:d3d:IWineD3DImpl_CheckDeviceMultiSampleType Quality levels unsupported at present
fixme:imm:ImmGetIMEFileNameA (0x4090409, 0x78dfe2a8, 260): stub
err:xrandr:X11DRV_XRandR_SetCurrentMode Resolution change not successful -- perhaps display has changed?
fixme:d3d:IWineD3DDeviceImpl_SetDialogBoxMode (0x139d30) Dialogs cannot be disabled yet
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2330238) : stub
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2330728) : stub
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2330c18) : stub
fixme:d3d:IWineD3DDeviceImpl_SetDialogBoxMode (0x139d30) Dialogs cannot be disabled yet
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2021740) : stub
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x189be8) : stub
fixme:d3d:IWineD3DResourceImpl_SetPriority (0x2021e38) : stub
fixme:cursor:create_cursor_image Currently no support for cursors with 0 bits per pixel
Mesa 7.0.1 implementation error: i915_program_error: Exceeded max temporary reg
Please report at bugzilla.freedesktop.org
DRM_I830_CMDBUFFER: -22
Comment 3 Steve Todorov 2008-03-26 14:18:58 UTC
Hi Garry,

I'm using slackware 12 ( original distro's release ) but I've installed Gnome because I hate KDE. I also have the latest version of wine ( I've tried that one :) ) also I've updated everything to the latest available version including video drivers,wine,mesa and etc.. I'll see in the forums if there is something that could be done about this one.. 
Comment 4 Adam Bittner 2008-06-19 21:50:37 UTC
is this a dupe of bug 11131 ?
Comment 5 Adam Bittner 2008-06-19 21:53:53 UTC
*** Bug 15735 has been marked as a duplicate of this bug. ***
Comment 6 Eric Anholt 2009-10-23 14:56:58 UTC
Does this still occur at this point?
Comment 7 Eric Anholt 2010-01-06 11:19:19 UTC
feedback timeout.  Given that I fixed bugs related to the original report, I'm hoping it's really fixed.