Bug 14900 - Segfault 0xb7001a6d in viaEmitState () from /usr/lib/dri/unichrome_dri.so
Summary: Segfault 0xb7001a6d in viaEmitState () from /usr/lib/dri/unichrome_dri.so
Status: RESOLVED MOVED
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/Unichrome (show other bugs)
Version: 6.5
Hardware: x86 (IA32) Linux (All)
: highest critical
Assignee: mesa-dev
QA Contact:
URL: http://openchrome.org/trac/ticket/162...
Whiteboard:
Keywords:
: qglVertex2f (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-03-07 23:26 UTC by Dmitriy
Modified: 2019-09-18 20:34 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Dmitriy 2008-03-07 23:26:47 UTC
GL_VENDOR: VIA Technology
GL_RENDERER: Mesa DRI UniChrome 20060710
GL_VERSION: 1.2 Mesa 6.5.1
Linux Debian 4.0r3 etch


http://ufoai.sourceforge.net/
=>
svn co https://ufoai.svn.sourceforge.net/svnroot/ufoai/ufoai/trunk ufoai
=>
gdb ufo
run +set vid_fullscreen 0 +set vid_grabmouse 0
bt full
=>
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread -1217816896 (LWP 5702)]
0xb7001a6d in viaEmitState () from /usr/lib/dri/unichrome_dri.so
(gdb) bt full
#0 0xb7001a6d in viaEmitState () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#1 0xb7004c88 in viaRasterPrimitive () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#2 0xb6ffab70 in viaCopyBuffer () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#3 0xb6ffa9be in viaCopyBuffer () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#4 0xb70973ef in _tnl_run_pipeline () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#5 0xb70040e0 in viaInitTriFuncs () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#6 0xb70c5175 in _tnl_flush_vtx () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#7 0xb70bdb3c in _tnl_FlushVertices () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#8 0xb714449b in _mesa_set_enable () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#9 0xb714535d in _mesa_Disable () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#10 0xb7231e0a in glDisable () from /usr/lib/libGL.so.1
No symbol table info available.
#11 0x0810d153 in R_DrawFlatGeoscape (x=0, y=0, w=1024, h=768, p=0.25,
q=-1.77736676, cx=0.5, cy=0.5,
iz=0.5, map=0x8166d30 "map_earth") at src/renderer/r_draw.c:484
gl = (image_t *) 0x114546dc
nx = 0
ny = 0
nw = 1024
nh = 768
__PRETTY_FUNCTION__ = "R_DrawFlatGeoscape"
#12 0x0809f19b in MAP_DrawMap (node=0x15f64618) at
src/client/cl_map.c:1371
q = -1.77736676
base = (base_t *) 0x300
---Type <return> to continue, or q <return> to quit---
distance = 9.94714651e-26
__PRETTY_FUNCTION__ = "MAP_DrawMap"
#13 0x080d06f3 in MN_DrawMenus () at src/client/menu/m_draw.c:313
node = (menuNode_t *) 0x15f64618
menu = (menu_t *) 0x162a8e40
ref = 0x0
font = 0xb7230699 "\201�s3\002"
source = '\0' <repeats 63 times>
sp = 1
pp = 0
color = {0.800000012, 0.800000012, 0.800000012, 1}
mouseOver = 1
y = 135649357
i = 193
message = (message_t *) 0x815d863
width = 1072693248
height = 0
itemHover = (const invList_t *) 0x0
tab = 0x6 <Address 0x6 out of bounds>
end = 0x1 <Address 0x1 out of bounds>
__PRETTY_FUNCTION__ = "MN_DrawMenus"
#14 0x080b874a in SCR_UpdateScreen () at src/client/cl_screen.c:458
No locals.
#15 0x08097a5a in CL_Frame (now=61957, data=0x0) at
src/client/cl_main.c:2380
delta = 51
last_frame = 61957
#16 0x080ea25b in tick_timer (now=61957, data=0x183b78b8) at
src/common/common.c:922
timer = (struct timer *) 0x183b78b8
old_interval = 11
lateness = 597
#17 0x080ea4af in Qcommon_Frame () at src/common/common.c:1003
event = (struct event *) 0x18553c80
time_to_next = 0
---Type <return> to continue, or q <return> to quit---
#18 0x081275ab in main (argc=7, argv=0xbfee7694) at
src/ports/linux/linux_main.c:102
No locals.
(gdb)
Comment 1 Dmitriy 2008-03-14 05:36:12 UTC
GL_VERSION: 1.4 (2.1 Mesa 7.0.3)

bug not fixed
Comment 2 Dmitriy 2008-03-22 22:24:20 UTC
GL_VENDOR: VIA Technology
GL_RENDERER: Mesa DRI UniChrome 20060710 x86/MMX/SSE2
GL_VERSION: 1.2 Mesa 7.0.3-rc2
Linux: lenny/sid

Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb756e6d0 (LWP 3169)]
0xb6fd594a in viaEmitState () from /usr/lib/dri/unichrome_dri.so
(gdb) bt full
#0  0xb6fd594a in viaEmitState () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#1  0xb6fd9298 in viaRasterPrimitive () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#2  0xb6fceede in ?? () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#3  0x182aa4d0 in ?? ()
No symbol table info available.
#4  0x00000004 in ?? ()
No symbol table info available.
#5  0x00000004 in ?? ()
No symbol table info available.
#6  0x182f5588 in ?? ()
No symbol table info available.
#7  0x00000049 in ?? ()
No symbol table info available.
#8  0xec007d80 in ?? ()
No symbol table info available.
#9  0x182a8740 in ?? ()
No symbol table info available.
#10 0xb719e31c in ?? () from /usr/lib/dri/unichrome_dri.so
No symbol table info available.
#11 0x00000000 in ?? ()
No symbol table info available.
(gdb)
Comment 3 Dmitriy 2008-03-29 13:28:45 UTC
Program received signal SIGSEGV, Segmentation fault.
[Switching to Thread 0xb77126d0 (LWP 17813)]
viaEmitState (vmesa=0x182a8c78) at via_state.c:223
223     via_state.c: No such file or directory.
        in via_state.c
(gdb) bt full
#0  viaEmitState (vmesa=0x182a8c78) at via_state.c:223
        texObj = <value optimized out>
        ctx = (GLcontext *) 0x182aa9f8
        j = <value optimized out>
        _vb = <value optimized out>
        _nr = <value optimized out>
        _x = <value optimized out>
#1  0xb717c298 in viaRasterPrimitive (ctx=0x182aa9f8, glprim=4, hwprim=4) at via_tris.c:927
        vmesa = (struct via_context *) 0x182a8c78
        regCmdB = <value optimized out>
        _vb = <value optimized out>
        __FUNCTION__ = "viaRasterPrimitive"
        __PRETTY_FUNCTION__ = "viaRasterPrimitive"
#2  0xb7171ede in via_fastrender_quads_verts (ctx=0x182aa9f8, start=0, count=4, flags=55)
    at ../../../../../src/mesa/tnl_dd/t_dd_dmatmp.h:626
        vmesa = (struct via_context *) 0x182a8c78
        j = <value optimized out>
#3  0xb7171d03 in via_run_fastrender (ctx=0x182aa9f8, stage=0x182f5c6c) at via_render.c:113
        mode = 0
        start = 0
        length = <value optimized out>
        tnl = (TNLcontext *) 0x182f5a88
        i = 0
#4  0xb7217cd3 in _tnl_run_pipeline (ctx=0x182aa9f8) at tnl/t_pipeline.c:158
        tnl = (TNLcontext *) 0x182f5a88
        __tmp = 895
        i = 6
        mask = 63
#5  0xb717b6e0 in viaRunPipeline (ctx=0x182aa9f8) at via_tris.c:1160
        vmesa = (struct via_context *) 0x2
#6  0xb7218251 in _tnl_draw_prims (ctx=0x182aa9f8, arrays=0x182e3ed8, prim=0x182e2a34, nr_prims=1, ib=0x0,
    min_index=0, max_index=3) at tnl/t_draw.c:402
        bo = {0x3f12fa33, 0x9, 0x3f1813b7, 0x3f1a97bb, 0x3f1d15c8, 0x3f1f8dc7, 0x3f21ffa0, 0x3f246b3a,
  0x3f26d07c, 0x3f292f4b, 0xde1, 0x0, 0xa, 0x3f32687d, 0x8, 0x3f36dc2c, 0x18a65aa4, 0x3f3b33a8, 0x3f3d549e,
  0x3f3f6e46, 0x3f41808e, 0x3f438b5f, 0x3f458ea7, 0x3f478a4c, 0x3f497e44, 0x3f4b6a78, 0x3f4d4ed5,
---Type <return> to continue, or q <return> to quit---
  0x3f4f2b47, 0x3f50ffbc, 0x3f52cc23, 0x3f549069, 0x3f564c7d, 0x3f58004e}
        nr_bo = 0
        tnl = (TNLcontext *) 0x182f5a88
#7  0xb7210dc0 in vbo_exec_vtx_flush (exec=0x182e2910) at vbo/vbo_exec_draw.c:215
        ctx = (GLcontext *) 0x182aa9f8
#8  0xb720d358 in vbo_exec_FlushVertices (ctx=0x182aa9f8, flags=1) at vbo/vbo_exec_api.c:700
        exec = (struct vbo_exec_context *) 0x182e2910
#9  0xb72ae061 in enable_texture (ctx=0x182aa9f8, state=<value optimized out>, bit=0) at main/enable.c:207
        curr = 1
        newenabled = 0
#10 0xb72b08d3 in _mesa_set_enable (ctx=0x182aa9f8, cap=3553, state=248 '�') at main/enable.c:595
        newenabled = <value optimized out>
#11 0xb72b1ece in _mesa_Disable (cap=3553) at main/enable.c:974
No locals.
#12 0x081112d6 in R_DrawFlatGeoscape (x=0, y=0, w=1024, h=768, p=0.25, q=-1.77736676, cx=0.5, cy=0.5,
    iz=0.5, map=0x816e070 "map_earth") at src/renderer/r_draw.c:527
        gl = (image_t *) 0x1146676c
        nx = 0
        ny = 0
        nw = 800
        nh = 600
        __PRETTY_FUNCTION__ = "R_DrawFlatGeoscape"
#13 0x080a17f8 in MAP_DrawMap (node=0x15e85d40) at src/client/cl_map.c:1372
        q = -1.77736676
        base = (base_t *) 0x300
        distance = 9.38534443e-26
        __PRETTY_FUNCTION__ = "MAP_DrawMap"
#14 0x080d33be in MN_DrawMenus () at src/client/menu/m_draw.c:326
        node = (menuNode_t *) 0x15e85d40
        menu = (menu_t *) 0x1664df08
        ref = 0x0
        font = 0x3ff00000 <Address 0x3ff00000 out of bounds>
        source = '\0' <repeats 63 times>
        sp = 1
        pp = 0
---Type <return> to continue, or q <return> to quit---
        color = {0.800000012, 0.800000012, 0.800000012, 1}
        mouseOver = 1
        y = -1208087328
        i = -1074918504
        message = (message_t *) 0x812260d
        width = 0
        height = 409424912
        itemHover = (const invList_t *) 0x0
        tab = 0xc3 <Address 0xc3 out of bounds>
        end = 0x8164eb5 "R_Clear"
        __PRETTY_FUNCTION__ = "MN_DrawMenus"
#15 0x080bb1ce in SCR_UpdateScreen () at src/client/cl_screen.c:458
No locals.
#16 0x08099ed3 in CL_Frame (now=24270, data=0x0) at src/client/cl_main.c:2374
        delta = 52
        last_frame = 24270
#17 0x080edf88 in tick_timer (now=24270, data=0x18a59cf8) at src/common/common.c:963
        timer = (struct timer *) 0x18a59cf8
        old_interval = 11
        lateness = 1041
#18 0x080ee1e1 in Qcommon_Frame () at src/common/common.c:1044
        event = (struct event *) 0x18a65a00
        time_to_next = 0
#19 0x0812d195 in main (argc=10, argv=0xbfee0d24) at src/ports/linux/linux_main.c:102
No locals.
(gdb)
Comment 4 Roland Scheidegger 2008-03-31 07:58:38 UTC
*** Bug 15261 has been marked as a duplicate of this bug. ***
Comment 5 GitLab Migration User 2019-09-18 20:34:56 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/openchrome/old-bug-database/issues/8.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.