Bug 1495 - r200 Messed up display with UT2004 linux demo
Summary: r200 Messed up display with UT2004 linux demo
Status: RESOLVED WORKSFORME
Alias: None
Product: DRI
Classification: Unclassified
Component: General (show other bugs)
Version: XOrg git
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-09-29 13:00 UTC by Phil Armstrong
Modified: 2004-10-01 07:11 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Phil Armstrong 2004-09-29 13:00:35 UTC
I'm using the DRI snapshot as of today (20040929). The display for the UT2004
linux demo (a 250+Mb download unfortunately :( ) is completely messed up --
there are planes of repeated textures sticking out all over the place.

Btw, driconf doesn't want to talk to the driver either (?) (It says "Driver
"r200" is not installed or does not support configuration.")

Setting R200_NO_TCL results in a better display, but the startup sequence has a
'rippled' effect to the circular LOGO.

If someone will tell me how, I'll take a screenshot ;)
Comment 1 Felix Kühling 2004-09-29 14:01:49 UTC
Your comment about driconf not working makes me think you're using an old
driver, not the new one from the snapshot. Can you run the following command
line (bash):

LIBGL_DEBUG=verbose xdriinfo options r200

It should output a line about which driver it tries to load. Make sure this is
the one you installed with the snapshot.
Comment 2 Phil Armstrong 2004-09-29 14:22:12 UTC
Ah:
$ LIBGL_DEBUG=verbose xdriinfo options r200
libGL: OpenDriver: trying /usr/X11R6/lib/modules/dri/r200_dri.so
Driver "r200" is not installed or does not support configuration.

This is because I'm using debian dri packages (2004-07-07) with
the snapshot binaries replacing the files in /usr/X11R6/lib/modules-dri-trunk/

xdriinfo is looking in the wrong place.

The head of /var/log/XFree86.0.log reads:

XFree86 Version 4.3.99.12 (DRI trunk)
Release Date: 10 September 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.6.6-1-k7 i686 [ELF] 
Current Operating System: Linux trigger 2.6.8-1-k7 #1 Mon Sep 13 23:56:00 EDT 20
04 i686
Build Date: 07 July 2004
...
(==) RgbPath set to "/usr/X11R6/lib/X11/rgb"
(==) ModulePath set to "/usr/X11R6/lib/modules-dri-trunk"

Of course, it's possible that the libGL in there needs updating to a more
recent common snapshot. I'll try that.
Comment 3 Phil Armstrong 2004-09-29 14:25:46 UTC
Nope, no difference. Does this output from the dri mean anything?

$ ./ut2004-demo 
WARNING: ALC_EXT_capture is subject to change!
Xlib:  extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".
r200_makeX86Normal3fv/197 CVAL 0 OFFSET 14 VAL 448fc4a0
r200_makeX86Normal3fv/198 CVAL 4 OFFSET 20 VAL 448fc4a4
r200_makeX86Normal3fv/199 CVAL 8 OFFSET 25 VAL 448fc4a8
r200_makeX86Normal3fv done
r200_makeX86Normal3fv/197 CVAL 0 OFFSET 14 VAL b4e2ebc
r200_makeX86Normal3fv/198 CVAL 4 OFFSET 20 VAL b4e2ec0
r200_makeX86Normal3fv/199 CVAL 8 OFFSET 25 VAL b4e2ec4
r200_makeX86Normal3fv done

(I know the XiG-SUNDRY-NONSTANDARD bit is irrelevant)
Comment 4 Felix Kühling 2004-09-29 14:52:44 UTC
xdriinfo looks for the 3D driver in the same place as any other 3D application.
You can override it using the environment variable LIBGL_DRIVERS_PATH. That may
also help with your UT2004 problems.
Comment 5 Eric Anholt 2004-09-30 00:08:00 UTC
Please try again with current CVS.  Some fixes were committed today.
Comment 6 Phil Armstrong 2004-09-30 00:36:26 UTC
Argh.

OK. That fixes it. It must have been loading the old DRI drivers.

New bug with the DRI snapshot: the UT2004 menu screen has a comletely white
background, unlike the non-dri one (there should be a few images there).

Otherwise everything seems to work.

Argh.

Should I change to NOTABUG & report the above separately?
Comment 7 Phil Armstrong 2004-10-02 00:11:37 UTC
Not a Bug, so changed to Works for me. cheers, Phil


bug/show.html.tmpl processed on Dec 06, 2016 at 00:47:56.
(provided by the Example extension).