Bug 15006 - translate & rotate the line cause Aliasing
Summary: translate & rotate the line cause Aliasing
Status: RESOLVED DUPLICATE of bug 9951
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915 (show other bugs)
Version: git
Hardware: Other Linux (All)
: medium normal
Assignee: marius predut
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-14 02:23 UTC by Colin.Joe
Modified: 2015-05-06 12:47 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
ths case code (2.83 KB, text/plain)
2008-03-14 02:25 UTC, Colin.Joe
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Colin.Joe 2008-03-14 02:23:38 UTC
System Environment:
--------------------------
--Platform: 965 (32bit & 64bit)
Mesa:
master branch 	
fcb7cb9e72ecac7c165a3a6ed7a033e2e6793a26

Xf86_video_intel:	
master branch	1c0e4958564588162bc22a980567436dfc9d1e56

Xorg:		 7.2

Drm:
master branch		
9be916f3537599489e083437c9a948eb93004904


Bug detailed description:
--------------------------
This case  tests position independence of anti-aliased
lines. The coverage of a  line is calculated.
This line is then translated. Regardless of its new
position, the coverage should remain the same.
The error allowance is based on a minimum of 4
subpixel sampling. This yields 0.125 per pixel.
 One half of a color epsilon (ERRORGENE in the case code) 
is added per pixel to account for the rounding from a coverage 
value to a shade. This sum is multiplied by the number of
 pixels along the perimeter (twice width for ends,
 plus twice length).


Reproduce steps:
----------------
start X
compile and run antialia


Current result:
----------------
the disparity between the coverages is bigger than the error margin 

Expected result:
----------------
the disparity between the coverages should not bigger than the error margin
Comment 1 Colin.Joe 2008-03-14 02:25:40 UTC
Created attachment 15113 [details]
ths case code
Comment 2 WuNian 2008-03-16 18:24:52 UTC
The bug exists on both i915 and i965.
Comment 3 Zou Nan hai 2008-03-24 19:36:48 UTC

*** This bug has been marked as a duplicate of bug 9951 ***
Comment 4 Adam Jackson 2009-08-24 12:29:37 UTC
Mass version move, cvs -> git
Comment 5 marius predut 2015-05-06 12:47:51 UTC
The patch series that fix this bug are upstream


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.