Bug 15011 - MMC card are not detected in coldplug
Summary: MMC card are not detected in coldplug
Status: RESOLVED NOTOURBUG
Alias: None
Product: hal
Classification: Unclassified
Component: hald (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Danny Kukawka
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-14 07:17 UTC by Frederic Crozat
Modified: 2010-09-10 07:01 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
coldplug trace (734.62 KB, text/plain)
2008-03-14 07:20 UTC, Frederic Crozat
Details
hotplug trace (825.71 KB, text/plain)
2008-03-14 07:20 UTC, Frederic Crozat
Details
patch to add some debug (2.76 KB, patch)
2008-03-14 08:48 UTC, Danny Kukawka
Details | Splinter Review
coldplug trace with debug patch (66.32 KB, application/x-gzip)
2008-03-14 09:29 UTC, Frederic Crozat
Details
hotplug log with debug patch (67.77 KB, application/x-gzip)
2008-03-14 09:30 UTC, Frederic Crozat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frederic Crozat 2008-03-14 07:17:33 UTC
on some mmc integrated cards reader, cards are not detected during coldplug (but are correctly detected during hotplug).

Bug report from https://qa.mandriva.com/show_bug.cgi?id=35937

I'm attaching a coldplug and an hotplug traces.
Comment 1 Frederic Crozat 2008-03-14 07:20:08 UTC
Created attachment 15118 [details]
coldplug trace
Comment 2 Frederic Crozat 2008-03-14 07:20:30 UTC
Created attachment 15119 [details]
hotplug trace
Comment 3 Danny Kukawka 2008-03-14 08:48:55 UTC
Created attachment 15122 [details] [review]
patch to add some debug

Could you please apply the patch to your HAL and reproduce the coldplug and attach the trace?
Comment 4 Frederic Crozat 2008-03-14 09:29:31 UTC
Created attachment 15126 [details]
coldplug trace with debug patch
Comment 5 Frederic Crozat 2008-03-14 09:30:14 UTC
Created attachment 15127 [details]
hotplug log with debug patch
Comment 6 Danny Kukawka 2008-03-14 10:12:36 UTC
is /sys/class/mmc_host/mmc0/mmc0:ffff/device present if the card is inserted? What is the target of the link?
Comment 7 Frederic Crozat 2008-03-14 12:58:02 UTC
no, there is no device symlink in /sts/class/mmc_host/mmc0/mmc0:ffff/
Comment 8 Danny Kukawka 2010-09-10 07:01:04 UTC
(In reply to comment #7)
> no, there is no device symlink in /sts/class/mmc_host/mmc0/mmc0:ffff/

I assume that's the problem. AFAIK a kernel bug. Maybe try latest kernel and/or latest hal version (git). 

Feel free to reopen if the problem is still there with the latest versions (or connect me via SUSE ;-) ).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.