Bug 15094 - Updating one package asks me some password
Summary: Updating one package asks me some password
Status: RESOLVED FIXED
Alias: None
Product: PackageKit
Classification: Unclassified
Component: core (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Richard Hughes
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-03-17 08:23 UTC by fujisan
Modified: 2008-03-26 08:16 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Updates available (28.29 KB, image/png)
2008-03-17 08:23 UTC, fujisan
Details
Available updates (47.47 KB, image/png)
2008-03-17 09:08 UTC, fujisan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fujisan 2008-03-17 08:23:21 UTC
Created attachment 15228 [details]
Updates available

When I want to install one package only, pk asks me a password.
A dialog window "System policy prevents updating package" pops up (see attached image)
Comment 1 Richard Hughes 2008-03-17 09:01:41 UTC
How did you generate the ui? From the command line or a client tool?
Comment 2 fujisan 2008-03-17 09:08:50 UTC
Created attachment 15229 [details]
Available updates
Comment 3 fujisan 2008-03-17 09:12:27 UTC
I click on the icon in the notif. area, then click "review updates", then I select a package (see 2nd attachment) and then click "update package" and then I get this "System policy prevents updating package" dialog window.
Comment 4 Richard Hughes 2008-03-17 09:13:51 UTC
Yes, the version you are using is quite old; in newer versions we'll just have
a checkable list of updates.

It's okay to authenticate, it should work fine.
Comment 5 fujisan 2008-03-17 09:15:42 UTC
I click on the icon in the notif. area, then click "review updates", then I select a package (see 2nd attachment) and then click "update package" and then I get this "System policy prevents updating package" dialog window.
Comment 6 fujisan 2008-03-17 09:16:54 UTC
Here is what I have. It was installed this morning.

PackageKit-libs-0.1.10-0.549.20080316git.fc8.hughsie
PackageKit-devel-0.1.10-0.549.20080316git.fc8.hughsie
PackageKit-0.1.10-0.549.20080316git.fc8.hughsie
Comment 7 Richard Hughes 2008-03-26 08:16:16 UTC
Fixed in git, and the soon-to-be-released 0.1.10.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.