Bug 1510 - xorg will use /xorg.conf if loaded from gdm
Summary: xorg will use /xorg.conf if loaded from gdm
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: 6.7.0
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
Depends on:
Reported: 2004-10-01 14:04 UTC by Tor Klingberg
Modified: 2006-04-14 12:22 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Description Tor Klingberg 2004-10-01 14:04:29 UTC
If there happen to exist a file /xorg.conf, then that file will be used instead
of /etc/X11/xorg.conf when X is loaded with gdm during init. 

I have this bug in Gentoo with gdm started by the Gentoo init scripts. Still, I
believe xorg should never use the file /xorg.conf

Steps to Reproduce:
1. Make sure you use x.org and gdm
2. echo FOOBAR>/xorg.conf
3. reboot

Actual Results:  
X won't start, complaining about error in xorg.conf

Expected Results:  
Used /etc/X11/xorg.conf, and started properly.

/var/log/Xorg.0.log will say 'Using config file: "//xorg.conf"'

running '/etc/init.d/xdm start' will fail the same way.
running /usr/bin/gdm does does NOT fail.

I also tried creating a trivial /etc/init.d/gdm that did nothing but 
run /usr/bin/gdm. Then running '/etc/init.d/gdm start' worked fine, but adding 
gdm to init (rc-update add gdm default) would still fail just like xdm.

I do not know if this problem also exists with kdm and xdm.

This bug is also reported in Gentoo Bugzilla at
Comment 1 Matthieu Herrb 2004-10-03 01:45:57 UTC
for root ${HOME}/xorg.conf is tried before /etc/X11/. 
If HOME is not defined, it defaults to /. 
Comment 2 Shawn Starr 2005-10-04 15:13:55 UTC
The paths for where xorg is found is being cleaned up see #4641 
Comment 3 Adam Jackson 2006-04-15 05:22:59 UTC
not a bug, see comment 2.

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.