Bug 15276 - text rendering, PGRAPH_ERROR/ILLEGAL_MTHD/PROTECTION_FAULT spam in syslog
text rendering, PGRAPH_ERROR/ILLEGAL_MTHD/PROTECTION_FAULT spam in syslog
Status: RESOLVED FIXED
Product: xorg
Classification: Unclassified
Component: Driver/nouveau
git
x86 (IA32) Linux (All)
: medium normal
Assigned To: Nouveau Project
Xorg Project Team
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-03-31 01:10 UTC by Paul Wise
Modified: 2009-02-01 14:12 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
syslog & Xorg log (23.87 KB, application/x-bzip)
2008-03-31 01:10 UTC, Paul Wise
no flags Details
log without vesafb (22.06 KB, application/x-bzip)
2008-04-01 03:04 UTC, Paul Wise
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Paul Wise 2008-03-31 01:10:10 UTC
Created attachment 15578 [details]
syslog & Xorg log

Not sure if these are related, but some text doesn't render and I get PGRAPH_ERROR spam in syslog).

The apps I was using are openbox (text in menu doesn't render), xterm (text renders), epiphany (menu text doesn't render, some website text renders).

I've attached the xorg log and the stretch of syslog (with drm debug=1) when Xorg was active.

I built xorg and nouveau from git yesterday using jhbuild.

The nv driver in Debian sid doesn't have this problem (2.1.8).
Comment 1 Stephane Marchesin 2008-03-31 04:16:04 UTC
What framebuffer driver are you using here ? If it's nvidiafb, it's not supported (this driver stomps all over the card state to the point we can't really maintain it properly).
Comment 2 Paul Wise 2008-03-31 04:31:38 UTC
I don't seem to have any fb driver loaded. I have it installed, but lsmod | grep nvidia only points out the nvidia_agp driver. lsmod | grep fb reports nothing.
Comment 3 Stephane Marchesin 2008-03-31 04:34:54 UTC
There is this line:

Mar 31 16:07:18 morrison kernel: [drm] Used old pci detect: framebuffer loaded

It's either a *fb driver, or the nvidia binary driver, which is bad in any case.
Comment 4 Paul Wise 2008-03-31 05:20:21 UTC
I purged everything from the nvidia 96xx legacy proprietary driver after I verified that it still sucks (used to kernel freeze occasionally, now kernel freezes when X starts) and before starting with nouveau stuff.

Looks like the fb thing was caused by vesafb being compiled into my kernel and having vga=... on the kernel command-line. Without this, I still get the same syslog spam and the text rendering issue. The monitor attached to the computer is now being used on another computer, I'll get you the updated logs later tonight.
Comment 5 Paul Wise 2008-04-01 03:04:49 UTC
Created attachment 15598 [details]
log without vesafb

New log attached without the vesafb thing. Same issues as before.
Comment 6 Paul Wise 2009-01-31 23:58:47 UTC
When I add MigrationHeuristic greedy to xorg.conf the fonts situation is fixed.

http://nouveau.freedesktop.org/wiki/MigrationHeuristic

I still get the PGRAPH_ERROR syslog spam though.

This is with Debian sid, Linux 2.6.26 and xserver-xorg-video-nouveau 1:0.0.10~git+20090105+7dc567d-1.
Comment 7 Ben Skeggs 2009-02-01 00:55:57 UTC
Ah, I actually noticed this bug earlier today and was planning on seeing if you still had the hw available.  I think I know the issue here, I'll push the fix to xf86-video-nouveau git.  If you're able to update afterwards, I'd love to know if it fixes things for you.
Comment 8 Paul Wise 2009-02-01 02:18:46 UTC
Will attempt that (or pester the Debian nouveau maintainer), please let me know when you've pushed the changes and to where.
Comment 9 Ben Skeggs 2009-02-01 02:22:35 UTC
The fix is in the 2D driver now.  If you don't want to wait for the debian maintainers to repackage the updates, you can install the driver yourself from git.

If you start to follow the instructions at http://nouveau.freedesktop.org/wiki/InstallNouveau from step 7 you should be fine.
Comment 10 Paul Wise 2009-02-01 03:30:44 UTC
Applied your patch to the Debian package and now I no longer get the PGRAPH_ERROR spam.

With the patch I can see the fonts fine with or without MigrationHeuristic greedy.

Without the MigrationHeuristic greedy, I see some horizontal pixel breakage on the Debian swirl at xdm after logging in and then logging out. Looks like maybe uninitialised pixels being passed to the GPU, unsure about this.

After building git master, installing nouveau_drv.so and restarting X/xdm I can still see the pixel breakage.

Anyway, I think this bug can be closed now since the fonts and PGRAPH_ERROR things are fixed, thanks heaps!

BTW, the Debian partition on the machine is for development, so if you need me to try anything on it, please let me know (http://bonedaddy.net/pabs3/about/#contact).

BTW, during testing the git master driver, I saw some "Bad page state in process 'Xorg'" messages on the console, the kernel printed a backtrace too:

Bad page state in process 'Xorg'
page:c1000000 flags:0x00000400 mapping:00000000 mapcount:0 count:0
Trying to fix it up, but a reboot is needed
Backtrace:
Pid: 5881, comm: Xorg Not tainted 2.6.26-1-686 #1
 [<c015a2e0>] bad_page+0x4d/0x74
 [<c015a711>] free_hot_cold_page+0x58/0x170
 [<ee92e21f>] agp_generic_destroy_page+0x3a/0x52 [agpgart]
 [<ee92e95e>] agp_free_memory+0x8a/0xac [agpgart]
 [<eea96240>] drm_agp_free_memory+0xb/0x13 [drm]
 [<eea937ca>] drm_free_agp+0x5/0xe [drm]
 [<eea914dc>] drm_lastclose+0x150/0x31b [drm]
 [<c01750f3>] __fput+0x8a/0x135
 [<c0165794>] remove_vma+0x25/0x43
 [<c016586c>] exit_mmap+0xba/0xd3
 [<c01206e2>] mmput+0x20/0x7e
 [<c0124ff2>] do_exit+0x1e5/0x5c9
 [<c012543a>] do_group_exit+0x64/0x8d
 [<c0103853>] sysenter_past_esp+0x78/0xb1
 =======================
Comment 11 Ben Skeggs 2009-02-01 14:12:36 UTC
Thanks for testing, I'll close this bug as fixed.  As for your other issues, feel free to file bugs for them so they don't get forgotten :)