Bug 1532 - Color changes on radeon when the window moves or focus changes
Summary: Color changes on radeon when the window moves or focus changes
Status: RESOLVED WONTFIX
Alias: None
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/R100 (show other bugs)
Version: unspecified
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Default DRI bug account
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-04 11:36 UTC by Stephane Marchesin
Modified: 2012-08-15 06:41 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Stephane Marchesin 2004-10-04 11:36:38 UTC
The rendered color changes once when I move the window, or when the focus on the
window changes, or in the case of a fullscreen program when I go to console mode
and back. I'm running a radeon 7000 with cvs dri drivers. I tested software mesa
on the same machine and it works fine.

The following C program demonstrates this problem :
http://icps.u-strasbg.fr/~marchesin/divers/multitex.c
For example, when I run it it initially looks green-ish, but when I switch focus
away and back on the window, it becomes white.
Note that this problem is not related to multitexture, since it also happens
with a single texture, but it is almost invisible then. Multitexturing with
GL_MODULATE seems to make it the most noticeable.
Comment 1 Erik Andren 2006-07-28 09:46:04 UTC
Is this still an issue using more current code?
Comment 2 Roland Scheidegger 2006-07-29 13:46:44 UTC
I could not reproduce the problem on my radeon 7200 with recent drivers, even
when disabling tcl (to make it more similar to a radeon 7000). However,
strangely enough the color shown is indeed somewhat different (but not changing)
to software mesa. Not sure if this is purely due to texture filtering /
precision issues or if there is indeed some bug. Also, the non-reproducability
_might_ have been caused by using a different wm, that bug is weird enough...
Comment 3 Jerome Glisse 2009-06-30 07:43:14 UTC
I can't see this bug with lastest master and dri2, i am closing this bug, i will test latter dri1 path and reopen if necessary.
Comment 4 Stephane Marchesin 2009-06-30 07:45:59 UTC
Please don't close bugs until they're fixed.
Comment 5 almos 2012-08-14 23:13:28 UTC
Is this fixed now?
Comment 6 Stephane Marchesin 2012-08-15 01:32:41 UTC
I don't have the card any more. I guess you could claim it's fixed?
Comment 7 Michel Dänzer 2012-08-15 06:41:41 UTC
I think this is the most accurate resolution (bug submitter can no longer test, DRI1 support has been removed).


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.