Bug 15432 - X fails to start when connected to TV via DVI->HDMI when TV on alternate input.
Summary: X fails to start when connected to TV via DVI->HDMI when TV on alternate input.
Status: RESOLVED DUPLICATE of bug 14611
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Hong Liu
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords: NEEDINFO
Depends on:
Blocks:
 
Reported: 2008-04-09 16:59 UTC by Billy Macdonald
Modified: 2008-07-10 00:10 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg with untouched code where X fails (20.00 KB, text/plain)
2008-04-09 17:00 UTC, Billy Macdonald
no flags Details
X log when X is able to start with code change. Shows that the driver does see the DVI connection and gets EDID info. (66.29 KB, text/plain)
2008-04-09 17:01 UTC, Billy Macdonald
no flags Details
Xorg conf file (890 bytes, text/plain)
2008-04-09 17:02 UTC, Billy Macdonald
no flags Details
Xorg.0.log (32.72 KB, text/plain)
2008-05-02 18:34 UTC, Billy Macdonald
no flags Details
force enable output -2nd (952 bytes, patch)
2008-05-03 18:52 UTC, Hong Liu
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Billy Macdonald 2008-04-09 16:59:34 UTC
The situation I have run into is that when X restarts when the TV is switched to a different input the DVI connection is not connected and X fails to start.  I have not tested with the TV off yet.

However, a minor modification to the driver (which is not a fix, just a test from other tickets) allows X to start.  When X does start it is able to get EDID information from the TV.  The retrieval of EDID info tells me that part of the connection is seen by the driver.

I am currently using xf86-video-intel-2.2.99.902

Two Xorg logs are attached.  Xorg.0.log (unmodified code) and Xorg.0.log.Unknown (modified code to allow X to start, showing that it is able to get EDID info)

This may duplicate https://bugs.freedesktop.org/show_bug.cgi?id=14611 but in my case the display is connected just not switched to the proper input.

Thanks.

PS to get X to start I did the following since I know that the DVI is connected.
Changed XF86OutputStatusDisconnected to XF86OutputStatusUnknown on line 1098 of src/i830_sdvo.c
Comment 1 Billy Macdonald 2008-04-09 17:00:36 UTC
Created attachment 15790 [details]
Xorg with untouched code where X fails
Comment 2 Billy Macdonald 2008-04-09 17:01:31 UTC
Created attachment 15791 [details]
X log when X is able to start with code change.  Shows that the driver does see the DVI connection and gets EDID info.
Comment 3 Billy Macdonald 2008-04-09 17:02:35 UTC
Created attachment 15792 [details]
Xorg conf file
Comment 4 Hong Liu 2008-04-13 19:39:59 UTC
Would you please attach the xorg log with option modedebug turned on?
It should be the same problem as bug 14611.

When you switch the TV to other input, our driver can't detect any active output attached to SDVO tmds-1 output (using the hotplug detection mechanism but it seems that we can still get EDID from the DDC channel to your TV).

Thanks,
Hong
Comment 5 Hong Liu 2008-04-16 21:51:30 UTC
Please try the patch in bug 14611.
Comment 6 Billy Macdonald 2008-05-02 18:34:57 UTC
Created attachment 16317 [details]
Xorg.0.log

Logfile with ModeDebug set to true.
Comment 7 Billy Macdonald 2008-05-02 18:51:03 UTC
I tried the referenced patch and setting the enable option did not help.
Comment 8 Hong Liu 2008-05-03 18:52:45 UTC
Created attachment 16339 [details] [review]
force enable output -2nd

Would you please make sure that you are using the new X server (with patch applied)? I've tried you xorg.conf file with my patch, it works.

Attached patch is the same with the 1st, except I've added some debug messages.
This will make sure whether you are using the newly patched X server. Would you please try this patch and repost the xorg log?

Thanks,
Hong
Comment 9 Gordon Jin 2008-06-03 23:56:30 UTC
Billy, any feedback for comment#8? Thanks.
Comment 10 Michael Fu 2008-07-10 00:10:19 UTC

*** This bug has been marked as a duplicate of bug 14611 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.