Bug 15539 - Backlight is set to off on Xorg start, Radeon Mobility X1700
Summary: Backlight is set to off on Xorg start, Radeon Mobility X1700
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/radeonhd (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Egbert Eich
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-16 13:29 UTC by Kirill Belokurov
Modified: 2008-04-19 12:57 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Xorg log with the git commit b6be09ff (38.12 KB, text/plain)
2008-04-16 13:29 UTC, Kirill Belokurov
no flags Details
Proposed fix. (839 bytes, patch)
2008-04-16 13:53 UTC, Egbert Eich
no flags Details | Splinter Review
Xorg log for git version, -verbose 7, without patch (65.27 KB, text/plain)
2008-04-17 00:10 UTC, Kirill Belokurov
no flags Details
Xorg log for git version, -verbose 7, with patch (65.27 KB, text/plain)
2008-04-17 00:11 UTC, Kirill Belokurov
no flags Details
Xorg log for last good revision (3893c), -verbose 7 (56.02 KB, text/plain)
2008-04-17 00:12 UTC, Kirill Belokurov
no flags Details
Xorg log for git version, -verbose 7, with patch (65.29 KB, text/plain)
2008-04-17 00:19 UTC, Kirill Belokurov
no flags Details
Another test patch. (643 bytes, patch)
2008-04-18 03:47 UTC, Egbert Eich
no flags Details | Splinter Review
Another test patch. (643 bytes, patch)
2008-04-18 03:48 UTC, Egbert Eich
no flags Details | Splinter Review
Another test patch. (643 bytes, patch)
2008-04-18 03:50 UTC, Egbert Eich
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Kirill Belokurov 2008-04-16 13:29:07 UTC
Created attachment 15960 [details]
Xorg log with the git commit b6be09ff

Tested on latest git: when Xorg starts, it sets the screen brightness to 0 (not sure if it is the same as 'off') - I see black screen with just a 'shadows' of login prompt.

Tracking with git bisect lead to the following first bad commit:
===========
commit b6be09ff1de86c8014d7605d7b6c93937252ea80
Author: Egbert Eich <eich@freedesktop.org>
Date:   Sun Apr 13 10:47:26 2008 +0200

    Save/Restore backlight controls, obtain initial brightness from text mode.

    The text mode BL state gets checked and is used for the initial BL brightness
    value. Furthermore the text mode BL value gets restored on VT switch and exit.
    This patch olso contains some minor cleanup to the BL code.
===========

I am attaching the Xorg log with radeonhd driver built for that commit - the suspicious line there is:
(II) RADEONHD(0): LVDSSetBacklight: trying to set BL_MOD_LEVEL to: 0

The text console doesn't have the initial brightness set to zero.

My card is ATI Technologies Inc M66-P [Mobility Radeon X1700]
Comment 1 Egbert Eich 2008-04-16 13:53:48 UTC
Created attachment 15962 [details] [review]
Proposed fix.

Please try this patch. It's possible that BL was disabled so the 0 value was not actually set.
If this patch doesn't help please post a log generated with -logverbose 7.
Comment 2 Egbert Eich 2008-04-16 21:37:57 UTC
Assigning to reporter for feedback. Kjrill, please assign back to me when done. Thanks.
Comment 3 Kirill Belokurov 2008-04-17 00:09:40 UTC
The patch didn't work. Attaching few Xorg logs with -logverbose 7
Comment 4 Kirill Belokurov 2008-04-17 00:10:34 UTC
Created attachment 15974 [details]
Xorg log for git version, -verbose 7, without patch
Comment 5 Kirill Belokurov 2008-04-17 00:11:14 UTC
Created attachment 15975 [details]
Xorg log for git version, -verbose 7, with patch
Comment 6 Kirill Belokurov 2008-04-17 00:12:03 UTC
Created attachment 15976 [details]
Xorg log for last good revision (3893c), -verbose 7
Comment 7 Kirill Belokurov 2008-04-17 00:17:42 UTC
Comment on attachment 15975 [details]
Xorg log for git version, -verbose 7, with patch

marking _wrong_ log as obsolete
Comment 8 Kirill Belokurov 2008-04-17 00:19:45 UTC
Created attachment 15977 [details]
Xorg log for git version, -verbose 7, with patch
Comment 9 Kirill Belokurov 2008-04-17 00:22:40 UTC
Reassigned back.
Comment 10 Kirill Belokurov 2008-04-17 00:54:42 UTC
Modified title of bug, as it may be confusing - looks like indeed, backlight is simply off (another user in mail-list has the same issue).
Comment 11 Egbert Eich 2008-04-18 03:47:30 UTC
Created attachment 16004 [details] [review]
Another test patch.

Kirill, could you please apply this patch on top of the other one and see if this works?
If it doesn't please use rhd_conntest <pci_bus> -d to dump your BIOS and email it to me (eich_at_suse_de).
Comment 12 Egbert Eich 2008-04-18 03:48:11 UTC
Created attachment 16005 [details] [review]
Another test patch.

Kirill, could you please apply this patch on top of the other one and see if this works?
If it doesn't please use rhd_conntest <pci_bus> -d to dump your BIOS and email it to me (eich_at_suse_de).
Comment 13 Egbert Eich 2008-04-18 03:50:14 UTC
Created attachment 16006 [details] [review]
Another test patch.

Kirill, could you please apply this patch on top of the other one and see if this works?
If it doesn't please use rhd_conntest <pci_bus> -d to dump your BIOS and email it to me (eich_at_suse_de).
Comment 14 Egbert Eich 2008-04-18 08:04:23 UTC
This issue should be fixed now with commit 0442f2d5b2e23648b51bbf659f5bcd874b2b438a
Comment 15 Kirill Belokurov 2008-04-19 12:57:10 UTC
Confirmed, the brightness is OK with the latest git revision.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.