Bug 15582 - Qt4 Demo missing animation
Qt4 Demo missing animation
Status: RESOLVED WONTFIX
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
git
x86-64 (AMD64) Linux (All)
: medium normal
Assigned To: Default DRI bug account
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-18 07:59 UTC by Bernd Buschinski
Modified: 2009-08-24 12:30 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
how it should look (154.91 KB, image/png)
2008-04-18 08:00 UTC, Bernd Buschinski
Details
how it looks with qt-4.3.4 (88.55 KB, image/jpeg)
2008-05-30 02:32 UTC, Bernd Buschinski
Details
qtdemo on qt 4.4.0 (210.30 KB, image/png)
2008-05-30 02:43 UTC, Vinay S Shastry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bernd Buschinski 2008-04-18 07:59:07 UTC
In the qtdemo app (Qt-4.3.4) there are some nice green moving balls that form figures, however they are missing on my intel 945GM

qt-4.3.4
mesa-git
drm-git
xf86-video-intel-2.2.99.903
xorg-server-git
(DRI1)
Comment 1 Bernd Buschinski 2008-04-18 08:00:20 UTC
Created attachment 16016 [details]
how it should look

you cant start the qtdemo app with
"qtdemo" :)
Comment 2 Vinay S Shastry 2008-05-30 00:10:38 UTC
The animated green balls show up with a self compiled Qt 4.4.0 on Archlinux

qt 4.4.0-1
intel-dri 7.0.3-1
xf86-video-intel 2.3.1-1 (Intel 954GM)
mesa 7.0.3-2
xorg-server 1.4.0.90-13
Comment 3 Bernd Buschinski 2008-05-30 02:32:39 UTC
Created attachment 16822 [details]
how it looks with qt-4.3.4

qt-4.3.4
mesa-7.0.3
xorg-server-1.4.0.90
xf86-video-intel-2.3.1

still doesnt work here :(
the only custom xorg.conf setting I have is
Option          "FramebufferCompression"        "false"
to work around a bug, but this shouldnt matter at all
Comment 4 Vinay S Shastry 2008-05-30 02:39:29 UTC
Hey, I'm using qt 4.4. The animation didn't show up in 4.3.X for me either.

May be it's some bug in the way qt looks for some opengl extension before enabling the animation, and it's fixed in 4.4?
Comment 5 Vinay S Shastry 2008-05-30 02:43:18 UTC
Created attachment 16823 [details]
qtdemo on qt 4.4.0
Comment 6 Bernd Buschinski 2008-05-30 08:24:55 UTC
I tried to emerge(gentoo/portage) Qt-4.4 but realised that the ebuilds arent masked for fun, they are broken as hell :)
Well anyway I failed installing qt-4.4 but I wonder, even if it is a bugfix in 4.4, why does it not happen on my nvidia maschine? It should be opengl too :)
I am not sure if this bug can be closed with this, maybe some more investigations.
Comment 7 Michael Fu 2008-06-23 18:44:02 UTC
doesn't sounds like driver bug.. I marks this as wontfix for now. please reopen if you tried qt-4.4 and still see this...
Comment 8 ajax at nwnk dot net 2009-08-24 12:30:00 UTC
Mass version move, cvs -> git