Bug 15609 (nv_G80) - nv: Missing Xv extension for G80 chipsets
Summary: nv: Missing Xv extension for G80 chipsets
Status: RESOLVED DUPLICATE of bug 11586
Alias: nv_G80
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: 7.2 (2007.02)
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Aaron Plattner
QA Contact: Xorg Project Team
URL: https://bugzilla.novell.com/show_bug....
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-19 09:39 UTC by Alexander Koenig
Modified: 2008-04-19 21:28 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Koenig 2008-04-19 09:39:07 UTC
I am running the 32bit (OpenSUSE 10.3) system on my 64bit hardware

Hardware:
Mainboard - MSI K9N Neo-F V2, NVIDIA Nforce 520, BIOS V2.3
Processor - AMD Athlon64 X2 5200+
Memory - 2x 2048MB Mushkin SP2-6400, CL5
Disk - 2x Samsung HD501LJ 500GB 7200, 16 MB Cache, SATA
DVD ROM - LG GDR - H20N, SATA
DVD RAM - LG GSA - H66N, SATA
Display - MSI NX8600GT-T2D256EZ, NVIDIA 8600GT, 256MB, PCI-Express

Symptoms:

xawtv window remains dark with nv driver, it works with proprietary nvidia
driver

DVB card and VDR are running, /dev/video0 is accessible. 

Messages when starting xawtv:
alexande@asterix:~> xawtv -geometry 640x480 -T DVB -device /dev/video0
This is xawtv-3.95, running on Linux/i686 (2.6.22.16-0.2-bigsmp)
xinerama 0: 1280x1024+0+0
WARNING: No DGA support available for this display.
WARNING: couldn't find framebuffer base address, try manual
         configuration ("v4l-conf -a <addr>")
config: invalid value for input: Camera
valid choices for "input": "DVB"
Xlib:  extension "GLX" missing on display ":0.0".
ioctl:
VIDIOC_TRY_FMT(type=VIDEO_OVERLAY;fmt.win.w.left=293;fmt.win.w.top=223;fmt.win.w.width=832;fmt.win.w.height=648;fmt.win.field=ANY;fmt.win.chromakey=0;fmt.win.clips=(nil);fmt.win.clipcount=0;fmt.win.bitmap=(nil)):
Das Argument ist ungültig


Comment from Stefan Dirsch <sndirsch@novell.com>:
I can reproduce this issue with a Quadro FX 4600 (similar to GeForce 8600, it's
also a G80 based card) when using nv driver. It doesn't happen with an Intel
onboard graphic (915G) using the intel driver. This is a nv driver issue.
xvinfo with nv driver also told me "no adaptors present". Looking at the
sources there is no Xv support. :-(



Please find further details and supporting files at:
https://bugzilla.novell.com/show_bug.cgi?id=360419
Comment 1 Aaron Plattner 2008-04-19 21:28:02 UTC

*** This bug has been marked as a duplicate of bug 11586 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.