Bug 15631 - Cannot install packages from repositories from which RPM-GPG-KEYs have not been installed.
Cannot install packages from repositories from which RPM-GPG-KEYs have not be...
Status: RESOLVED FIXED
Product: PackageKit
Classification: Unclassified
Component: backend-yum
unspecified
x86 (IA32) All
: medium normal
Assigned To: Richard Hughes
:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-21 09:05 UTC by Patrick Klingemann
Modified: 2008-09-26 08:02 UTC (History)
0 users

See Also:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Patrick Klingemann 2008-04-21 09:05:18 UTC
There does not appear to be a mechanism in PackageKit to import RPM-GPG-KEYs for new repositories.  Thus it is not possible to install packages from newly linked repositories.

Steps to reproduce:
1.  Add a new valid yum repository (software source).
2.  Open PackageKit.
3.  Select a package from the newly added repository.
4.  Click the install button.
5.  The installation hangs with "Checking Signatures" displayed in the statusbar.

Actual Results:
Installation hangs with "Checking Signatures" displayed in the statusbar.

Expected Results:
User is prompted to import the new repository's RPM-GPG-KEY and the package installs successfully.

Build Date/Platform:
PackageKit 0.1.12
Fedora 9 (rawhide) i686

Workaround:
1.  Add a new valid yum repository.
2.  Open a terminal.
3.  su root
4.  yum install package-name-from-new-repository
5.  You are then prompted to import the new RPM-GPG-KEY for the new repository.
6.  When the package finishes installing you should be able to install packages from the new repository via PackageKit.
Comment 1 Richard Hughes 2008-04-25 09:20:54 UTC
I think I've fixed this in KOJI, please could you verify: http://koji.fedoraproject.org/koji/buildinfo?buildID=47270 - thanks.
Comment 2 Patrick Klingemann 2008-04-25 15:44:37 UTC
Richard, there has been much discussion on this subject at the Fedora bugzilla: https://bugzilla.redhat.com/show_bug.cgi?id=443445 I tested the KOJI build and received the following error message:

A security trust relationship is not present
GPG key xxxxxxxxx is required

Was this the intended result?

Comment 3 Richard Hughes 2008-05-05 13:19:35 UTC
Should be fixed now?
Comment 4 Richard Hughes 2008-09-26 08:02:24 UTC
Works for me.