Bug 15645 - X server unloads keyboard and mouse drivers on logout
Summary: X server unloads keyboard and mouse drivers on logout
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/General (show other bugs)
Version: git
Hardware: All Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on: 14418
Blocks:
  Show dependency treegraph
 
Reported: 2008-04-22 02:02 UTC by Bernhard Rosenkraenzer
Modified: 2008-04-29 00:20 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Bernhard Rosenkraenzer 2008-04-22 02:02:27 UTC
When using kdm, logging out from a session with the current git x server returns to the kdm login screen as expected - but it doesn't take any keyboard or mouse input.

Checking /var/log/Xorg.0.log shows these new entries after returning to kdm:

(II) UnloadModule: "kbd"
(II) UnloadModule: "mouse"
(II) Open ACPI successful (/var/run/acpid.socket)
(II) APM registered successfully
(II) RADEONHD(0): Mapped IO at 0xb7f07000 (size 0x00010000)
(II) RADEONHD(0): Mapped FB at 0xa7e4d000 (size 0x10000000)
(II) RADEONHD(0): Using 2383 scanlines of offscreen memory
(II) RADEONHD(0): RandR 1.2 enabled, ignore the following RandR disabled message.
(II) RADEONHD(0): Using HW cursor
(**) RADEONHD(0): DPMS enabled
(--) RandR disabled
(II) AIGLX: Screen 0 is not DRI2 capable
(II) AIGLX: Screen 0 is not DRI capable
(II) GLX: Initialized MESA-PROXY GL provider for screen 0
(II) RADEONHD(0): Setting screen physical size to 376 x 301
(EE) Error loading keymap /var/lib/xkb/server-0.xkm
(EE) Error loading keymap /var/lib/xkb/server-0.xkm

The problem quite clearly appears to be the first 2 lines -- the keyboard and mouse drivers are both being unloaded (for no obvious reason) and not reloaded.


The X server is compiled without HAL support, and the keyboard/mouse settings are hardcoded in xorg.conf as

Section "ServerLayout"
	[...]
        InputDevice "Mouse0" "CorePointer"
        InputDevice "Keyboard0" "CoreKeyboard"
EndSection

Section "InputDevice"
        Identifier      "Mouse0"
        Driver          "mouse"
        Option "Device" "/dev/input/mice"
        Option "Emulate3Buttons" "on"
        Option "Protocol" "ExplorerPS/2"
        Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
        Identifier      "Keyboard0"
        Driver          "kbd"
        Option "XkbLayout" "de"
        Option "XkbModel" "pc105"
        Option "XkbVariant" "nodeadkeys"
EndSection
Comment 1 Julien Cristau 2008-04-22 05:27:35 UTC
(In reply to comment #0)
> When using kdm, logging out from a session with the current git x server
> returns to the kdm login screen as expected - but it doesn't take any keyboard
> or mouse input.
> 
Can you try reverting 6d22a9615a0e6ab3d00b0bcb22ff001b6ece02ae?
Comment 2 Bernhard Rosenkraenzer 2008-04-22 05:45:34 UTC
Reverting 6d22a9615a0e6ab3d00b0bcb22ff001b6ece02ae fixes it.

So does simply reverting the

CloseDevice -> DeleteInputDeviceRequest

change from 6d22a9615a0e6ab3d00b0bcb22ff001b6ece02ae
Comment 3 Peter Hutterer 2008-04-22 20:39:13 UTC
This bug is entwined with the original fix to 14418, so I'll mark it as a duplicate. See comment 14 to #14418.

https://bugs.freedesktop.org/show_bug.cgi?id=14418#c14

*** This bug has been marked as a duplicate of bug 14418 ***
Comment 4 Peter Hutterer 2008-04-23 21:58:52 UTC
Fixes pushed as 
9ab4e2fd8eaa87dbd16835affb1aa54dcb1a619e
aec485f2dcc87b340759d67b60e7dee7931aaec5 and
f377141912594f87144d6d7f7fdd279a101d8e6c

See bug 14418.
Comment 5 Peter Hutterer 2008-04-29 00:20:07 UTC
Removing duplicate status, there are two parts to the bug and the part this bug describes has been fixed.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.