Bug 15663 - Randr gives incorrect TV status
Summary: Randr gives incorrect TV status
Status: VERIFIED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Wang Zhenyu
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-04-22 20:11 UTC by WuNian
Modified: 2008-07-09 01:22 UTC (History)
2 users (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description WuNian 2008-04-22 20:11:11 UTC
+++ This bug was initially created as a clone of Bug #15559 +++

Created an attachment (id=15980)
xorg log file

2D source is git tip.
platform: 915GM

On our 915GM machine, the TV did not connect, but xrandr reported TV was connected.

output of "xrandr -q":

Screen 0: minimum 320 x 200, current 720 x 400, maximum 1024 x 1024
VGA disconnected (normal left inverted right x axis y axis)
LVDS connected 720x400+0+0 (normal left inverted right x axis y axis) 0mm x 0mm
   1024x768       60.0 +   85.0     75.0     70.1     60.0
   832x624        74.6
   800x600        85.1     72.2     75.0     60.3     56.2
   640x480        85.0     72.8     75.0     59.9
   720x400        85.0*
   640x400        85.1
   640x350        85.1
TV connected (normal left inverted right x axis y axis)
   1024x768       30.0 +
   800x600        30.0
   848x480        30.0
   640x480        30.0
Comment 1 WuNian 2008-04-22 20:15:09 UTC
attachment #15980 [details] is the bug's xorg log file. Same log with bug #15559.
Comment 2 Michael Fu 2008-04-29 18:10:06 UTC
do we know if this is a regression? can we bisect?
Comment 3 Gordon Jin 2008-04-29 18:35:30 UTC
but the log says "Output TV disconnected" correctly. It seems the TV load detect code is random.
Comment 4 Michael Fu 2008-04-30 16:28:29 UTC
"the TV load detect code is random -- it will say 'yes' and 'no' alternately on some machines" - Keithp
Comment 5 WuNian 2008-05-03 19:30:29 UTC
(In reply to comment #4)
> "the TV load detect code is random -- it will say 'yes' and 'no' alternately on
> some machines" - Keithp

Why is it random? Any comments?

Comment 6 Hong Liu 2008-05-03 22:38:58 UTC
(In reply to comment #5)
> Why is it random? Any comments?
> 

The reason is not clear for now :(
Comment 7 Gordon Jin 2008-06-30 01:40:03 UTC
We can't reproduce this on 915GM now, so closing it.
Comment 8 Michael Fu 2008-07-03 18:58:26 UTC
is bug# 16566 a dup of this one?
Comment 9 Gordon Jin 2008-07-03 19:41:12 UTC
Maybe related(In reply to comment #8)
> is bug# 16566 a dup of this one?
> 

Maybe related somewhat, but with totally different symptons.

15663 is no TV connected in fact but randr reports TV connected.
16566 is with TV connected in fact but randr reports TV disconnected.
Comment 10 Michael Fu 2008-07-03 22:21:13 UTC
(In reply to comment #9)
> Maybe related(In reply to comment #8)
> > is bug# 16566 a dup of this one?
> > 
> 
> Maybe related somewhat, but with totally different symptons.
> 
> 15663 is no TV connected in fact but randr reports TV connected.
> 16566 is with TV connected in fact but randr reports TV disconnected.
> 

that's why called "random"? :)
Comment 11 Michael Fu 2008-07-08 22:43:55 UTC
result of zhenyu's experiment yesterday:

it seems that pull the TV cable out and type in 'xrandr -q', it still say TV connected. But run 'xrandr --auto' will refresh the state, then 'xrandr -q' will give correct status.

Might because the test machine was once used for TV testing before performed this test.. close this bug anyway.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.