Bug 1616 - xvideo crashes in widescreen modus
Summary: xvideo crashes in widescreen modus
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/nVidia (open) (show other bugs)
Version: 6.8.1
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2004-10-13 01:16 UTC by Christian Schaller
Modified: 2006-05-24 11:31 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Christian Schaller 2004-10-13 01:16:29 UTC
Using the free nvidia driver it seems the xorg server is not able to
handle xvideo images when I set the screen to widescreen resolution.
Using a standard resolution this isn't a problem (using the binary
nvidia driver with FC2 this also worked).

I have a Dell Inspiron 8600 laptop which has a wider than standard
screen. 

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
[cschalle@cschalle movies]$ totem gravity.mpg


Actual Results:  The program 'totem' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadAlloc (insufficient resources for operation)'.
  (Details: serial 48 error_code 11 request_code 140 minor_code 19)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error()
function.)

Below is the xorg.conf lines I changed to cater for the wider screen.

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Dell 1400x1050 Laptop Display Panel"
        DisplaySize  331        207
        HorizSync    31.5 - 100.0
        VertRefresh  30.0 - 90.0
        Modeline "720x450"    33.92  720  765  841  963  450  451  454
 470
        Modeline "720x450"    39.04  720  770  846  972  450  451  454
 472
        Modeline "720x450"    46.79  720  774  850  981  450  451  454
 477
        Modeline "1280x800"  107.21 1280 1360 1496 1712  800  801  804
 835
        Modeline "1280x800"  123.38 1280 1368 1504 1728  800  801  804
 840
        Modeline "1280x800"  147.89 1280 1376 1512 1744  800  801  804
 848
        Modeline "1680x1050" 147.14 1680 1784 1968 2256 1050 1051 1054
1087
        Modeline "1680x1050" 188.07 1680 1800 1984 2288 1050 1051 1054
1096
        Modeline "1680x1050" 214.51 1680 1800 1984 2288 1050 1051 1054
1103
        Modeline "1680x1050" 256.20 1680 1808 1992 2304 1050 1051 1054
1112
        Modeline "1920x1200" 246.59 1920 2064 2272 2624 1200 1201 1204
1253
        Modeline "1920x1200" 282.74 1920 2072 2280 2640 1200 1201 1204
1260
        Modeline "1920x1200" 337.58 1920 2072 2288 2656 1200 1201 1204
1271
        Option      "dpms"
EndSection

Section "Screen"
        Identifier "Screen0"
        Device     "Videocard0"
        Monitor    "Monitor0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
                Modes    Modes    "1680x1050" "1280x800"
        EndSubSection
EndSection
Comment 1 Christian Schaller 2006-02-19 09:33:45 UTC
Over a year later and this is still the case. I hope someone could take a look
at this soon.
Comment 2 Erik Andren 2006-05-05 02:59:10 UTC
Are you experiencing the same issue with other movie playing softwares?
Comment 3 Erik Andren 2006-05-23 07:09:11 UTC
Ping!
Comment 4 Christian Schaller 2006-05-25 04:31:08 UTC
I am unable to reproduce now, but I think I got it with all video playback
applications way back then :) Anyway, I guess the bug is fixed now someplace or
the other. Closing as fixed :)


bug/show.html.tmpl processed on Jul 30, 2016 at 18:52:06.
(provided by the Example extension).