Bug 16169 - Buffer underrun with i945GM
Summary: Buffer underrun with i945GM
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/intel (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Jesse Barnes
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 16536 (view as bug list)
Depends on:
Blocks: 16467 intel-2.5
  Show dependency treegraph
 
Reported: 2008-05-30 09:41 UTC by Johannes Engel
Modified: 2008-08-20 17:08 UTC (History)
3 users (show)

See Also:
i915 platform:
i915 features:


Attachments
split dsparb appropriately (4.73 KB, patch)
2008-07-08 10:18 UTC, Jesse Barnes
no flags Details | Splinter Review
Xorg.0.log (12.97 KB, text/plain)
2008-07-15 15:45 UTC, Johannes Engel
no flags Details
fix dsparb split (5.33 KB, patch)
2008-07-17 10:08 UTC, Jesse Barnes
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Johannes Engel 2008-05-30 09:41:58 UTC
Using latest git xf96-video-intel I experience some buffer underruns on Pipe B together with a jittering of the image on the attached LVDS.
As Jesse told me I changed the critical value for DSPARB_BSTART_SHIFT from 64 to 48 and upto now it feels good. :)
Comment 1 Johannes Engel 2008-05-31 14:14:13 UTC
OK, it is not yet totally gone, but not that frequent as before.
Comment 2 Tino Keitel 2008-06-02 08:59:23 UTC
On my Mac mini Core Duo with i945, I also have a blank display after some time. In this case, I need to reboot to get the display back.
Comment 3 Jesse Barnes 2008-06-06 11:50:16 UTC
I'm still talking with the chipset guys about this; hopefully we'll have a resolution soon.
Comment 4 Jesse Barnes 2008-06-20 14:54:38 UTC
Out of curiosity, what does xrandr report on your machines?  Can you attach your X log with "modedebug" enabled?
Comment 5 Jesse Barnes 2008-07-08 10:15:37 UTC
*** Bug 16536 has been marked as a duplicate of this bug. ***
Comment 6 Jesse Barnes 2008-07-08 10:18:54 UTC
Created attachment 17574 [details] [review]
split dsparb appropriately

Can you guys give this patch a try?  Rather than statically allocating FIFO entries, it tries to choose a good split based on the programmed modes.  Hopefully this will fix things for people without introducing any regressions.
Comment 7 Jesse Barnes 2008-07-15 09:03:54 UTC
Johannes and/or Jonathan, can you give the attached patch a try?  It's one of the final blockers for the 2.4 release, I want to make sure it works.  If it doesn't, I've still got another idea we can try.
Comment 8 Johannes Engel 2008-07-15 15:45:35 UTC
Created attachment 17690 [details]
Xorg.0.log

I am sorry, Jesse, but your patch makes the whole thing even worse, since the display does not even come up.
Comment 9 Jesse Barnes 2008-07-17 10:08:59 UTC
Created attachment 17729 [details] [review]
fix dsparb split

Oops, had an off by one in there.  This one fixes that and includes 845/865 support too.  Please try again!
Comment 10 Johannes Engel 2008-07-17 14:26:25 UTC
That one seems to work perfectly. Thanks a lot! :)
Comment 11 Eric Anholt 2008-07-17 14:45:16 UTC
Committed a slight variation on the patch.  Thanks to everyone for testing on this one!
Comment 12 Tino Keitel 2008-07-17 22:18:19 UTC
In what branch was the commit? And what was the commit hash? The only relevant commit I see is in master, but that one (b37a2a8ca82279468e3806dcf77d5fa7bdd0e874) only talks about 855 chips.
Comment 13 Johannes Engel 2008-07-21 15:03:06 UTC
It is commit b8ca1c747a679c931267363639fc0bc690cae2d6.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct.