Bug 16173 - Rendering quality of Evince is poorer than that of Okular
Summary: Rendering quality of Evince is poorer than that of Okular
Status: RESOLVED DUPLICATE of bug 5589
Alias: None
Product: poppler
Classification: Unclassified
Component: cairo backend (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL: http://bugzilla.gnome.org/show_bug.cg...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-05-30 22:17 UTC by Michel Salim
Modified: 2010-01-24 10:30 UTC (History)
0 users

See Also:
i915 platform:
i915 features:


Attachments
Sample Evince output (129.45 KB, image/png)
2008-05-30 22:18 UTC, Michel Salim
Details
Sample Okular output (294.76 KB, image/png)
2008-05-30 22:19 UTC, Michel Salim
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michel Salim 2008-05-30 22:17:24 UTC
Evince and Okular use the same library to handle PDFs, but for some reason,
Okular's output is more smoothly anti-aliased. There does not seem to be any
applicable setting, both in the menus and using gconf-editor, to adjust how
much anti-aliasing is done in Evince.


Steps to reproduce:
1. Open a PS or PDF document (preferably older and scanned, rather than
LaTeX-generated)
2. Open the same document in Okular
3. Set zoom level to Fit Width in both and compare (the documents are otherwise
very different in size at the same zoom level. Bizarre)


Actual results:
Okular's output looks much better anti-aliased -- and does not render any
slower

Expected results:
Both outputs should be equivalent in quality -- okular uses poppler-qt4 for rendering, evince uses poppler-glib

Does this happen every time?
Yes

Other information:
This is on Fedora 9; Evince maintainer identified this as a Poppler bug (see URL)
Comment 1 Michel Salim 2008-05-30 22:18:21 UTC
Created attachment 16839 [details]
Sample Evince output
Comment 2 Michel Salim 2008-05-30 22:19:20 UTC
Created attachment 16840 [details]
Sample Okular output
Comment 3 Albert Astals Cid 2008-05-31 04:23:39 UTC
Please attach the file, without it little is possible to be done.
Comment 4 Michel Salim 2008-06-20 00:19:03 UTC
Not attaching the original PDF since that's not freely available, but this document demonstrates the differing output rendering just as well:

http://dspace.mit.edu/handle/1721.1/5790

(PS and PDF versions downloadable; file is too large to attach)
Comment 5 Carlos Garcia Campos 2010-01-24 10:30:32 UTC

*** This bug has been marked as a duplicate of bug 5589 ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.