Bug 1622 - X Server crashing at startup when forcing MonitorLayout option.
Summary: X Server crashing at startup when forcing MonitorLayout option.
Status: RESOLVED DUPLICATE of bug 1559
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.8.1
Hardware: x86 (IA32) Linux (All)
: high normal
Assignee: Xorg Project Team
QA Contact:
Depends on:
Blocks: 1690
  Show dependency treegraph
Reported: 2004-10-13 06:54 UTC by Dams
Modified: 2005-08-27 18:20 UTC (History)
6 users (show)

See Also:
i915 platform:
i915 features:

X configuration file. (/etc/X11/xorg.conf) (2.89 KB, text/plain)
2004-10-13 06:56 UTC, Dams
no flags Details
Xorg.0.log : X server log file (39.41 KB, text/plain)
2004-10-13 06:57 UTC, Dams
no flags Details
Patch to CVS head. (2.42 KB, patch)
2004-10-15 12:16 UTC, HUI YU
no flags Details | Splinter Review

Description Dams 2004-10-13 06:54:09 UTC
My monitor is actually mis-detected by the radeon driver (see bug #1514).
Following Mike Harris good advice, I tried to force the driver to use the CRT
monitor layout mode, so I added this line to the X configuration file : 
Option "Monitorlayout" "CRT,NONE"
In the radeon driver section. 

The X server crashed with segmentation fault at startup. 
See attached configuration and log files.

I'm using X11 6.8.1-4 packages from fedora project development tree. Hardware
configuration is :
- "Built By ATI" Radeon 7200 (QD)
- 22" CRT Mitsubishi Diamond Plus 230SB Monitor
Comment 1 Dams 2004-10-13 06:56:10 UTC
Created attachment 1098 [details]
X configuration file. (/etc/X11/xorg.conf)
Comment 2 Dams 2004-10-13 06:57:33 UTC
Created attachment 1099 [details]
Xorg.0.log : X server log file
Comment 3 Mike A. Harris 2004-10-13 10:59:53 UTC
What's rather odd with this one, is that Radeon 7200 is a singlehead
card with a single VGA output.  Some models have video out on them,
but I don't believe merged framebuffer mode works on them.  IIRC, the first
chip to support this is RV100 (Radeon VE/7000), which has 2 heads.

It appears the driver is trying to handle mergedfb modes even though
it isn't sensible on this adaptor.  Then it crashes.
Comment 4 HUI YU 2004-10-15 12:16:23 UTC
Created attachment 1111 [details] [review]
Patch to CVS head.

It's a driver bug, I missed this one in my test on 7200. Please try attached
patch with and without MonitorLayout option. Thanks.
Comment 5 Dams 2004-10-16 01:29:33 UTC
Hui : Marvelous ! It sure does work. Do you need any information from me (logs,
whatever..) to be sure that there is no side effect or something before the bug
gets closed ?

Mike : i'd appreciate if you would include this patch in your next X.org's X11
package set :)
Comment 6 Kevin E. Martin 2004-10-18 16:52:56 UTC
Hui's patch (from bug 1559) fixes this problem for me as well.

BTW, I traced down the problem here (before applying Hui's patch) and it occurs
when there are no modes for the secondary head.  RADEONGenerateModeList() has
valid data for "i" but "j" is NULL.  Perhaps a check should be made in this
routine to verify that "i" and "j" are not NULL.
Comment 7 Mike A. Harris 2004-10-20 00:03:51 UTC
Adding patch to our rpm for testing.  When making patches, it is best to
use unified diff format (diff -u) generated from the root of the tree, so
that the full path to the file is embedded in the patch, as that is the
easiest to work with.

Thanks for the fix Hui!
Comment 8 Mike A. Harris 2004-10-20 00:15:24 UTC
The text leading up to this was:
|diff -r1.23 xc/programs/Xserver/hw/xfree86/drivers/ati/radeon_driver.c
File to patch:
Skip this patch? [y]
5 out of 5 hunks ignored

The non-unified diff refuses to apply to our sources.  I've modified the
file path to be correct, and it still refuses to apply.  I'm not sure
what the problem is, but suspect it's non-obvious to me because I'm
incredibly tired, and nodding off at the keyboard a bit in last minute
cram for fixes.  ;o)  This could be an rpm glitch perhaps.

If someone can produce a unified diff that patches cleanly and attach
it, that'd be helpful.  I'm not sure how much longer I'll be awake though.
Comment 9 Mike A. Harris 2004-10-20 00:19:08 UTC
oops, last comment meant for bug 1559
Comment 10 Mike A. Harris 2004-10-20 00:21:23 UTC
God, I really am out of it.  It isn't bug 1559, it is this one.  From
comment #4
Comment 11 Mike A. Harris 2004-10-20 00:30:00 UTC
Ok, this is incredibly strange.  I've manually applied the patch to a fresh
untarred tree, but had to manually give it the file path, then it applied
with fuzz.

Now, the freshly generated unified diff I created, also wont reply and gives
the exact same error.  The problem I was having seems to be a diff bug
perhaps.  caillon said he saw some strange issue also this week like this,
so perhaps I'm not as insane as I feared.  ;o)
Comment 12 Mike A. Harris 2004-10-20 00:50:52 UTC
Ok, the patch from comment #4 in this bug is obsoleted by the patch
in comment #29 in bug #1559.  That was a bit confusing, but was hard
to discover due to the difference in patch formats. ;o)
Comment 13 HUI YU 2004-10-20 06:39:49 UTC
Hi Mike, the patch from comment #4 in this bug is the first one I posted only
for this bug (I forgot to turn on unified diff flag). Then I noticed more same
or related bug reports in Bug 1559, so I posted an improved version there
including the fix for this bug and a few related ones. The only thing hasn't
been varified for the patch in Bug 1559 is the change in radeon_bios.c, which is
meant to fix the problems with parsing BIOS connector information table. I
should have marked the patch in this bug obsolete earlier, sorry for the confusion.
Comment 14 HUI YU 2004-10-20 06:41:53 UTC
Comment on attachment 1111 [details] [review]
Patch to CVS head.

See improved version in Bug 1559.
Comment 15 Mike A. Harris 2004-10-20 11:00:59 UTC
Ok, thanks Hui.  We've got the patch from bug 1599 in our latest package for
testing now.  We should get a decent idea of the results over the next few
days, once we fix another glitch or two we created in the process.  ;o)

Take care,
Comment 16 Adam Jackson 2005-07-03 13:24:41 UTC
so was this ever applied to CVS?  is it still relevant?
Comment 17 Adam Jackson 2005-08-28 11:20:16 UTC
this appears to have been applied as rev 1.28 of radeon_driver.c:


*** This bug has been marked as a duplicate of 1559 ***

Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.