Bug 16224 - Opening new window causes external monitor to momentarily blank
Opening new window causes external monitor to momentarily blank
Status: RESOLVED NOTOURBUG
Product: xorg
Classification: Unclassified
Component: Driver/intel
git
Other All
: medium normal
Assigned To: Gordon Jin
Xorg Project Team
: NEEDINFO
: 16947 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2008-06-03 22:40 UTC by Ben Gamari
Modified: 2008-09-01 05:43 UTC (History)
5 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Xorg log (214.49 KB, text/plain)
2008-06-03 22:40 UTC, Ben Gamari
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ben Gamari 2008-06-03 22:40:45 UTC
Created attachment 16908 [details]
Xorg log

When running dual-heads on my 965, opening a new window causes the VGA output to blank momentarily (a second or so), apparently while the xserver conducts an EDID query judging from the hundreds of lines of modelines accumulating in my Xorg.log. Running xf86-video-intel and xserver from git.
Comment 1 Jesse Barnes 2008-06-10 18:04:56 UTC
That's weird... the driver definitely shouldn't be causing that sort of behavior.  Maybe your desktop environment is configured strangely causing RandR event when windows open?  Or maybe your .bashrc has a call to xrandr in it or something?
Comment 2 Michael Fu 2008-07-10 01:03:41 UTC
sounds not our driver related...
Comment 3 Julien Cristau 2008-07-10 03:24:00 UTC
> --- Comment #1 from Jesse Barnes <jbarnes@virtuousgeek.org>  2008-06-10 18:04:56 PST ---
> That's weird... the driver definitely shouldn't be causing that sort of
> behavior.  Maybe your desktop environment is configured strangely causing RandR
> event when windows open?  Or maybe your .bashrc has a call to xrandr in it or
> something?
> 
It seems that gtk 2.13 calls XRRGetScreenResources() on startup, which
causes a call to xf86ProbeOutputModes() in the server, which leads to
load detection and loss.
Comment 4 Ben Gamari 2008-07-10 05:57:16 UTC
Sounds about right to me. I'm running gtk+-2.13.0. What needs to be fixed, here: the xserver, the driver, or gtk?
Comment 5 Eric Piel 2008-07-21 05:58:53 UTC
After upgrading to gtk 2.13, I've got the same problem. I expect to turn epileptic rather soon ;-)

Although this problem is exacerbated by the new gtk behaviour, the problem has always been there for instance with xrandr: every single call to xrandr turns off and on my VGA monitor. Would there be a way to avoid stopping the signals when probing the outputs? Either by doing caching or just by keeping the signal live all the time?
Comment 6 Ben Gamari 2008-07-21 15:47:40 UTC
If I'm not mistaken, EDID transfers are done in-band and thus will cause the monitor to lose sync. There's really no way around it. From the recent thread on the mailing list, it sounds like the solution is to fix GTK to not rely so heavily on calls to XRRGetScreenResources().
Comment 7 Ben Gamari 2008-07-28 07:05:36 UTC
For the record, I'm now seeing LVDS blanking on opening a window as well. I get the following in Xorg.0.log with every window,

(II) intel(0): EDID vendor "SEC", prod id 12885
(II) intel(0): Printing DDC gathered Modelines:
(II) intel(0): Modeline "1920x1200"x0.0  167.80  1920 2020 2052 2264  1200 1202 1208 1235 -hsync -vsync (74.1 kHz)
(II) intel(0): EDID vendor "SEC", prod id 12885
(EE) intel(0): underrun on pipe B!
Comment 8 Gordon Jin 2008-08-01 23:42:42 UTC
*** Bug 16947 has been marked as a duplicate of this bug. ***