Bug 16388 - [GEM 945]'shadowtex' displays nothing but a black window
[GEM 945]'shadowtex' displays nothing but a black window
Status: VERIFIED FIXED
Product: Mesa
Classification: Unclassified
Component: Drivers/DRI/i915
unspecified
Other Linux (All)
: medium normal
Assigned To: Eric Anholt
:
Depends on:
Blocks: 18841 intel-3d-release
  Show dependency treegraph
 
Reported: 2008-06-17 01:32 UTC by liuhaien
Modified: 2009-08-23 02:22 UTC (History)
1 user (show)

See Also:


Attachments
shadowtex_image (295.85 KB, image/png)
2008-06-17 01:32 UTC, liuhaien
Details
Xorg.0.log (25.86 KB, text/plain)
2008-06-17 01:39 UTC, liuhaien
Details
xorg conf file (3.65 KB, text/plain)
2008-06-17 01:42 UTC, liuhaien
Details
Image of shadowtex on 965G (7.31 KB, image/jpeg)
2008-07-18 09:44 UTC, Ian Romanick
Details

Note You need to log in before you can comment on or make changes to this bug.
Description liuhaien 2008-06-17 01:32:25 UTC
Created attachment 17172 [details]
shadowtex_image

System Environment:
--------------------------
Host:           945
Arch:           i386
Kernel:         2.6.26-rc5
Libdrm_gem:drm-gem branch       3e48e144992fb11b31875989d45bc8a7c041cdef
Mesa_gem: drm-gem branch        407ce3da3c53c9ebba0fbf827d7b0f610122d44b
Xserver: master                  8c9234a163eceda2abc0a2523e0f5587ea399935
Xf86_video_intel_gem:drm-gem branch    d775ddc64dc8349b8ef9e85b0be9e93cb1997fea

Bug detailed description:
--------------------------
start X,then run 'shadowtex' with GEM ,it displays nothing but a black window as is shown in the attached image. 

Reproduce steps:
----------------
1.xinit&
2../shadowtex
Comment 1 liuhaien 2008-06-17 01:39:05 UTC
Created attachment 17173 [details]
Xorg.0.log
Comment 2 liuhaien 2008-06-17 01:42:14 UTC
Created attachment 17175 [details]
xorg conf file
Comment 3 Eric Anholt 2008-06-26 16:00:34 UTC
Also seen on my system.  Unclear what's going on.
Comment 4 liuhaien 2008-07-14 00:12:34 UTC
with the latest commit, this bug still exists.
Comment 5 Ian Romanick 2008-07-18 09:44:30 UTC
Created attachment 17751 [details]
Image of shadowtex on 965G

I get different incorrect results on my 965G system.  When run in fixed function mode, shadowtex just modulates the surface color with the shadow depth value.  It effectively uses the depth image as a GL_LUMINANCE texture.  In fragment program mode correct results are produced.

This is with bits recent as of last night on a x86_64 build.
Comment 6 liuhaien 2008-07-29 23:35:14 UTC
it still exists with the latest GEM.
Comment 7 liuhaien 2008-08-05 23:58:01 UTC
We've just tried the latest drm-gem for all components except drm module and kernel from anholt's linux-2.6 tree drm-gem-merge branch.this issue still exists.
Comment 8 liuhaien 2008-08-14 19:09:08 UTC
this issue still exists in the latest commit of master.
Comment 9 liuhaien 2008-08-31 19:02:18 UTC
this issue still exists in the latest commit.
Comment 10 liuhaien 2008-10-27 19:45:33 UTC
this issue still exists with the latest master and drm-intel-next kernel.
Comment 11 liuhaien 2008-12-09 00:04:12 UTC
still exists against below:
xf86_video_intel   xf86-video-intel-2.6-branch
       commit b156b3165e1aae5df0353737d0335ac2e653f5fd

mesa   intel-2008-q4 branch
       commit 154a9e5317f890618932cea0129ef887e16baf84

kernel  for-airlied branch
        commit 66647dc60d16fae9f6963fd98b6d9baa1a8dac69

libdrm  master branch
       commit b0d93c74d884b40bd94469a5ef75fdb2fef17680

xserver 1.6 
Comment 12 liuhaien 2008-12-09 00:05:00 UTC
(In reply to comment #11)
> still exists against below:
> xf86_video_intel   xf86-video-intel-2.6-branch
>        commit b156b3165e1aae5df0353737d0335ac2e653f5fd
> 
> mesa   intel-2008-q4 branch
>        commit 154a9e5317f890618932cea0129ef887e16baf84
> 
> kernel  for-airlied branch
>         commit 66647dc60d16fae9f6963fd98b6d9baa1a8dac69
> 
> libdrm  master branch
>        commit b0d93c74d884b40bd94469a5ef75fdb2fef17680
> 
> xserver 1.6 
> 

GEM kernel (for-airlied)6c76409370d7ee18208a7adfa5f8dabf8a42a274
Comment 13 liuhaien 2008-12-09 00:05:20 UTC
(In reply to comment #11)
> still exists against below:
> xf86_video_intel   xf86-video-intel-2.6-branch
>        commit b156b3165e1aae5df0353737d0335ac2e653f5fd
> 
> mesa   intel-2008-q4 branch
>        commit 154a9e5317f890618932cea0129ef887e16baf84
> 
> kernel  for-airlied branch
>         commit 66647dc60d16fae9f6963fd98b6d9baa1a8dac69
> 
> libdrm  master branch
>        commit b0d93c74d884b40bd94469a5ef75fdb2fef17680
> 
> xserver 1.6 
> 

GEM kernel (for-airalied)6c76409370d7ee18208a7adfa5f8dabf8a42a274
Comment 14 Eric Anholt 2008-12-19 14:10:36 UTC
This has been going on since the previous release (basically, since FBO support landed), and I don't think it's release-blocker quality.
Comment 15 liuhaien 2009-02-24 00:29:49 UTC
(In reply to comment #14)
> This has been going on since the previous release (basically, since FBO support
> landed), and I don't think it's release-blocker quality.
> 

still exists with below commits:
Libdrm:         (master)4a0d19ef4f210cea9e60c5acc355df03723ef808
Mesa:           (mesa_7_4_branch)e2092bb23c956ba9ab940935f803ef843db81af2
Xserver:        (server-1.6-branch)4557b3f6c4273cd83b701beaf7a150c806fed298
Xf86_video_intel:              
(master)81c652e9a666a7459bcc5217c8a5ec518b6e00da
GEM_kernel:       (for-airlied)99d31f896d243c13bb90b56620d33b416a5cffa7
Comment 16 liuhaien 2009-03-18 23:46:40 UTC
verified against:
Libdrm:         (master)2e2e8575b1ed4703653a72ac2b60b75316c388d7
Mesa_stable:            (mesa_7_4_branch)a8528a2e8653b5237c1d1d66fe98c6e031d007f9
Xserver:(server-1.6-branch) 60c161545af80eb78eb790a05bde79409dfdf16e
Xf86_video_intel:                (2.7)238c2c40afd9f8b61479b8640d53f20d52fd7ddf
Kernel:       (for-airlied)dc529a4fe1ae4667c819437a94185e8581e1e680