Bug 16416 - ExaOptimizeMigration still broken
Summary: ExaOptimizeMigration still broken
Status: RESOLVED WORKSFORME
Alias: None
Product: xorg
Classification: Unclassified
Component: Server/Acceleration/EXA (show other bugs)
Version: git
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Xorg Project Team
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-06-18 09:44 UTC by Andrew Randrianasulu
Modified: 2011-10-10 14:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
screenshot, look for text field "In group" (202.18 KB, image/jpeg)
2008-06-18 09:44 UTC, Andrew Randrianasulu
no flags Details
xorg.conf (6.47 KB, text/plain)
2008-06-18 09:44 UTC, Andrew Randrianasulu
no flags Details
xorg log (45.51 KB, text/plain)
2008-06-18 09:45 UTC, Andrew Randrianasulu
no flags Details
simple html page (293 bytes, text/plain)
2008-06-19 14:32 UTC, Andrew Randrianasulu
no flags Details
css file (4.90 KB, text/plain)
2008-06-19 14:34 UTC, Andrew Randrianasulu
no flags Details
Xorg.log with EXA debug enabled (84.75 KB, text/plain)
2008-06-19 14:37 UTC, Andrew Randrianasulu
no flags Details
xorg.log with optimization enabled, same EXA debug level (84.70 KB, text/plain)
2008-06-19 14:39 UTC, Andrew Randrianasulu
no flags Details
screenshot (35.14 KB, image/jpeg)
2008-06-19 14:47 UTC, Andrew Randrianasulu
no flags Details
fonts from my machine (646.03 KB, application/octet-stream)
2008-06-25 20:41 UTC, Andrew Randrianasulu
no flags Details
probably broken font (*.pcf) (5.61 KB, application/octet-stream)
2008-06-25 21:12 UTC, Andrew Randrianasulu
no flags Details
more visible corruption, with "EXANoComposite" "1" (155.90 KB, image/png)
2008-07-30 07:04 UTC, Andrew Randrianasulu
no flags Details
Example for corruption 1 (121.86 KB, image/png)
2010-04-10 02:37 UTC, Jure Repinc
no flags Details
Example for corruption 2 (132.15 KB, image/png)
2010-04-10 02:38 UTC, Jure Repinc
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andrew Randrianasulu 2008-06-18 09:44:18 UTC
Created attachment 17212 [details]
screenshot, look for text field "In group"

I have 

X server from git master - 068fa63496c7c363706f0d356b5132bc591c04c6
pixman from git master - commit eb2d95de98683a387153f010077ad9c3c3b1b01d
xf86-video-ati git master -  eed241553748125e902c44dcc8cf8e0605be071b
drm -  59112c9e521d1543e8b76635ef223e7f29d35e6a

Video hardware - 
01:00.0 VGA compatible controller: ATI Technologies Inc RV280 [Radeon 9200 SE] (rev 01)

Monitor - SyncMaster 550s, mode 1024x768, 24 bit, 75hz plugged into VGA
Additional monitor in clone mode - same model, same mode, plugged into DVI (DVI-A)

I have strange artifacts while scrolling gmane's search page, using SeaMonkey 1.1.9 _GTK1_ build.

Artifacts can be fixed by doing any from following actions:
1) Use SeaMonkey GTK2 version.
2) Resize application window to weight < 900.
3) Insert Option "EXAOptimizeMigration" "0" in my Xorg.conf
Comment 1 Andrew Randrianasulu 2008-06-18 09:44:55 UTC
Created attachment 17213 [details]
xorg.conf
Comment 2 Andrew Randrianasulu 2008-06-18 09:45:21 UTC
Created attachment 17214 [details]
xorg log
Comment 3 Andrew Randrianasulu 2008-06-18 10:00:12 UTC
Additional comment: please, scroll with mouse wheel or arrow keys - scrolling by dragging scrollbar not always trigger this bug.
Comment 4 Michel Dänzer 2008-06-19 02:49:37 UTC
Does the problem also occur without Option "AccelDFS"?

A simpler test case would be helpful.
Comment 5 Andrew Randrianasulu 2008-06-19 14:32:30 UTC
Created attachment 17238 [details]
simple html page

This bug look generic enough - i have it even on nouveau. Same option Option "EXAOptimizeMigration" "0" fixes it here, too. On rv280 - accelDFS "0" give me  no result.

About this html - if you add corresponding css file to it, and use default style you will see nice black input field right at startup. (in Linux GTK1 build from http://www.seamonkey-project.org/releases/)
Comment 6 Andrew Randrianasulu 2008-06-19 14:34:50 UTC
Created attachment 17239 [details]
css file

unmodified *.css as saved by seamonkey.
Comment 7 Andrew Randrianasulu 2008-06-19 14:37:31 UTC
Created attachment 17240 [details]
Xorg.log with EXA debug enabled

Just started twm + seamonkey with simple.html in it. (**) RADEON(0): Option "EXAOptimizeMigration" "0"

Next file will be from radeon too, but without this option.
Comment 8 Andrew Randrianasulu 2008-06-19 14:39:59 UTC
Created attachment 17241 [details]
xorg.log with optimization enabled, same EXA debug level

both logs from x server 1.5.99, git master commit 155fcecb320dbcfb899d6bcd78048ce0993bf28b.
Comment 9 Andrew Randrianasulu 2008-06-19 14:47:01 UTC
Created attachment 17242 [details]
screenshot
Comment 10 Andrew Randrianasulu 2008-06-25 20:40:43 UTC
Looks like i have broken font(s): bug only present if i have  
FontPath "/usr/X11R7/lib/X11/fonts/cp1251/75dpi" in my xorg.conf.

I'll attach archive with these fonts .... 
Comment 11 Andrew Randrianasulu 2008-06-25 20:41:48 UTC
Created attachment 17385 [details]
fonts from my machine
Comment 12 Andrew Randrianasulu 2008-06-25 21:12:42 UTC
Created attachment 17386 [details]
probably broken font (*.pcf)

At least without this font everything is normal.
Comment 13 Michel Dänzer 2008-06-26 22:55:08 UTC
I've reproduced the problem with a different font. I don't think the problem is directly related to the font.
Comment 14 Andrew Randrianasulu 2008-07-30 07:04:18 UTC
Created attachment 18000 [details]
more visible corruption, with "EXANoComposite" "1"

May be this is another bug, but now ("EXANoComposite" "1" in xorg.conf) i can see various image corruption everywhere, in gtk2/qt3/kde apps, all font-related.

(same result with nouveau (tnt2,nv40) and radeon drivers).
Comment 15 Michel Dänzer 2008-07-30 09:15:22 UTC
(In reply to comment #14)
> May be this is another bug, 

No need to speculate... If

       Option "EXAOptimizeMigration" "off"

works around the problem, it may be the same bug, otherwise it's not.


> (same result with nouveau (tnt2,nv40) and radeon drivers).

With radeon, does it also happen if you disable the DRI?
Comment 16 Andrew Randrianasulu 2008-07-30 11:09:27 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > May be this is another bug, 
> 
> No need to speculate... If
> 
>        Option "EXAOptimizeMigration" "off"
> 
> works around the problem, it may be the same bug, otherwise it's not.
> 
> 
> > (same result with nouveau (tnt2,nv40) and radeon drivers).
> 
> With radeon, does it also happen if you disable the DRI?
> 

yes, xserver master commit a3afa6f2fb80489f7b6a88d12def09281d32ed94 , xf86-video-ati commit 1f3eee3682f3598a303c9c3accfbe01b245cacf9, pixman commit dfe1f63f709fc711c15d1be317dc1404d72b3efd, DRI off - bug still here.

Comment 17 Michel Dänzer 2009-05-09 10:53:25 UTC
I'm having a hard time reproducing this with EXA from current upstream xserver Git. Can you try that?
Comment 18 Jure Repinc 2010-04-10 02:36:30 UTC
I started to have this problem after I upgraded my machine from xorg-server 1.6.4 to 1.8.0. It happens quite often, especially after I resume my laptop (HP Compaq nx6325 with RS482) from suspend to RAM. it looks like in 1.6.4 ExaOptimizeMigration was disabled by default and now in 1.8.0 it is enabled by default. When I disable it manualy problems with corruption seem to be gone. O, I'm using xf86-video-ati from git.
Comment 19 Jure Repinc 2010-04-10 02:37:29 UTC
Created attachment 34864 [details]
Example for corruption 1
Comment 20 Jure Repinc 2010-04-10 02:38:02 UTC
Created attachment 34865 [details]
Example for corruption 2
Comment 21 Raúl 2010-04-22 09:10:30 UTC
Hi:

I'm having similar problems with slightly different versions:
libdrm2: 2.4.18
radeon: 6.13.0
mesa 7.7.1
xserver: 1.7.6.901

I've found that maybe "EXANoDownloadFromScreen" would workaround "Example for corruption 1", but not the example 2 which I can't avoid so far.

Maybe you could try that option too.

Regards,
Comment 22 Matt Turner 2010-12-02 19:34:29 UTC
Any updates? Is this still a problem?
Comment 23 Jeremy Huddleston Sequoia 2011-10-10 14:05:23 UTC
No response, so closing.  If this is still an issue, please reopen with 
additional information.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.