Bug 16519 - Additional keys for remotes
Summary: Additional keys for remotes
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Protocol/Core (show other bugs)
Version: unspecified
Hardware: Other All
: medium normal
Assignee: Daniel Stone
QA Contact: Xorg Project Team
URL:
Whiteboard:
Keywords:
: 2337 (view as bug list)
Depends on:
Blocks:
 
Reported: 2008-06-25 09:27 UTC by Bastien Nocera
Modified: 2011-10-17 03:05 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
add a few keys to the keysyms (621 bytes, patch)
2008-06-25 09:27 UTC, Bastien Nocera
no flags Details | Splinter Review
Updated patch (1.58 KB, patch)
2008-07-02 06:37 UTC, Bastien Nocera
no flags Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Bastien Nocera 2008-06-25 09:27:04 UTC
Created attachment 17376 [details] [review]
add a few keys to the keysyms

This is needed for some HID remote controls to work under X.

XF86XK_AudioForward = KEY_FASTFORWARD
XF86XK_AudioRepeat = ...
XF86XK_AudioRandomPlay = KEY_SHUFFLE (the HID Usage Tables call it "Random Play")

(Turns out there's no KEY_REPEAT in the Linux kernel headers...)

I have half-a-gazillion more to be able to support the PS3 Bluetooth remote.
Comment 1 Bastien Nocera 2008-06-26 08:38:01 UTC
FYI, the definition for repeat was added:
#define KEY_MEDIA_REPEAT 0x1b7

I'll put up an updated patch with more of the keys I would need later on.
Comment 2 Bastien Nocera 2008-07-02 06:37:22 UTC
Created attachment 17478 [details] [review]
Updated patch

This should be good enough to support the new keys I need for Sony Ericsson phones remote, and PS3 BD remotes.
Comment 3 Peter Hutterer 2008-10-14 21:04:46 UTC
Pushed, thanks.

x11proto: 1cf41088ff751e60071a519466b5a51b65c7626a
libX11: 39c0b266cac8cbc15bf501d7869186862f01d823
Comment 4 Jeremy Huddleston Sequoia 2011-10-17 03:05:47 UTC
*** Bug 2337 has been marked as a duplicate of this bug. ***


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.