Bug 16575 - hal ignores fdi files containing uint64 merges
Summary: hal ignores fdi files containing uint64 merges
Status: RESOLVED FIXED
Alias: None
Product: hal
Classification: Unclassified
Component: libhal (show other bugs)
Version: unspecified
Hardware: Other All
: low normal
Assignee: David Zeuthen (not reading bugmail)
QA Contact:
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2008-07-01 04:06 UTC by Sense Hofstede
Modified: 2008-08-11 07:03 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
fix for the bug (719 bytes, patch)
2008-07-01 15:28 UTC, Danny Kukawka
Details | Splinter Review

Note You need to log in before you can comment on or make changes to this bug.
Description Sense Hofstede 2008-07-01 04:06:34 UTC
Thorsten Schoel reported this a while ago at Launchpad:
"Since the update to 0.5.9 in feisty-backports hal does no longer accept fdi files which contain a merge with type="uint64". Such files are simply ignored. Usually this is not a problem since hal (i.e. hal-info in 0.5.9) doesn't come with any such fdi files but it potentially makes the use of certain user provided fdi files impossible (as in my case). Downgrading to 0.5.8.1 solved the problem for me."

After I asked him whether the bug was still present in the latest version he told me that he could still reproduce it. 
He provided this example file:

<?xml version="1.0" encoding="UTF-8"?>

<deviceinfo version="0.2">
        <device>
                <match key="@info.parent:storage.cdrom.cdr" bool="true">
                <match key="block.is_volume" bool="true">
                        <merge key="foo" type="string">foo</merge>
                        <merge key="bar" type="uint64">12345</merge>
                </match>
                </match>
        </device>
</deviceinfo>

Removing the uint64 merge makes HAL detect the fdi file again.

The Launchpad bug report: https://bugs.launchpad.net/ubuntu/+source/hal/+bug/116264

The latest version of HAL in Ubuntu is 0.5.11~rc2-1ubuntu8.1
Comment 1 Danny Kukawka 2008-07-01 15:28:52 UTC
Created attachment 17474 [details] [review]
fix for the bug

Without any deeper test.
Comment 2 Danny Kukawka 2008-07-01 15:32:03 UTC
I really don't understand why the Ubuntu guys (always) report such trivial bugs upstream without fixing them while you are able to confirm the bug. Sorry, but this behavior leaves bad karma!
Comment 3 Sense Hofstede 2008-07-02 01:16:51 UTC
(In reply to comment #2)
> I really don't understand why the Ubuntu guys (always) report such trivial bugs
> upstream without fixing them while you are able to confirm the bug. Sorry, but
> this behavior leaves bad karma!
> 

I think that was my fault. I triaged the bug and reported it upstream after it was confirmed. I'm not a developer by myself, so I didn't (have the time to) look if I could find the cause. I'm just a Bug Triager. ;)

Anyway, thank you for the fast response. I'll ask if someone can test this patch.
Comment 4 Sense Hofstede 2008-07-17 02:57:46 UTC
The path has been tested and it works. It's not a very complex patch, so it isn't a surprise, but I thought it would be good to let you know.
Comment 5 Danny Kukawka 2008-08-11 07:03:34 UTC
Commited patch to git master.


bug/show.html.tmpl processed on Mar 29, 2017 at 19:02:18.
(provided by the Example extension).