Bug 1661 - X crashes w/ Composite
Summary: X crashes w/ Composite
Status: RESOLVED FIXED
Alias: None
Product: xorg
Classification: Unclassified
Component: Driver/Radeon (show other bugs)
Version: 6.8.0
Hardware: PowerPC Linux (All)
: high major
Assignee: Xorg Project Team
QA Contact:
URL:
Whiteboard:
Keywords: want-backtrace
Depends on:
Blocks:
 
Reported: 2004-10-18 01:58 UTC by George Wright
Modified: 2007-02-22 14:27 UTC (History)
1 user (show)

See Also:
i915 platform:
i915 features:


Attachments
Configuration file for one monitor. (3.03 KB, text/plain)
2004-12-28 12:50 UTC, Douglas
no flags Details
Single Monitor configuration Log file (31.84 KB, text/plain)
2004-12-28 12:51 UTC, Douglas
no flags Details

Note You need to log in before you can comment on or make changes to this bug.
Description George Wright 2004-10-18 01:58:02 UTC
Hardware: PowerBook G4 with ATI Radeon 9600 Mobility 64MB 
 
When a game such as Kolf is loaded, several messages are sent to stderr saying: 
 
X Error: BadAlloc (insufficient resources for operation) 11 
 
The second time the application is run in the same xorg session, xorg will 
crash. Nothing relevant seems to be sent to /var/log/Xorg.0.log. 
 
This is my xorg.conf: 
 
Section "ServerLayout" 
Identifier     "XFree86 Configured" 
Screen      0  "Screen0" 0 0 
InputDevice    "Mouse0" "CorePointer" 
InputDevice    "Keyboard0" "CoreKeyboard" 
EndSection 
 
Section "Files" 
RgbPath      "/usr/X11R6/lib/X11/rgb" 
ModulePath   "/usr/X11R6/lib/modules" 
FontPath     "/usr/X11R6/lib/X11/fonts/truetype" 
FontPath     "/usr/X11R6/lib/X11/fonts/TTF" 
FontPath     "/usr/X11R6/lib/X11/fonts/misc/" 
FontPath     "/usr/X11R6/lib/X11/fonts/Speedo/" 
FontPath     "/usr/X11R6/lib/X11/fonts/Type1/" 
FontPath     "/usr/X11R6/lib/X11/fonts/CID/" 
FontPath     "/usr/X11R6/lib/X11/fonts/75dpi/" 
FontPath     "/usr/X11R6/lib/X11/fonts/100dpi/" 
FontPath     "/usr/share/fonts/corefonts" 
EndSection 
 
Section "Module" 
Load  "extmod" 
Load  "dri" 
Load  "dbe" 
Load  "record" 
Load  "xtrap" 
Load  "glx" 
Load  "speedo" 
Load  "type1" 
EndSection 
 
Section "InputDevice" 
Identifier  "Keyboard0" 
Driver      "keyboard" 
Option      "XkbModel"    "Macintosh" 
Option      "XkbLayout"   "us" 
Option      "XkbRules"    "xfree" 
EndSection 
 
Section "InputDevice" 
Identifier  "Mouse0" 
Driver      "mouse" 
Option  "Protocol"        "IMPS/2" 
Option          "ZAxisMapping"  "4 5" 
Option          "Device"        "/dev/input/mice" 
EndSection 
 
Section "Monitor" 
Identifier   "Monitor0" 
VendorName   "Monitor Vendor" 
ModelName    "Monitor Model" 
UseModes        "Modes0" 
HorizSync       30-70 
VertRefresh     50-160 
EndSection 
 
Section "Device" 
### Available Driver options are:- 
### Values: <i>: integer, <f>: float, <bool>: "True"/"False", 
### <string>: "String", <freq>: "<f> Hz/kHz/MHz" 
### [arg]: arg optional 
#Option     "NoAccel"                   # [<bool>] 
#Option     "SWcursor"                  # [<bool>] 
#Option     "Dac6Bit"                   # [<bool>] 
#Option     "Dac8Bit"                   # [<bool>] 
#Option     "ForcePCIMode"              # [<bool>] 
#Option     "BusType"                   # [<str>] 
#Option     "CPPIOMode"                 # [<bool>] 
#Option     "CPusecTimeout"             # <i> 
#Option     "AGPMode"                   # <i> 
#Option     "AGPFastWrite"              # [<bool>] 
#Option     "AGPSize"                   # <i> 
#Option     "GARTSize"                  # <i> 
#Option     "RingSize"                  # <i> 
#Option     "BufferSize"                # <i> 
#Option     "EnableDepthMoves"          # [<bool>] 
#Option     "EnablePageFlip"            # [<bool>] 
#Option     "NoBackBuffer"              # [<bool>] 
#Option     "DRIReinit"                 # [<bool>] 
#Option     "PanelOff"                  # [<bool>] 
#Option     "DDCMode"                   # [<bool>] 
#Option     "MonitorLayout"             # [<str>] 
#Option     "IgnoreEDID"                # [<bool>] 
#Option     "OverlayOnCRTC2"            # [<bool>] 
#Option     "CloneMode"                 # [<str>] 
#Option     "CloneHSync"                # [<str>] 
#Option     "CloneVRefresh"             # [<str>] 
#Option     "UseFBDev"                  # [<bool>] 
#Option     "VideoKey"                  # <i> 
#Option     "DisplayPriority"           # [<str>] 
#Option     "PanelSize"                 # [<str>] 
#Option     "ForceMinDotClock"          # <freq> 
Identifier  "Card0" 
Option      "UseFBDev" 
Option      "AGPMode"                   "4" 
Driver      "ati" 
VendorName  "ATI Technologies Inc" 
BoardName   "Unknown Board" 
BusID       "PCI:0:16:0" 
EndSection 
 
Section "Screen" 
Identifier "Screen0" 
Device     "Card0" 
Monitor    "Monitor0" 
DefaultDepth 24 
SubSection "Display" 
Viewport   0 0 
Depth 1 
Modes   "1280x854" 
EndSubSection 
SubSection "Display" 
Viewport   0 0 
Depth 4 
Modes   "1280x854" 
EndSubSection 
SubSection "Display" 
Viewport   0 0 
Depth 8 
Modes   "1280x854" 
EndSubSection 
SubSection "Display" 
Viewport   0 0 
Depth 15 
Modes   "1280x854" 
EndSubSection 
SubSection "Display" 
Viewport   0 0 
Depth 16 
Modes   "1280x854" 
EndSubSection 
SubSection "Display" 
Viewport   0 0 
Depth 24 
Modes   "1280x854" 
EndSubSection 
EndSection 
 
Section "DRI" 
        Mode 0666 
EndSection 
 
Section "Modes" 
        Identifier      "Modes0" 
        # mode generated by Xeasyconf 
        Modeline "1280x854" 79.815 1280 1296 1408 1536  854 855 858 866  -HSync 
-VSync 
EndSection 
 
#Section "Extensions" 
# Option "Composite" "Enable" 
#EndSection
Comment 1 Douglas 2004-12-28 12:50:39 UTC
Created attachment 1601 [details]
Configuration file for one monitor.

I have also tried to simplify (I think) things by only trying to configure one
monitor, however this does not seem to be helping.
Comment 2 Douglas 2004-12-28 12:51:31 UTC
Created attachment 1602 [details]
Single Monitor configuration Log file

This is the associated log file for a single monitor configuration.
Comment 3 Adam Jackson 2005-07-02 10:26:46 UTC
if you could verify this is still an issue with a CVS snapshot, and attach a
backtrace from the server from such a crash, that would be great.
Comment 4 Adam Jackson 2005-07-03 14:46:53 UTC
starting with the 6.8.99.14 snapshot, on linux systems, the X server can print
its own backtrace when it crashes.  please confirm that these bugs are still
valid with 6.8.99.14 or later, and if they are please attach a the server log
from the crash.
Comment 5 T. Hood 2005-09-26 04:09:29 UTC

*** This bug has been marked as a duplicate of 3617 ***
Comment 6 Eric Anholt 2005-09-30 17:59:51 UTC
Doesn't appear to be a dupe of 3617 in any way.
Comment 7 T. Hood 2005-10-03 04:57:31 UTC
(In reply to comment #6)
> Doesn't appear to be a dupe of 3617 in any way.

Right.  I merged them too hastily based on the info that enabling Composite
caused the crash.
Comment 8 Erik Andren 2006-04-25 07:33:44 UTC
George, are you still experiencing this problem using a current version of xorg?
Comment 9 George Wright 2006-04-27 19:14:05 UTC
This is a while back now, but it doesn't actually show this problem anymore. 
The version of Xorg I'm on now is x11-base/xorg-x11-6.8.2-r1 (as this machine 
is running Gentoo). However, I don't have COMPOSITE enabled. I'll test it later 
with composite enabled and see whether it still crashes.
Comment 10 Erik Andren 2006-05-10 06:13:14 UTC
What's the status with COMPOSITE enabled?
Comment 11 Erik Andren 2006-05-21 02:05:58 UTC
Ping!
Comment 12 Timo Jyrinki 2007-02-22 14:27:14 UTC
Marking broken (status null/blank) bugs in xorg with no activity in a long time as fixed. Please reopen if you think it's necessary, but first do a search if a similar bug report is already filed and in a NEW/ASSIGNED state. These bugs do not currently show in most search results as they do not have any status.

Sorry for this janitorial spam, you know where to send hate mails to when your inbox gets full of bugs you're subscribed to.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.