Bug 16619 - evince and selection on rotated text
Summary: evince and selection on rotated text
Status: RESOLVED MOVED
Alias: None
Product: poppler
Classification: Unclassified
Component: general (show other bugs)
Version: unspecified
Hardware: All All
: medium normal
Assignee: poppler-bugs
QA Contact:
URL: https://bugs.launchpad.net/ubuntu/+so...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2008-07-04 13:09 UTC by Pedro Villavicencio
Modified: 2018-08-21 11:04 UTC (History)
4 users (show)

See Also:
i915 platform:
i915 features:


Attachments
Respect orientation when selecting words (7.69 KB, patch)
2014-01-28 14:26 UTC, Marek Kasik
Details | Splinter Review
reproducer showing "Invalid rectangle" error when selecting text (972 bytes, application/pdf)
2014-01-28 14:28 UTC, Marek Kasik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pedro Villavicencio 2008-07-04 13:09:21 UTC
this report has been filed here:

https://bugs.edge.launchpad.net/ubuntu/+source/poppler/+bug/245620

"When selecting rotated text in evince, it doesn't work correctly (see attached screenshot)."

http://launchpadlibrarian.net/15829551/Capture-1.png
http://launchpadlibrarian.net/15829586/m1.pdf

Thanks,
Comment 1 Marek Kasik 2014-01-28 14:26:35 UTC
Created attachment 92928 [details] [review]
Respect orientation when selecting words

Attached is a patch which improves selection of words when PDF is rotated by multiples of 90°. It sets correct bounds on various visit*() functions.

The patch doesn't solve all problems related to this. There are still problems with order of selected lines and blocks when multiple blocks are selected.

The problem with correct order of lines is easier to fix but I have not a patch ready yet. The problem with correct order of blocks is a little bit harder since it needs to correct flows.


The main problem why I started to look into this was that poppler shows this warning on some PDFs (see next attachment):

*** BUG ***
In pixman_region32_init_rect: Invalid rectangle passed
Set a breakpoint on '_pixman_log_error' to debug


Btw, the patch doesn't fix the problem shown on the Pedro's screenshot but it is related to the name of this bug.
Comment 2 Marek Kasik 2014-01-28 14:28:02 UTC
Created attachment 92929 [details]
reproducer showing "Invalid rectangle" error when selecting text
Comment 3 Christopher M. Penalver 2014-12-13 00:42:49 UTC
Problem confirmed:

1) lsb_release -rd
Description:	Ubuntu Vivid Vervet (development branch)
Release:	15.04

2) libpoppler 0.28.1-1ubuntu1 

apt-cache policy evince
evince:
  Installed: 3.14.1-0ubuntu1
  Candidate: 3.14.1-0ubuntu1
  Version table:
 *** 3.14.1-0ubuntu1 0
        500 http://us.archive.ubuntu.com/ubuntu/ vivid/main amd64 Packages
        100 /var/lib/dpkg/status

3) What is expected to happen via the attached document is that one may highlight the text that has been rotated at a 45 degree angle, one row at a time, just like Adobe Reader 10.x:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/245620/+attachment/314937/+files/m1.pdf

4) What happens instead is it highlights parts of the line, along with others, as per the attached screenshot:
https://bugs.launchpad.net/ubuntu/+source/poppler/+bug/245620/+attachment/314936/+files/Capture-1.png
Comment 4 GitLab Migration User 2018-08-21 11:04:25 UTC
-- GitLab Migration Automatic Message --

This bug has been migrated to freedesktop.org's GitLab instance and has been closed from further activity.

You can subscribe and participate further through the new bug through this link to our GitLab instance: https://gitlab.freedesktop.org/poppler/poppler/issues/499.


Use of freedesktop.org services, including Bugzilla, is subject to our Code of Conduct. How we collect and use information is described in our Privacy Policy.